summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-04-09 12:42:14 +0200
committerMichał Górny <mgorny@gentoo.org>2016-04-09 13:14:41 +0200
commitc07a10fee955bc389b8ada0db44fbd82d25397d4 (patch)
treef585bbece457ac9eaa5477f9fde530b31a31f3ff
parentmedia-gfx/gnome-photos: Fix dependencies (#579334 by ago) (diff)
downloadgentoo-c07a10fee955bc389b8ada0db44fbd82d25397d4.tar.gz
gentoo-c07a10fee955bc389b8ada0db44fbd82d25397d4.tar.bz2
gentoo-c07a10fee955bc389b8ada0db44fbd82d25397d4.zip
net-misc/aria2: Bump to 1.21.0, #579022
-rw-r--r--net-misc/aria2/Manifest1
-rw-r--r--net-misc/aria2/aria2-1.21.0.ebuild149
2 files changed, 150 insertions, 0 deletions
diff --git a/net-misc/aria2/Manifest b/net-misc/aria2/Manifest
index c5769b62c872..af146cb77965 100644
--- a/net-misc/aria2/Manifest
+++ b/net-misc/aria2/Manifest
@@ -7,3 +7,4 @@ DIST aria2-1.18.7.tar.bz2 2141933 SHA256 358bda2a7b1d5aca1acc4b528f32bd01f5db819
DIST aria2-1.18.9.tar.bz2 2151923 SHA256 e24bca91edbe8fff52615420085317ce22faec4a0a9c34843f86dbcc2a79c4b2 SHA512 6a701f23167255a8ea135c6c9455a11d0eddf007fbcc1c3af663dd98825c0812d7db0214be963a06740e60d8b6fdae92bee5062aa4864b212b959e97ac857d74 WHIRLPOOL 0996dbbcd9828e8a977275f889e14a0e5a8fc0dc5d1a05a7550542cab27de252597389a796da98590935d02a81fdf302f9d078c8c0068af0587a2437ee01e85a
DIST aria2-1.19.0.tar.bz2 2155310 SHA256 ae2b6fce7a0974c9156415cccf2395cd258580ab34eec2b34a8e76120b7240ce SHA512 ba505b45f84266543cb403752cc3592469545dea806e77bd7b7fec1fbe7ed5baf14372cf6dea840ccbdd054cd0c92cdeb4516eb52b167aca03909000f02aec95 WHIRLPOOL b13502f9dd646832799af6a0db199e87abae042c0e48b778f9b782d56d838c5b9d36bc04c487534f3fe1c59e970dc34702facc5508927325e34bcffa39946519
DIST aria2-1.19.2.tar.xz 1377356 SHA256 3605486dd495cd8c2f672b7d0b763397989d831396862f15730697ebcf0ad53e SHA512 ae3fb231fa9f989a8c4f8015d7e64db2b62b922548839a884454ef1fc6dc024363b482268200efa234ac71a1dba969aaefbeb81c811223e2e117f3adae9a8468 WHIRLPOOL 10f4ad709e26f29685b05e5db4fde687c733404a994649d4f5c5a8f66bf60142ae3bc65179db7b83766e32663100b5c7c58f1b6e4a6f6a4d2f089176604a8c95
+DIST aria2-1.21.0.tar.xz 1438608 SHA256 225c5f2c8acc899e0a802cdf198f82bd0d3282218e80cdce251b1f9ffacf6580 SHA512 2862d82f064de160b64705ee5ae9180e7402859c7c0d9bc5421b1368cebd143e0a0e2e971713cd27f11efbeffe6618e801309ff34b12aeb00060b9de58652251 WHIRLPOOL 07030ec26b002c98f8a76984bec1594b76dba404c40dbda8d4d80d682ee41ac7667c45c9fb723fa335906ebf0f462f4d2bd924ce64422a26d23d7da4ae5b62d9
diff --git a/net-misc/aria2/aria2-1.21.0.ebuild b/net-misc/aria2/aria2-1.21.0.ebuild
new file mode 100644
index 000000000000..40ee99f0865e
--- /dev/null
+++ b/net-misc/aria2/aria2-1.21.0.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit bash-completion-r1 eutils
+
+DESCRIPTION="A download utility with segmented downloading with BitTorrent support"
+HOMEPAGE="http://aria2.sourceforge.net/"
+SRC_URI="https://github.com/tatsuhiro-t/${PN}/releases/download/release-${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="adns bittorrent +gnutls jemalloc libuv +libxml2 metalink +nettle nls sqlite scripts ssh ssl tcmalloc test xmlrpc"
+
+CDEPEND="sys-libs/zlib:0=
+ ssl? (
+ app-misc/ca-certificates
+ gnutls? ( >=net-libs/gnutls-1.2.9:0= )
+ !gnutls? ( dev-libs/openssl:0= ) )
+ adns? ( >=net-dns/c-ares-1.5.0:0= )
+ bittorrent? (
+ ssl? (
+ gnutls? (
+ nettle? ( >=dev-libs/nettle-2.4:0=[gmp] >=dev-libs/gmp-5:0= )
+ !nettle? ( >=dev-libs/libgcrypt-1.2.2:0= ) ) )
+ !ssl? (
+ nettle? ( >=dev-libs/nettle-2.4:0=[gmp] >=dev-libs/gmp-5:0= )
+ !nettle? ( >=dev-libs/libgcrypt-1.2.2:0= ) ) )
+ jemalloc? ( dev-libs/jemalloc )
+ libuv? ( dev-libs/libuv:0= )
+ metalink? (
+ libxml2? ( >=dev-libs/libxml2-2.6.26:2= )
+ !libxml2? ( dev-libs/expat:0= ) )
+ sqlite? ( dev-db/sqlite:3= )
+ ssh? ( net-libs/libssh2:= )
+ tcmalloc? ( dev-util/google-perftools )
+ xmlrpc? (
+ libxml2? ( >=dev-libs/libxml2-2.6.26:2= )
+ !libxml2? ( dev-libs/expat:0= ) )"
+
+DEPEND="${CDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? ( >=dev-util/cppunit-1.12.0:0 )"
+RDEPEND="${CDEPEND}
+ nls? ( virtual/libiconv virtual/libintl )
+ scripts? ( dev-lang/ruby )"
+
+REQUIRED_USE="jemalloc? ( !tcmalloc )
+ tcmalloc? ( !jemalloc )"
+
+pkg_setup() {
+ if use scripts && use !xmlrpc && use !metalink; then
+ ewarn "Please note that you may need to enable USE=xmlrpc to run the aria2rpc"
+ ewarn "and aria2mon scripts against the local aria2."
+ fi
+}
+
+src_prepare() {
+ epatch_user
+ sed -i -e "s|/tmp|${T}|" test/*.cc test/*.txt || die "sed failed"
+}
+
+src_configure() {
+ local myconf=(
+ # threads, epoll: check for best portability
+
+ # do not try to compile and run a test LIBXML program
+ --disable-xmltest
+ # enable the shared library
+ --enable-libaria2
+ # zlib should always be available anyway
+ --with-libz
+ --with-ca-bundle="${EPREFIX}/etc/ssl/certs/ca-certificates.crt"
+
+ # optional features
+ $(use_enable bittorrent)
+ $(use_enable metalink)
+ $(use_enable nls)
+ $(use_with sqlite sqlite3)
+ $(use_with adns libcares)
+ $(use_with libuv)
+ $(use_with jemalloc)
+ $(use_with tcmalloc)
+ )
+
+ # SSL := gnutls / openssl
+ # USE=ssl
+ # + USE=gnutls -> gnutls
+ # + USE=-gnutls -> openssl
+
+ if use ssl; then
+ myconf+=( $(use_with gnutls) $(use_with !gnutls openssl) )
+ else
+ myconf+=( --without-gnutls --without-openssl )
+ fi
+
+ # message-digest := nettle / gcrypt / openssl
+ # bignum := nettle+gmp / gcrypt / openssl
+ # bittorrent := message-digest + bignum
+ # USE=bittorrent
+ # + USE=(ssl -gnutls) -> openssl
+ # + USE=nettle -> nettle+gmp
+ # + USE=-nettle -> gcrypt
+
+ if use !bittorrent || use ssl && use !gnutls; then
+ myconf+=( --without-libgcrypt --without-libnettle --without-libgmp )
+ else
+ myconf+=( $(use_with !nettle libgcrypt)
+ $(use_with nettle libnettle) $(use_with nettle libgmp) )
+ fi
+
+ # metalink+xmlrpc := libxml2 / expat
+ # USE=(metalink || xmlrpc)
+ # + USE=libxml2 -> libxml2
+ # + USE=-libxml2 -> expat
+
+ if use metalink || use xmlrpc; then
+ myconf+=( $(use_with !libxml2 libexpat) $(use_with libxml2) )
+ else
+ myconf+=( --without-libexpat --without-libxml2 )
+ fi
+
+ # Note:
+ # - always enable gzip/http compression since zlib should always be available anyway
+ # - always enable epoll since we can assume kernel 2.6.x
+ # - other options for threads: solaris, pth, win32
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ rm -rf "${D}"/usr/share/doc/aria2 \
+ "${D}"/usr/share/doc/${PF}/README{,.html}
+
+ dobashcomp doc/bash_completion/aria2c
+ use scripts && dobin doc/xmlrpc/aria2{mon,rpc}
+}
+
+pkg_postinst() {
+ if use xmlrpc || use metalink; then
+ elog "If you would like to use the additional aria2mon and aria2rpc tools,"
+ elog "you need to have \033[1mdev-lang/ruby\033[0m installed."
+ fi
+}