summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2022-09-07 09:24:24 +0800
committerYixun Lan <dlan@gentoo.org>2022-09-07 09:24:24 +0800
commitc0a7889115890bfc1011568bc20381cd77f24e69 (patch)
tree1ed1931deba7398560461524e3e514d9464f2d19
parentapp-crypt/gnupg: Stabilize 2.2.39 sparc, #868942 (diff)
downloadgentoo-c0a78891.tar.gz
gentoo-c0a78891.tar.bz2
gentoo-c0a78891.zip
app-i18n/ibus: fix not byte-compiled issue
Closes: https://bugs.gentoo.org/868699 Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--app-i18n/ibus/ibus-1.5.27.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/app-i18n/ibus/ibus-1.5.27.ebuild b/app-i18n/ibus/ibus-1.5.27.ebuild
index 65119041410e..57b8aa524735 100644
--- a/app-i18n/ibus/ibus-1.5.27.ebuild
+++ b/app-i18n/ibus/ibus-1.5.27.ebuild
@@ -184,6 +184,12 @@ src_test() {
src_install() {
default
+ # Remove la files
+ find "${ED}" -name '*.la' -delete || die
+
+ # Remove stray python files generated by the build system
+ find "${ED}" -name '*.pyc' -exec rm -f {} \; || die
+ find "${ED}" -name '*.pyo' -exec rm -f {} \; || die
if use python; then
python_install() {
@@ -206,13 +212,6 @@ src_install() {
# Undo compression of man page
find "${ED}"/usr/share/man -type f -name '*.gz' -exec gzip -d {} \; || die
-
- # Remove stray python files generated by the build system
- find "${ED}" -name '*.pyc' -exec rm -f {} \; || die
- find "${ED}" -name '*.pyo' -exec rm -f {} \; || die
-
- # Remove la files
- find "${ED}" -name '*.la' -delete || die
}
pkg_postinst() {