summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-08-27 12:49:45 -0400
committerCraig Andrews <candrews@gentoo.org>2020-08-27 12:49:45 -0400
commitc0c1d322aae1744982fc5fa2ae6c8cc545db97f1 (patch)
tree98a94a5e130ae4c5b4131e56762f79510f3e9825
parentsys-devel/llvm-roc: Restore accidentally deleted patch (diff)
downloadgentoo-c0c1d322aae1744982fc5fa2ae6c8cc545db97f1.tar.gz
gentoo-c0c1d322aae1744982fc5fa2ae6c8cc545db97f1.tar.bz2
gentoo-c0c1d322aae1744982fc5fa2ae6c8cc545db97f1.zip
app-arch/brotli: 1.0.9 version bump
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--app-arch/brotli/Manifest1
-rw-r--r--app-arch/brotli/brotli-1.0.9.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/app-arch/brotli/Manifest b/app-arch/brotli/Manifest
index 98f703dc3325..5f8398009268 100644
--- a/app-arch/brotli/Manifest
+++ b/app-arch/brotli/Manifest
@@ -1,2 +1,3 @@
DIST brotli-1.0.6.tar.gz 23827656 BLAKE2B 8d31eb1c4119de44702f2239fba9db72f1ae81801d06e51716432ff2f8aa78259c52cbd57b8fcd005c1bc14ada81b6e47a35c5d3864bb10bb02d113e30bd321b SHA512 b9847375471de3ae815ef4bb45a29653c343fad0a891a79d5132fcdee34c85caafd82289c8b413c3ef609049f2e8c4af9f9abd1736a2408ba44544c5fefc0010
DIST brotli-1.0.7.tar.gz 23827908 BLAKE2B b9fc554cd23c8387b648638b6f9bb2d29fa87035856d03cf284662f9281984f3bf8e40109e61155ece18673f4391bc0fff704f8ab800a2041d3ce1824478d2ae SHA512 a82362aa36d2f2094bca0b2808d9de0d57291fb3a4c29d7c0ca0a37e73087ec5ac4df299c8c363e61106fccf2fe7f58b5cf76eb97729e2696058ef43b1d3930a
+DIST brotli-1.0.9.tar.gz 486984 BLAKE2B 8b9939d5224396ef33b43e019250ba4bc8949903583615e8dc02c85340fc0a1e2d1632161e00b0ee7355d77f05529ac772f482e05d2089afd71a0bf71e803904 SHA512 b8e2df955e8796ac1f022eb4ebad29532cb7e3aa6a4b6aee91dbd2c7d637eee84d9a144d3e878895bb5e62800875c2c01c8f737a1261020c54feacf9f676b5f5
diff --git a/app-arch/brotli/brotli-1.0.9.ebuild b/app-arch/brotli/brotli-1.0.9.ebuild
new file mode 100644
index 000000000000..89d52f2c2ec4
--- /dev/null
+++ b/app-arch/brotli/brotli-1.0.9.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_OPTIONAL="1"
+DISTUTILS_IN_SOURCE_BUILD="1"
+
+inherit cmake-multilib distutils-r1
+
+DESCRIPTION="Generic-purpose lossless compression algorithm"
+HOMEPAGE="https://github.com/google/brotli"
+
+SLOT="0/$(ver_cut 1)"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+
+IUSE="python test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+LICENSE="MIT python? ( Apache-2.0 )"
+
+DOCS=( README.md CONTRIBUTING.md )
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/google/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+ SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ use python && distutils-r1_src_prepare
+ cmake-utils_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ )
+ cmake-utils_src_configure
+}
+src_configure() {
+ cmake-multilib_src_configure
+ use python && distutils-r1_src_configure
+}
+
+multilib_src_compile() {
+ cmake-utils_src_compile
+}
+src_compile() {
+ cmake-multilib_src_compile
+ use python && distutils-r1_src_compile
+}
+
+python_test() {
+ esetup.py test || die
+}
+
+multilib_src_test() {
+ cmake-utils_src_test
+}
+src_test() {
+ cmake-multilib_src_test
+ use python && distutils-r1_src_test
+}
+
+multilib_src_install() {
+ cmake-utils_src_install
+}
+multilib_src_install_all() {
+ use python && distutils-r1_src_install
+}