summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-03-05 08:45:35 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2021-03-05 08:45:35 +0100
commitc0c202f8b5e162c4bed69722e1f00e705e68be97 (patch)
tree4916615c9800b39b2a2b0b8d5e5a57a24b89f834
parentwww-client/surfraw: x86 stable wrt bug #772050 (diff)
downloadgentoo-c0c202f8.tar.gz
gentoo-c0c202f8.tar.bz2
gentoo-c0c202f8.zip
www-apps/postfixadmin: bump to 3.3.8
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--www-apps/postfixadmin/Manifest1
-rw-r--r--www-apps/postfixadmin/postfixadmin-3.3.8.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/www-apps/postfixadmin/Manifest b/www-apps/postfixadmin/Manifest
index 65447f19db34..e2062be71ac2 100644
--- a/www-apps/postfixadmin/Manifest
+++ b/www-apps/postfixadmin/Manifest
@@ -1,3 +1,4 @@
DIST postfixadmin-3.2.4.tar.gz 1331185 BLAKE2B a16df15f6376f9024114c5870174168e5f3d4b0f52d8759db0d83cb4c05fbbe2949056de0ca5ce097652588b777d59f08bcc2555577c95fbd7f2ebc5dd7f357f SHA512 2bd7ae05addbaf3c6c7eebea16ec1e21b2c67c8e6161446ed82a9553c26c04e19c1ec9ce248a9b9df504df56d309590259e6f04907b04b593548028b40e40d47
DIST postfixadmin-3.3.5.tar.gz 1857139 BLAKE2B f6e051e8439a5bc4a2145fa58219d3e92f9599923a8b9380db2e1a241cbcca03c6cec893a63de78329f78633cd97e09ab08cc4179667629e7ef77687d2a6d752 SHA512 1db7dd42335d1704501f2491ceed3f0ecb3063a1df4b6487a1f1aac397f658e3479e4ccbc374b3e2f854f90406c1465a68579b1bd9a98386dbd6dda6b22d94c5
DIST postfixadmin-3.3.7.tar.gz 1858520 BLAKE2B 5da2663fe6c445828118cb4531cbb7ca8a0a81b2d4997b71fe1a39dc25031ec3b1ead393dd3dbbef80d139c1518d172b1937a052a15a0a43dfb6bd6f693bee5b SHA512 c635b885235f2683532ff4fcd6d3e123fa5af8314cfcdbcdf412d7242444bb9c040a6eeb2f6b0669b9f5dd9fc56c53127779727768c68699885cc642717453ca
+DIST postfixadmin-3.3.8.tar.gz 1865581 BLAKE2B f8b29248e839d973fd72647747e0bba7452676543f44310f12203d5e64e83222a3992e282a3898fa077dc54100b3446e4d1cded56cd464d72b2997ce34f064db SHA512 bfe5d874083568f1e8b1830394338d2aa29e39e30834d4c8c728836495f12f6d49c65b83b1fae1fce20e7456afaef0058320033866b720a5858911ceec22a022
diff --git a/www-apps/postfixadmin/postfixadmin-3.3.8.ebuild b/www-apps/postfixadmin/postfixadmin-3.3.8.ebuild
new file mode 100644
index 000000000000..0df1b6d26679
--- /dev/null
+++ b/www-apps/postfixadmin/postfixadmin-3.3.8.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit user webapp
+
+DESCRIPTION="Web Based Management tool for Postfix style virtual domains and users"
+HOMEPAGE="http://postfixadmin.sourceforge.net"
+SRC_URI="https://github.com/postfixadmin/postfixadmin/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+mysql postgres +vacation"
+REQUIRED_USE="|| ( mysql postgres )"
+
+DEPEND="
+ dev-lang/php:*[unicode,imap,postgres?]
+ vacation? (
+ dev-perl/DBI
+ dev-perl/Email-Sender
+ dev-perl/Email-Valid
+ dev-perl/Log-Dispatch
+ dev-perl/Log-Log4perl
+ dev-perl/MIME-Charset
+ dev-perl/MIME-EncWords
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )
+ )
+"
+RDEPEND="${DEPEND}
+ virtual/httpd-php
+ mysql? ( || ( dev-lang/php[mysqli] dev-lang/php[mysql] ) )"
+
+S="${WORKDIR}/${PN}-${P}"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if use vacation; then
+ enewgroup vacation
+ enewuser vacation -1 -1 -1 vacation
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ if use vacation; then
+ insinto /var/spool/vacation
+ newins VIRTUAL_VACATION/vacation.pl vacation.pl-${SLOT}
+ fowners vacation:vacation /var/spool/vacation/vacation.pl-${SLOT}
+ fperms 770 /var/spool/vacation/vacation.pl-${SLOT}
+ dodoc VIRTUAL_VACATION/FILTER_README
+ newdoc VIRTUAL_VACATION/INSTALL.md VIRTUAL_VACATION_INSTALL.md
+ rm -r VIRTUAL_VACATION/{vacation.pl,INSTALL.md,tests,FILTER_README} || die
+ fi
+
+ docinto /usr/share/doc/${PF}/
+ dodoc -r ADDITIONS
+
+ local docs="DOCUMENTS/*.txt INSTALL.TXT CHANGELOG.TXT"
+ dodoc ${docs}
+
+ rm -rf ${docs} DOCUMENTS/ GPL-LICENSE.TXT LICENSE.TXT debian/ tests/ ADDITIONS/
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.inc.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-2.3.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ einfo "Please note that if upgrading from version prior to 3.3.0,"
+ einfo "existing setup_password will no longer work and you will"
+ einfo "need to generate new one. See instructions in setup.php."
+
+ if use vacation; then
+ # portage does not update owners of directories (feature :)
+ chown vacation:vacation "${ROOT}"/var/spool/vacation/
+ einfo
+ einfo "/var/spool/vacation/vacation.pl symlink was updated to:"
+ einfo "/var/spool/vacation/vacation.pl-${SLOT}"
+ ln -sf "${ROOT}"/var/spool/vacation/vacation.pl{-${SLOT},} || die
+ fi
+}
+
+pkg_postrm() {
+ # Make sure we don't leave broken vacation.pl symlink
+ find -L "${ROOT}"/var/spool/vacation/ -type l -delete
+ local shopt_save=$(shopt -p nullglob)
+ shopt -s nullglob
+ local vacation=( "${ROOT}"/var/spool/vacation/vacation.pl-* )
+ ${shopt_save}
+ if [[ ! -e "${ROOT}"/var/spool/vacation/vacation.pl && -n ${vacation[@]} ]]; then
+ ln -s "${vacation[-1]}" "${ROOT}"/var/spool/vacation/vacation.pl || die
+ ewarn "/var/spool/vacation/vacation.pl was updated to point on most"
+ ewarn "recent verion, but please, do your own checks"
+ fi
+}