summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-17 04:19:41 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-17 04:30:58 +0100
commitc0d5596f0a1c95b8d184ca65460c99b656b5ecd7 (patch)
tree10defcb3ef4a1ec3122888c469e290a86f86fb10
parentdev-python/versioningit: Bump to 3.1.0 (diff)
downloadgentoo-c0d5596f0a1c95b8d184ca65460c99b656b5ecd7.tar.gz
gentoo-c0d5596f0a1c95b8d184ca65460c99b656b5ecd7.tar.bz2
gentoo-c0d5596f0a1c95b8d184ca65460c99b656b5ecd7.zip
dev-python/paste: Bump to 3.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/paste/Manifest1
-rw-r--r--dev-python/paste/paste-3.8.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/paste/Manifest b/dev-python/paste/Manifest
index 9b21b0216aa8..43bf12bbf36e 100644
--- a/dev-python/paste/Manifest
+++ b/dev-python/paste/Manifest
@@ -1 +1,2 @@
DIST Paste-3.7.1.tar.gz 639191 BLAKE2B 5c36794e0d0aba9396a621933bfc2b600da5c951a6aed39ebcea8a1ad84449556a94bbf13651fe28c0886f826417ee0dfe6b82ad76c4956579b0a5795539ae3d SHA512 672f0476582b0c0f65a049800fbd23f7df2c62b405ed1b803474715a80d532bbf117558b201329967bf83f4c88c8740e5f626ff5c2dafa3eade04fccefd332b0
+DIST Paste-3.8.0.tar.gz 636922 BLAKE2B 4952eb6a8c59d0ed653ba9b74cb55fbf0c5a32fa298fc2e6a8c7beb10c4f0a35a82b9e30ca7bf8612f6ae4f4e6e4124974b49ee8f268fc95d15f8f619e3e8222 SHA512 88e21b3a00f7f871292d4c098b1e8c1c5331c9e28a297ca37a40551d11a2f086e6ddedb6ba1a9ec92b9d20c6584703e6ed1e84d236fcaf0378b15729360c52bd
diff --git a/dev-python/paste/paste-3.8.0.ebuild b/dev-python/paste/paste-3.8.0.ebuild
new file mode 100644
index 000000000000..a9c43ec6b2f2
--- /dev/null
+++ b/dev-python/paste/paste-3.8.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
+HOMEPAGE="
+ https://pythonpaste.readthedocs.io/en/latest/
+ https://github.com/cdent/paste/
+ https://pypi.org/project/Paste/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ !dev-python/namespace-paste
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/test_proxy.py
+ )
+
+ [[ ${EPYTHON} == python3.1[12] ]] && EPYTEST_DESELECT+=(
+ # fails due to cgi deprecation warning
+ tests/test_cgiapp.py::test_form
+ )
+
+ epytest
+}