summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-02 23:56:12 +0000
committerSam James <sam@gentoo.org>2021-12-02 23:56:12 +0000
commitc0ddacd19291a5c92245feacc7887921e10a697f (patch)
tree513a0726eda684aebc77d29bbd410558133fe09c
parentsys-libs/libunwind: add 1.6.2 (diff)
downloadgentoo-c0ddacd19291a5c92245feacc7887921e10a697f.tar.gz
gentoo-c0ddacd19291a5c92245feacc7887921e10a697f.tar.bz2
gentoo-c0ddacd19291a5c92245feacc7887921e10a697f.zip
sys-libs/libunwind: drop 1.6.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-libs/libunwind/Manifest1
-rw-r--r--sys-libs/libunwind/files/libunwind-1.6.0-avoid-bashisms-in-configure.patch21
-rw-r--r--sys-libs/libunwind/libunwind-1.6.0.ebuild100
3 files changed, 0 insertions, 122 deletions
diff --git a/sys-libs/libunwind/Manifest b/sys-libs/libunwind/Manifest
index 7634e7a03c51..2cf810467cc0 100644
--- a/sys-libs/libunwind/Manifest
+++ b/sys-libs/libunwind/Manifest
@@ -1,3 +1,2 @@
DIST libunwind-1.5.0.tar.gz 878355 BLAKE2B ee35441289926ac22a58bedb9f831d8e13bacd663a99b3ce25eed229f25f0423bbbd90e09e3d62b003518d7a620aa6d15b0dd5b93632736a89fa0667b35d5fc2 SHA512 1df20ca7a8cee2f2e61294fa9b677e88fec52e9d5a329f88d05c2671c69fa462f6c18808c97ca9ff664ef57292537a844f00b18d142b1938c9da701ca95a4bab
-DIST libunwind-1.6.0.tar.gz 901221 BLAKE2B 360275931399a1cd931e4680f404eff369c9e924d95797d91b61852ab49af2acb2c42ddb9fef72e1e2f39a1bddb6767f7b5f9ba56e27fa581f73db9e3f1168e4 SHA512 89f6355134a3c3175c23fe1a44600d61f15e2533e6816286ad39f799d48f7abdcc03ea354aa1aed859cf277c24e475bc7e625c90b1dc0b69921d03dd1f160464
DIST libunwind-1.6.2.tar.gz 901392 BLAKE2B 3d0313f7e92cbc3e1a84ad3831a5170f21cdf772f1697ca0a59dea63cdd47da382e9f1fd77325d9ff8bcd47559a425dc883a820c646c628cd00faed82cb0f83f SHA512 1d17dfb14f99a894a6cda256caf9ec481c14068aaf8f3a85fa3befa7c7cca7fca0f544a91a3a7c2f2fc55bab19b06a67ca79f55ac9081151d94478c7f611f8f7
diff --git a/sys-libs/libunwind/files/libunwind-1.6.0-avoid-bashisms-in-configure.patch b/sys-libs/libunwind/files/libunwind-1.6.0-avoid-bashisms-in-configure.patch
deleted file mode 100644
index 16fd593c3c1a..000000000000
--- a/sys-libs/libunwind/files/libunwind-1.6.0-avoid-bashisms-in-configure.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-https://github.com/libunwind/libunwind/pull/315
---- a/configure.ac
-+++ b/configure.ac
-@@ -136,7 +136,7 @@ AC_MSG_RESULT([$enable_ptrace])
-
- AC_ARG_ENABLE(setjmp,
- AS_HELP_STRING([--enable-setjmp],[building libunwind-setjmp library]),,
-- [AS_IF([test x$target_arch == x$host_arch], [enable_setjmp=yes], [enable_setjmp=no])]
-+ [AS_IF([test x$target_arch = x$host_arch], [enable_setjmp=yes], [enable_setjmp=no])]
- )
-
- AC_ARG_ENABLE(documentation,
-@@ -261,7 +261,7 @@ case "${target_arch}" in
- (aarch64) enable_debug_frame=yes;;
- (*) enable_debug_frame=no;;
- esac])
--if test x$remote_only == xyes; then
-+if test x$remote_only = xyes; then
- enable_debug_frame=no
- fi
- if test x$enable_debug_frame = xyes; then
diff --git a/sys-libs/libunwind/libunwind-1.6.0.ebuild b/sys-libs/libunwind/libunwind-1.6.0.ebuild
deleted file mode 100644
index 9a82c45d2b02..000000000000
--- a/sys-libs/libunwind/libunwind-1.6.0.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 2005-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PV=${PV/_/-}
-MY_P=${PN}-${MY_PV}
-inherit autotools multilib-minimal
-
-DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
-HOMEPAGE="https://savannah.nongnu.org/projects/libunwind"
-SRC_URI="mirror://nongnu/libunwind/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0/8" # libunwind.so.8
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv -sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug debug-frame doc libatomic lzma static-libs test zlib"
-
-RESTRICT="test !test? ( test )" # some tests are broken (toolchain version dependent, rely on external binaries)
-
-# We just use the header from libatomic.
-RDEPEND="
- lzma? ( app-arch/xz-utils[static-libs?,${MULTILIB_USEDEP}] )
- zlib? ( sys-libs/zlib[static-libs?,${MULTILIB_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- libatomic? ( dev-libs/libatomic_ops[${MULTILIB_USEDEP}] )"
-
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/libunwind.h
-
- # see libunwind.h for the full list of arch-specific headers
- /usr/include/libunwind-aarch64.h
- /usr/include/libunwind-arm.h
- /usr/include/libunwind-hppa.h
- /usr/include/libunwind-ia64.h
- /usr/include/libunwind-mips.h
- /usr/include/libunwind-ppc32.h
- /usr/include/libunwind-ppc64.h
- /usr/include/libunwind-riscv.h
- /usr/include/libunwind-sh.h
- /usr/include/libunwind-tilegx.h
- /usr/include/libunwind-x86.h
- /usr/include/libunwind-x86_64.h
-)
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.6.0-avoid-bashisms-in-configure.patch
-)
-
-src_prepare() {
- default
-
- chmod +x src/ia64/mk_cursor_i || die
-
- eautoreconf
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- # --enable-cxx-exceptions: always enable it, headers provide the interface
- # and on some archs it is disabled by default causing a mismatch between the
- # API and the ABI, bug #418253
- --enable-cxx-exceptions
- --enable-coredump
- --enable-ptrace
- --enable-setjmp
- $(use_enable debug-frame)
- $(use_enable doc documentation)
- $(use_enable lzma minidebuginfo)
- $(use_enable static-libs static)
- $(use_enable zlib zlibdebuginfo)
- # conservative-checks: validate memory addresses before use; as of 1.0.1,
- # only x86_64 supports this, yet may be useful for debugging, couple it with
- # debug useflag.
- $(use_enable debug conservative_checks)
- $(use_enable debug)
- $(use_enable test tests)
- )
-
- export ac_cv_header_atomic_ops_h=$(usex libatomic)
-
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_compile() {
- # bug #586208
- CCACHE_NODIRECT=1 default
-}
-
-multilib_src_test() {
- # Explicitly allow parallel build of tests.
- # Sandbox causes some tests to freak out.
- SANDBOX_ON=0 emake check
-}
-
-multilib_src_install_all() {
- find "${ED}" -name "*.la" -type f -delete || die
-}