summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-10-30 21:41:22 -0400
committerMike Frysinger <vapier@gentoo.org>2015-10-30 21:41:22 -0400
commitc0e9a7cf42c7bf4abae02b2ee0441244e01de9f6 (patch)
tree37eb8f0e1fb98e160f02e076a12da40ee481ec45
parentdev-libs/libevent: re-add m68k love (diff)
downloadgentoo-c0e9a7cf.tar.gz
gentoo-c0e9a7cf.tar.bz2
gentoo-c0e9a7cf.zip
dev-libs/libxml2: disable building of useless programs
These aren't used during build or install, so disable them.
-rw-r--r--dev-libs/libxml2/files/libxml2-2.9.2-disable-tests.patch59
-rw-r--r--dev-libs/libxml2/libxml2-2.9.2-r1.ebuild3
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/libxml2/files/libxml2-2.9.2-disable-tests.patch b/dev-libs/libxml2/files/libxml2-2.9.2-disable-tests.patch
new file mode 100644
index 000000000000..86d5995138a1
--- /dev/null
+++ b/dev-libs/libxml2/files/libxml2-2.9.2-disable-tests.patch
@@ -0,0 +1,59 @@
+do not build test programs as we don't install them
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -10,7 +10,7 @@
+
+ AM_CFLAGS = $(THREAD_CFLAGS) $(Z_CFLAGS) $(LZMA_CFLAGS)
+
+-noinst_PROGRAMS=testSchemas testRelax testSAX testHTML testXPath testURI \
++check_PROGRAMS=testSchemas testRelax testSAX testHTML testXPath testURI \
+ testThreads testC14N testAutomata testRegexp \
+ testReader testapi testModule runtest runsuite testchar \
+ testdict runxmlconf testrecurse testlimits
+@@ -170,7 +170,7 @@
+ testModule_DEPENDENCIES = $(DEPS)
+ testModule_LDADD= $(LDADDS)
+
+-noinst_LTLIBRARIES = testdso.la
++check_LTLIBRARIES = testdso.la
+ testdso_la_SOURCES = testdso.c
+ testdso_la_LDFLAGS = -module -no-undefined -avoid-version -rpath $(libdir)
+
+--- a/doc/examples/Makefile.am
++++ b/doc/examples/Makefile.am
+@@ -13,7 +13,7 @@
+ rebuild: examples.xml index.html
+ .PHONY: rebuild
+
+-examples.xml: index.py $(noinst_PROGRAMS:=.c)
++examples.xml: index.py $(check_PROGRAMS:=.c)
+ cd $(srcdir) && $(PYTHON) index.py
+ $(MAKE) Makefile
+
+@@ -49,7 +49,7 @@
+ xpath1.res \
+ xpath2.res
+
+-noinst_PROGRAMS = \
++check_PROGRAMS = \
+ io1 \
+ io2 \
+ parse1 \
+@@ -99,7 +99,7 @@
+ valgrind:
+ $(MAKE) CHECKER='valgrind' tests
+
+-tests: $(noinst_PROGRAMS)
++tests: $(check_PROGRAMS)
+ test -f Makefile.am || test -f test1.xml || $(LN_S) $(srcdir)/test?.xml .
+ @(echo '## examples regression tests')
+ @(echo > .memdump)
+--- a/example/Makefile.am
++++ b/example/Makefile.am
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = gjobread
++check_PROGRAMS = gjobread
+
+ AM_CPPFLAGS = -I$(top_builddir)/include -I$(top_srcdir)/include -I$(srcdir)/include
+ AM_CFLAGS = $(THREAD_CFLAGS) $(Z_CFLAGS)
diff --git a/dev-libs/libxml2/libxml2-2.9.2-r1.ebuild b/dev-libs/libxml2/libxml2-2.9.2-r1.ebuild
index a03df2448aaf..99c6b6c2e4c2 100644
--- a/dev-libs/libxml2/libxml2-2.9.2-r1.ebuild
+++ b/dev-libs/libxml2/libxml2-2.9.2-r1.ebuild
@@ -75,6 +75,9 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-2.7.1-catalog_path.patch
epatch "${FILESDIR}"/${PN}-2.8.0_rc1-winnt.patch
+ # Disable programs that we don't actually install.
+ epatch "${FILESDIR}"/${PN}-2.9.2-disable-tests.patch
+
eprefixify catalog.c xmlcatalog.c runtest.c xmllint.c
# epunt_cxx # if we don't eautoreconf