summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2018-01-19 13:25:22 -0800
committerBrian Dolbec <dolsen@gentoo.org>2018-01-19 14:55:34 -0800
commitc10013f6b4d797a3fc9f60c10101413a75195ad2 (patch)
treedca24e0623c14ff8b952591cd734b0b8577292c2
parentdev-python/hyperlink: Version bump (diff)
downloadgentoo-c10013f6b4d797a3fc9f60c10101413a75195ad2.tar.gz
gentoo-c10013f6b4d797a3fc9f60c10101413a75195ad2.tar.bz2
gentoo-c10013f6b4d797a3fc9f60c10101413a75195ad2.zip
dev-python/autobahn: Version bump
Package-Manager: Portage-2.3.16, Repoman-2.3.6
-rw-r--r--dev-python/autobahn/Manifest1
-rw-r--r--dev-python/autobahn/autobahn-17.10.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/autobahn/Manifest b/dev-python/autobahn/Manifest
index 1327ebc2d480..60f7cff98500 100644
--- a/dev-python/autobahn/Manifest
+++ b/dev-python/autobahn/Manifest
@@ -1,4 +1,5 @@
DIST autobahn-0.9.4-2.zip 175894 BLAKE2B 6b1ffea7d77968e4e4787b321c12434821fef6c6f4c84cb2bf9bfa2fdb9ff3438080609b825f976671a2cad16203be9efc0f7fe70ce7f5bef96576c1ced02b7c SHA512 7e0d4246b8b1c552b25c2ae36f1923ed9931e3d3ca684039a422773fecd92ca04734a0b24394a9bbc787f245c72b5552522351a7c1c8e500128e7c46c740a3d5
+DIST autobahn-17.10.1.tar.gz 212093 BLAKE2B 1505097dee07025c5433645397bb52807dbd67559b628ee80735a49f8e085e9c8433fbd453a4d001996dd5aee715c9278b9932e8fbb65ecd6458b6b4bd4a804d SHA512 f26c1c88bea325136f640420ada0fc70e82397ed660056c18f68a2193f069c5fb5771ac620db1583f8c7938e804726d8885d237c925c4bd38d1a613a6aabc219
DIST autobahn-17.5.1.tar.gz 205144 BLAKE2B a026381330d062059f23bd0fe20de12bf227fec45c816ce41a05d81951a2cb263e70ec3a5cee265ea3cc1f6910975903b493a767dce64c5bbb13be077561cabd SHA512 904f8f4c527a6c1c7840ea8634d0c0a47141458500c6d29f4aa1f05ff51f91c65a451b7c447201cbdf5e255c4c2d07509efa106790217b09398e7d50c1d85382
DIST autobahn-17.9.1.tar.gz 209230 BLAKE2B 4e637ee22fe84c51b294faa853034b65e5bc7b230d1d80eea022a2e3809a7ff0c9ffee7c13886f154efffdcdedf5c790e5891466107670c3221a5c7b5de846ea SHA512 036508c1170f53b01be360083bbf9f569fbaf216d984b34e10ad18e5f5e156e74bd4c8979bdd977a8e23deff0332e16d3d606716d32f3987ff37c7707eac0f86
DIST autobahn-17.9.2.tar.gz 209442 BLAKE2B 66d31a575d980d81ecd50d9511ed49b947a568ce5457db2de7fd67a85ae06016bacff10f65b74f43c2b72b21543ddb8c0d527f6b9ece706c67adb96860435232 SHA512 de73a4cc99616802d280887ef8a9971c532f974dd43cda933da953d7bcc45da3fd9d0c91763c6a80371f582f0acc9741134b1ba1b98035ef0f63e4971aaff79f
diff --git a/dev-python/autobahn/autobahn-17.10.1.ebuild b/dev-python/autobahn/autobahn-17.10.1.ebuild
new file mode 100644
index 000000000000..96be8246b797
--- /dev/null
+++ b/dev-python/autobahn/autobahn-17.10.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 versionator
+
+MY_P="${PN}-$(replace_version_separator 3 -)"
+
+DESCRIPTION="WebSocket and WAMP for Twisted and Asyncio"
+HOMEPAGE="https://pypi.python.org/pypi/autobahn http://autobahn.ws/python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="crypt test"
+
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-python/trollius-2.0[${PYTHON_USEDEP}]' 'python2_7')
+ $(python_gen_cond_dep '>=dev-python/futures-3.0.4[${PYTHON_USEDEP}]' 'python2_7')
+ >=dev-python/cbor-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/lz4-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/py-ubjson-0.8.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/snappy-0.5[${PYTHON_USEDEP}]
+ >=dev-python/twisted-16.6.0-r2[${PYTHON_USEDEP}]
+ >=dev-python/txaio-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/u-msgpack-2.1[${PYTHON_USEDEP}]
+ >=dev-python/wsaccel-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-3.6[${PYTHON_USEDEP}]
+ crypt? (
+ >=dev-python/pyopenssl-16.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytrie-0.2[${PYTHON_USEDEP}]
+ >=dev-python/pyqrcode-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/service_identity-16.0.0
+ )
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytrie-0.2[${PYTHON_USEDEP}]
+ >=dev-python/pyqrcode-1.1.0[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}"/${MY_P}
+
+python_test() {
+ #esetup.py test
+ cd "${BUILD_DIR}"/lib || die
+ py.test -v || die
+}
+
+pkg_postinst() {
+ python_foreach_impl twisted-regen-cache || die
+}
+
+pkg_postrm() {
+ python_foreach_impl twisted-regen-cache || die
+}