summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-05-07 12:18:41 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-05-07 12:21:48 +0100
commitc10e2e859c8cc839af691d217b9f7fc7d04205e2 (patch)
tree03f90c8d3f2ea3bfc90ad9f462c8a9dacdecd67d
parentdev-tex/biber: amd64 stable wrt bug #611984 (diff)
downloadgentoo-c10e2e85.tar.gz
gentoo-c10e2e85.tar.bz2
gentoo-c10e2e85.zip
sys-apps/nix: bump up to 1.11.9
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--sys-apps/nix/Manifest1
-rw-r--r--sys-apps/nix/nix-1.11.9.ebuild129
2 files changed, 130 insertions, 0 deletions
diff --git a/sys-apps/nix/Manifest b/sys-apps/nix/Manifest
index 6808aa2c57a1..72e08a2e364b 100644
--- a/sys-apps/nix/Manifest
+++ b/sys-apps/nix/Manifest
@@ -1,2 +1,3 @@
DIST nix-1.11.6.tar.xz 621796 SHA256 e729d55a9276756108a56bc1cbe2e182ee2e4be2b59b1c77d5f0e3edd879b2a3 SHA512 a2d9eed52d6791e0649e3e456c8751ab3055573def110ffbf9645d2106313adf6c3868c0ecd69e5ba95c7a742c6fb92f69722adf7381584f7c2c4efe4b400d65 WHIRLPOOL 262ce049d9cf616aaa4d5bd612accee827f04b684d1ee36b3b63bfc2004fb9d1f19e1455196183fc259b81913d318acb519fa79271b4915369780efb8f02200b
DIST nix-1.11.8.tar.xz 622744 SHA256 69e0f398affec2a14c47b46fec712906429c85312d5483be43e4c34da4f63f67 SHA512 4a5031625ab459c2fe99c7b4deb51f7c256d3ac04fde1b7a571880d9aa05716cd9269a6e4f2cf108fa187cfc84524a29fa7efa4881892fba757deba16f912048 WHIRLPOOL cacc9f3557d1051b97045bbf80be92272fbec84b34d0609195495a1d71976e8ca5e57337254b88ee37aab4dcd0511045b9b2f0a8c9b746e0997f450b3f436c9c
+DIST nix-1.11.9.tar.xz 623020 SHA256 0e943e277f37843f9196b0293cc31d828613ad7a328ee77cd5be01935dc6e7e1 SHA512 1e557d61261f958f7fa94510e88c8d34c8ed7b237427a036cdc461aceff4eb34b8e0cdd859fa14c2e392f9094a489bfc663e3043df8bd22651aa42f809caba97 WHIRLPOOL 1bd56f99da5f7ea427c3afc0170f37aa4ffcb58d8f2c3fc4915e08c95f67745a4b7a0943116c1beae2f67155806c7a5c56deadaeaed7ff3ab17d7c59235df580
diff --git a/sys-apps/nix/nix-1.11.9.ebuild b/sys-apps/nix/nix-1.11.9.ebuild
new file mode 100644
index 000000000000..448c3372ce56
--- /dev/null
+++ b/sys-apps/nix/nix-1.11.9.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic readme.gentoo-r1 user
+
+DESCRIPTION="A purely functional package manager"
+HOMEPAGE="https://nixos.org/nix"
+
+SRC_URI="http://nixos.org/releases/${PN}/${P}/${P}.tar.xz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+etc_profile +gc doc sodium"
+
+RDEPEND="
+ app-arch/bzip2
+ app-arch/xz-utils
+ dev-db/sqlite
+ dev-libs/openssl:0=
+ net-misc/curl
+ sys-libs/zlib
+ gc? ( dev-libs/boehm-gc[cxx] )
+ doc? ( dev-libs/libxml2
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ )
+ sodium? ( dev-libs/libsodium )
+ dev-lang/perl:=
+ dev-perl/DBD-SQLite
+ dev-perl/WWW-Curl
+ dev-perl/DBI
+"
+DEPEND="${RDEPEND}
+ >=sys-devel/bison-2.6
+ >=sys-devel/flex-2.5.35
+ virtual/perl-ExtUtils-ParseXS
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.11.6-systemd.patch
+ "${FILESDIR}"/${PN}-1.11.6-per-user.patch
+ "${FILESDIR}"/${PN}-1.11.6-respect-CXXFLAGS.patch
+ "${FILESDIR}"/${PN}-1.11.6-respect-LDFLAGS.patch
+)
+
+DISABLE_AUTOFORMATTING=yes
+DOC_CONTENTS=" Quick start user guide on Gentoo:
+
+[as root] enable nix-daemon service:
+ [systemd] # systemctl enable nix-daemon
+ [openrc] # rc-update add nix-daemon
+[as an user] relogin to get environment and profile update
+[as an user] fetch nixpkgs update:
+ \$ nix-channel --update
+[as an user] install nix packages:
+ \$ nix-env -i mc
+[as an user] configure environment:
+ Somewhere in .bash_profile you might want to set
+ LOCALE_ARCHIVE=\$HOME/.nix-profile/lib/locale/locale-archive
+ but please read https://github.com/NixOS/nixpkgs/issues/21820
+
+Next steps:
+ nix package manager user manual: http://nixos.org/nix/manual/
+"
+
+pkg_setup() {
+ enewgroup nixbld
+ for i in {1..10}; do
+ # we list 'nixbld' twice to
+ # both assign a primary group for user
+ # and add an user to /etc/group
+ enewuser nixbld${i} -1 -1 /var/empty nixbld,nixbld
+ done
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localstatedir="${EPREFIX}"/nix/var \
+ $(use_enable gc)
+}
+
+src_compile() {
+ local make_vars=(
+ OPTIMIZE=0 # disable hardcoded -O3
+ V=1 # verbose build
+ )
+ emake "${make_vars[@]}"
+}
+
+src_install() {
+ # TODO: emacs highlighter
+ default
+
+ readme.gentoo_create_doc
+
+ # here we an eager variant of something that
+ # is lazily done by nix-daemo and root nix-env
+
+ # TODO: will need a tweak for prefix
+ keepdir /nix/store
+ fowners root:nixbld /nix/store
+ fperms 1775 /nix/store
+
+ keepdir /nix/var/nix/profiles/per-user
+ fperms 1777 /nix/var/nix/profiles/per-user
+
+ doenvd "${FILESDIR}"/60nix-remote-daemon
+ newinitd "${FILESDIR}"/nix-daemon.initd nix-daemon
+
+ if ! use etc_profile; then
+ rm "${ED}"/etc/profile.d/nix.sh || die
+ fi
+}
+
+pkg_postinst() {
+ if ! use etc_profile; then
+ ewarn "${EROOT}etc/profile.d/nix.sh was removed (due to USE=-etc_profile)."
+ fi
+
+ readme.gentoo_print_elog
+}