summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-09-07 20:04:26 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-09-07 23:03:39 +0200
commitc115f95503a71b171266f2811fa3c4ff92e75c0f (patch)
tree6a0a37859ab2a3b9c7d0baff105b5785a49db751
parentdev-ml/odoc: bump to 2.2.1 (diff)
downloadgentoo-c115f95503a71b171266f2811fa3c4ff92e75c0f.tar.gz
gentoo-c115f95503a71b171266f2811fa3c4ff92e75c0f.tar.bz2
gentoo-c115f95503a71b171266f2811fa3c4ff92e75c0f.zip
app-emacs/racket-mode: bump to 1_p20230905
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/racket-mode/Manifest1
-rw-r--r--app-emacs/racket-mode/racket-mode-1_p20230905.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-emacs/racket-mode/Manifest b/app-emacs/racket-mode/Manifest
index 0b63255fe23d..9995554c6eb0 100644
--- a/app-emacs/racket-mode/Manifest
+++ b/app-emacs/racket-mode/Manifest
@@ -1 +1,2 @@
DIST racket-mode-1_p20230506.tar.gz 323446 BLAKE2B 087377a6491014c6d29728a4c3a29e75069b729eddfa339d5cd347102f884dc7eb069097b0bf0864779b861e64a132b497ea0eb202238b06fa3741d4a42a5003 SHA512 6b3d37901e3126d8b3597ab83b5c47869873e4fccf536eed4d9ff1ed1695af7ab551bad5807b37438d20950529032b7dc75f9079d95bcf5b088ff097454c48ae
+DIST racket-mode-1_p20230905.tar.gz 323536 BLAKE2B 449655a43346d0f000396781302461bc229b7769b68e6f8268e295a0c0fdea2786d7c759fd2e002dfd993b4cab087d1f497c53da29a5a3c7635e8807536b3d8d SHA512 ade32d446816024eefcf84f5e1939cbd8ba561bb58454c543f6d49f118e4a937a069cb7e62bff5f9b1c2479175e5cd8c380bc81f14fadaa139110956cd129cf4
diff --git a/app-emacs/racket-mode/racket-mode-1_p20230905.ebuild b/app-emacs/racket-mode/racket-mode-1_p20230905.ebuild
new file mode 100644
index 000000000000..d343ca431fd0
--- /dev/null
+++ b/app-emacs/racket-mode/racket-mode-1_p20230905.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs modes for Racket: edit, REPL, check-syntax, debug, profile, and more"
+HOMEPAGE="https://www.racket-mode.com/
+ https://github.com/greghendershott/racket-mode/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/greghendershott/${PN}.git"
+else
+ [[ ${PV} == *_p20230905 ]] && COMMIT=bfe5a8fc418e9710e474db3e6dcbe66f6b177ecb
+
+ SRC_URI="https://github.com/greghendershott/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="dev-scheme/racket:=[-minimal]"
+BDEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-rkt-source-dir.patch )
+
+DOCS=( CONTRIBUTING.org README.org THANKS.org )
+ELISP_TEXINFO="doc/${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|@SITEETC@|${SITEETC}/${PN}|" -i "${S}"/racket-util.el || die
+}
+
+src_compile() {
+ elisp_src_compile
+
+ # Equivalent to compiling from Emacs with "racket-mode-start-faster",
+ # because this is installed globally we have to compile it now.
+ ebegin "Compiling Racket source files"
+ find "${S}"/racket -type f -name "*.rkt" -exec raco make -v {} +
+ eend $? "failed to compile Racket source files" || die
+}
+
+src_test() {
+ # Set "PLTUSERHOME" to a safe temp directory to prevent writing to "~".
+ PLTUSERHOME="${T}"/racket-mode/test-racket emake test-racket
+}
+
+src_install() {
+ elisp_src_install
+
+ # Install Racket files to "${SITEETC}".
+ insinto "${SITEETC}/${PN}"
+ doins -r racket
+}