summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-01-05 07:49:41 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-01-05 07:49:57 +0100
commitc124f951eb937f27d87363fd1e1f9b980c17812e (patch)
tree7fec98aa51020521e0f883cb643a376c049e6e41
parentx11-wm/amiwm: patch to add flex 2.6.3 support (diff)
downloadgentoo-c124f951eb937f27d87363fd1e1f9b980c17812e.tar.gz
gentoo-c124f951eb937f27d87363fd1e1f9b980c17812e.tar.bz2
gentoo-c124f951eb937f27d87363fd1e1f9b980c17812e.zip
x11-wm/amiwm: Bumped to EAPI-6
Removed stripping from Makefile.in Fixed bad symlink in Makefile.in Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--x11-wm/amiwm/amiwm-0.21_p2.ebuild25
1 files changed, 15 insertions, 10 deletions
diff --git a/x11-wm/amiwm/amiwm-0.21_p2.ebuild b/x11-wm/amiwm/amiwm-0.21_p2.ebuild
index 462fed428f1b..a875e17d6796 100644
--- a/x11-wm/amiwm/amiwm-0.21_p2.ebuild
+++ b/x11-wm/amiwm/amiwm-0.21_p2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
inherit eutils multilib toolchain-funcs
@@ -29,18 +29,24 @@ DEPEND="${COMMON_DEPEND}
x11-proto/xproto
x11-proto/xextproto"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gentoo.diff"
+ "${FILESDIR}/${P}-implicts.patch"
+ "${FILESDIR}/${P}-flex-2.6.3-fix.patch"
+)
pkg_setup() {
tc-export CC
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.diff \
- "${FILESDIR}"/${P}-implicts.patch \
- "${FILESDIR}"/${P}-flex-2.6.3-fix.patch
- sed -i -e "s:\$(exec_prefix)/lib:\$(exec_prefix)/$(get_libdir):" \
- Makefile.in || die
+ default
+ sed -e "s:\$(exec_prefix)/lib:\$(exec_prefix)/$(get_libdir):" \
+ -e '/^STRIPFLAG/s@-s@@' \
+ -e '/$(LN_S)/s@$(DESTDIR)$(AMIWM_HOME)@../..$(AMIWM_HOME)@' \
+ -i Makefile.in || die
sed -i -e "s:/bin/ksh:/bin/sh:g" Xsession{,2}.in || die
cat <<- EOF > "${T}"/amiwm
@@ -50,9 +56,8 @@ src_prepare() {
}
src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc README*
+ local DOCS=( README* )
+ default
exeinto /etc/X11/Sessions
doexe "${T}"/amiwm