summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-05-29 11:16:09 -0400
committerRick Farina <zerochaos@gentoo.org>2020-06-01 16:43:04 -0400
commitc1356331c62e1901456694cefa4e6095241bdba3 (patch)
treec449414df45c779131a773f53d144bd044b62ffe
parentnet-wireless/dump1090: drop old (diff)
downloadgentoo-c1356331c62e1901456694cefa4e6095241bdba3.tar.gz
gentoo-c1356331c62e1901456694cefa4e6095241bdba3.tar.bz2
gentoo-c1356331c62e1901456694cefa4e6095241bdba3.zip
dev-python/pluginbase: bump + py3.8
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
-rw-r--r--dev-python/pluginbase/Manifest1
-rw-r--r--dev-python/pluginbase/pluginbase-1.0.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pluginbase/Manifest b/dev-python/pluginbase/Manifest
index 2f67f5ac6962..6c342243d2f7 100644
--- a/dev-python/pluginbase/Manifest
+++ b/dev-python/pluginbase/Manifest
@@ -1 +1,2 @@
DIST pluginbase-0.5.tar.gz 41964 BLAKE2B 84fc187b60182f100a9016ac663856b29587e60b5ef5ac9c51fb4ed99666908a77c9817c2dc5fb64e82b807e635bd10beb5ce7644e31e63262736cc667a7b8c2 SHA512 921ddc7dacb6ad63abc90beb1d1d993e7b15c9cfe21e850a5852eb40735436e08b39fd2a6d83e23f641014ee81e718aca147ef1e21b55f94ce04a64ba7780455
+DIST pluginbase-1.0.0.tar.gz 41795 BLAKE2B 68d7704b52db39af4f0c2e1f790802eb5f2fd15d91726752605901b3e8a3c736204fad93d96b5dd1a4199586b4d9b42895cbe8290acaed1b4051e8103efb43f9 SHA512 95c3b770980fa5ec745b8d788df29c6219ed6e5af7666f9830d56c6acae01f90831655127bcef69b2dfc423d09429373ae7d4c8b45c76c62a41f909d0747c0a0
diff --git a/dev-python/pluginbase/pluginbase-1.0.0.ebuild b/dev-python/pluginbase/pluginbase-1.0.0.ebuild
new file mode 100644
index 000000000000..634f1829e08d
--- /dev/null
+++ b/dev-python/pluginbase/pluginbase-1.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Support library for building plugins sytems in Python"
+HOMEPAGE="https://github.com/mitsuhiko/pluginbase"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed -e "s/, 'sphinx.ext.intersphinx'//" \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ cd tests && PYTHONPATH=.. py.test --tb=native || die "Tests fail with ${EPYTHON}"
+}