summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-15 16:02:47 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-15 17:03:26 +0200
commitc150c6fd4f4ddb3392d8569d91852c726d6e5a37 (patch)
tree8b4990172ba984ca3e2ae0cab673aba3d2df53ec
parentdev-python/uvloop: Add python@ as co-maint (diff)
downloadgentoo-c150c6fd4f4ddb3392d8569d91852c726d6e5a37.tar.gz
gentoo-c150c6fd4f4ddb3392d8569d91852c726d6e5a37.tar.bz2
gentoo-c150c6fd4f4ddb3392d8569d91852c726d6e5a37.zip
dev-python/uvloop: Bump to 0.12.2, py3.7, EAPI 7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/uvloop/Manifest1
-rw-r--r--dev-python/uvloop/uvloop-0.12.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/uvloop/Manifest b/dev-python/uvloop/Manifest
index b54d3523e850..87af5b375360 100644
--- a/dev-python/uvloop/Manifest
+++ b/dev-python/uvloop/Manifest
@@ -1 +1,2 @@
+DIST uvloop-0.12.2.tar.gz 1922375 BLAKE2B 49d17dc0899d59975d02dcc0b56e53e506e83a7f02ba7e9021abf92e8518b9904905c0175c3e2612a10f6f6d7a69505bfb024c00debf01823dcfb597966ab1a9 SHA512 59e34c83946facf70e839831dcd61fb7a8cf22df48d2ede6de84edbd4af5e789b2b404c8b7835e9a8cd7be706ad370bde2a290beab72c5d7411d35d07ee7974c
DIST uvloop-0.8.1.tar.gz 1719488 BLAKE2B eba6e15c8eb46286b6e8df6043280ec8b423f097fcf2d4d5be657ff18f0fb97ce83e5268a138cf46700f54b7040353b6588dc4b0140e11f38d7da2e26b1ff120 SHA512 45dba019a0dacaae6c2a732c3f321402c19c945b0d9fa35b9cae28f888a54c7d4b322b450c55a6cf21c1aac01dc49b90eccdffbf4cb8c812a5ec8b9e805e01e4
diff --git a/dev-python/uvloop/uvloop-0.12.2.ebuild b/dev-python/uvloop/uvloop-0.12.2.ebuild
new file mode 100644
index 000000000000..4b6fbd02211b
--- /dev/null
+++ b/dev-python/uvloop/uvloop-0.12.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
+inherit distutils-r1
+
+DESCRIPTION="Ultra-fast implementation of asyncio event loop on top of libuv"
+HOMEPAGE="https://github.com/magicstack/uvloop"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-libs/libuv-1.11.0:="
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ cat <<EOF >> setup.cfg || die
+[build_ext]
+use-system-libuv=1
+EOF
+
+ # failing not only for us
+ sed -i -e 's:test_write_pipe(:_&:' tests/test_pipes.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_ext --inplace build_sphinx
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ use doc && local HTML_DOCS=( "${BUILD_DIR}/sphinx/html/." )
+ distutils-r1_python_install_all
+}