summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-25 06:35:03 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-25 07:10:54 +0100
commitc1696521f624ffa9a46f80e36f74b3c0a842c9ee (patch)
treecb0e2995681582fca955bebc7fb88e546b74689c
parentdev-python/sentry-sdk: Bump to 1.37.1 (diff)
downloadgentoo-c1696521f624ffa9a46f80e36f74b3c0a842c9ee.tar.gz
gentoo-c1696521f624ffa9a46f80e36f74b3c0a842c9ee.tar.bz2
gentoo-c1696521f624ffa9a46f80e36f74b3c0a842c9ee.zip
dev-python/idna: Bump to 3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/idna/Manifest1
-rw-r--r--dev-python/idna/idna-3.5.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/idna/Manifest b/dev-python/idna/Manifest
index 35fb56f3169a..2cca1ab373ed 100644
--- a/dev-python/idna/Manifest
+++ b/dev-python/idna/Manifest
@@ -1 +1,2 @@
DIST idna-3.4.tar.gz 183077 BLAKE2B dd6c94104e17b441a7a63aec4e28f1969278996964c402865da8ad1040878539f798956e26532281cc44934544fd6fa33407949caf4a34fa2b48d7aafbb8fb5e SHA512 4060a9304c9bac04efdd0b97ec8f5aeb7e17417e767bf51c5dfc26605edad25ab67456cf6f6a3c5a9f32b8247e46f6343edfd8a6ffbcd6d1075c71e66d089d6a
+DIST idna-3.5.gh.tar.gz 184973 BLAKE2B 68b39c00850663f5966ed1ee8c287a0026c441ed052b52aa6243cd595f6cd6fe62a7fe61b9b855c4ee851144fae2e88eda7bbd8405c66e37a9ad42ddc87cf361 SHA512 a806e4f96f2f1034dd634f3c86e80c6e7929a80c0773e4b2749466b691d38b94b6ea64994613cb5f8764754c1c9813eade4b74105f64233671b8eeaca7125bdc
diff --git a/dev-python/idna/idna-3.5.ebuild b/dev-python/idna/idna-3.5.ebuild
new file mode 100644
index 000000000000..5eb91e865ff8
--- /dev/null
+++ b/dev-python/idna/idna-3.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Internationalized Domain Names in Applications (IDNA)"
+HOMEPAGE="
+ https://github.com/kjd/idna/
+ https://pypi.org/project/idna/
+"
+SRC_URI="
+ https://github.com/kjd/idna/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests unittest