summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-26 09:19:39 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-26 09:24:13 +0100
commitc17adb5acbdba208d8e4acba7947db05a922a5b6 (patch)
tree76b61ebdf582711c51265df523f2bee59047f5d2
parentdev-ros/rqt_nav_view: Bump to 0.5.6. (diff)
downloadgentoo-c17adb5acbdba208d8e4acba7947db05a922a5b6.tar.gz
gentoo-c17adb5acbdba208d8e4acba7947db05a922a5b6.tar.bz2
gentoo-c17adb5acbdba208d8e4acba7947db05a922a5b6.zip
dev-ros/rqt_pose_view: Bump to 0.5.6.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-ros/rqt_pose_view/Manifest1
-rw-r--r--dev-ros/rqt_pose_view/rqt_pose_view-0.5.6.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/rqt_pose_view/Manifest b/dev-ros/rqt_pose_view/Manifest
index b17102baa1b1..f7d21006ace4 100644
--- a/dev-ros/rqt_pose_view/Manifest
+++ b/dev-ros/rqt_pose_view/Manifest
@@ -1 +1,2 @@
DIST rqt_robot_plugins-0.5.5.tar.gz 2106937 SHA256 d8d0d5accc181c63146091f4ff9f50f56e84d56a5d55c67309377ed27c7ca613 SHA512 0be22bafaaf69eec4e354cc6a54be56b2b22c943dcbf214896873b672842a9e00ec7d80e20fd0ef26a31affe680e1dbbc733d5df93fe91c067a1276a7155688a WHIRLPOOL d91d254515767827147cc017142caaece10c489022efdb549dc2e0c97ec4ced084042a05f45bebb024ac530fd41223cfd16cebfba3694600cb40d4a80e7b304c
+DIST rqt_robot_plugins-0.5.6.tar.gz 2107696 SHA256 d5f1b509df54b253d3b2952560e8dc5e764c3259b0e9dcff08541e27ac9fed71 SHA512 871f660e22afafd510e34984b94d2530bc3314db194c06ff458430e15b1183a60147289e9544a5fb070665a3c83034cbcccefe2f820e62f091c3bbc0edfd0a51 WHIRLPOOL a90882b1e762f5e53b7ce7ff92695ba8eb63242b53304a08c928f2667ceb206cfda72e64d81b73d1d951e6b92cb5f16327528846f6b54e28b2acaf898424a664
diff --git a/dev-ros/rqt_pose_view/rqt_pose_view-0.5.6.ebuild b/dev-ros/rqt_pose_view/rqt_pose_view-0.5.6.ebuild
new file mode 100644
index 000000000000..983f8746bc4e
--- /dev/null
+++ b/dev-ros/rqt_pose_view/rqt_pose_view-0.5.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_robot_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing 3D poses"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-python/PyQt4[opengl,${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"