summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-02 18:58:49 +0000
committerSam James <sam@gentoo.org>2020-08-02 18:58:49 +0000
commitc19d66734a962a9c8deb9b7ad74f98806e4e0285 (patch)
treedc5fabd56095d36342de30c6bac21b2a2a1201a4
parentdev-python/gst-python: add Python 3.9 (diff)
downloadgentoo-c19d66734a962a9c8deb9b7ad74f98806e4e0285.tar.gz
gentoo-c19d66734a962a9c8deb9b7ad74f98806e4e0285.tar.bz2
gentoo-c19d66734a962a9c8deb9b7ad74f98806e4e0285.zip
dev-python/pyglet: bump to 1.5.7
* Add Python 3.9 * Unrestrict tests (passing here) * Run only unit tests (others: interactive, integration) (Interactive are a no-go for policy and obvious reasons, while the integration tests are slow.) Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/pyglet/Manifest1
-rw-r--r--dev-python/pyglet/pyglet-1.5.7.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/pyglet/Manifest b/dev-python/pyglet/Manifest
index 6f893d1c4e0b..3d5bd72bdd15 100644
--- a/dev-python/pyglet/Manifest
+++ b/dev-python/pyglet/Manifest
@@ -1,2 +1,3 @@
DIST pyglet-1.2.4.tar.gz 2122017 BLAKE2B 6e5e24ec78e24b9a9c8e9627791ede93d740c1af7af0176c6f75409c76981fa16752bbe14c9b5ec871438f5468b3587e7ce12194241d94ab3731d46cbbe395f1 SHA512 70cd781936db8c8c156499e524ee73520bc90c19461074264abd62a4854307ef090af5faba521686f247fb4cbee552a428892f59a5b382429acfc000f4c2e22d
DIST pyglet-1.5.3.tar.gz 6356079 BLAKE2B 517b196eff334d572d4db181ce0480c3af8e2bc4a92e23e1fd7c335aedebe3afa493eb3f4745d8daffc3c7d930b9e333075014d2ba5d4303f4691c490a09f252 SHA512 12e7189272b9ab3b4bd3d713d0e979cfc1d76200fc8454b31573fca29b179f99242c34a1adb7a1c2fabb7b950cc3006cfcd8b188eb2c50ae95cca95b0e15582c
+DIST pyglet-1.5.7.tar.gz 6367378 BLAKE2B 68d4aa673a7463f7da0f4ccb7f413b602f32ecc423438326fc4262a4449fe22dff25a513074611ce2c77c130dfe9cc29e44e54a95169875208731f70803f1a45 SHA512 2c2a06636b1db788241028d1ef2290a774b98721ccc92ceed2b2895bcee81d4aa72b2111896091b54531936513772505b0d43003e412735d606130ed4b08f8c9
diff --git a/dev-python/pyglet/pyglet-1.5.7.ebuild b/dev-python/pyglet/pyglet-1.5.7.ebuild
new file mode 100644
index 000000000000..c9b51798015c
--- /dev/null
+++ b/dev-python/pyglet/pyglet-1.5.7.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 virtualx xdg-utils
+
+DESCRIPTION="Cross-platform windowing and multimedia library for Python"
+HOMEPAGE="http://www.pyglet.org/"
+SRC_URI="https://github.com/pyglet/pyglet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples image +sound"
+
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/gst-python[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ virtual/opengl
+ image? ( || (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ x11-libs/gtk+:2
+ ) )
+ sound? ( || (
+ media-libs/openal
+ media-sound/pulseaudio
+ ) )
+"
+# ffmpeg? ( media-libs/avbin-bin )
+
+DOCS=( DESIGN NOTICE README.md RELEASE_NOTES )
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ xdg_environment_reset
+
+ # Specify path to avoid running interactive tests
+ # We could add in integration tests, but they're slow
+ pytest -vv tests/unit || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}