summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2023-12-21 15:17:24 +0100
committerPetr Vaněk <arkamar@gentoo.org>2023-12-21 15:22:51 +0100
commitc1a004fe0cf4d4ce78af46af6794e7c778f3a644 (patch)
treed73e635e2605f60c47165dbbaf5a7781ea8eb6aa
parentnet-dns/s6-dns: add 2.3.7.1 (diff)
downloadgentoo-c1a004fe0cf4d4ce78af46af6794e7c778f3a644.tar.gz
gentoo-c1a004fe0cf4d4ce78af46af6794e7c778f3a644.tar.bz2
gentoo-c1a004fe0cf4d4ce78af46af6794e7c778f3a644.zip
net-misc/s6-networking: add 2.7.0.1
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
-rw-r--r--net-misc/s6-networking/Manifest1
-rw-r--r--net-misc/s6-networking/s6-networking-2.7.0.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-misc/s6-networking/Manifest b/net-misc/s6-networking/Manifest
index bba355c99153..a361b82262f1 100644
--- a/net-misc/s6-networking/Manifest
+++ b/net-misc/s6-networking/Manifest
@@ -1,3 +1,4 @@
DIST s6-networking-2.5.1.3.tar.gz 114490 BLAKE2B 09b74ff4c881e0c30162a1a01d0d372c0dab2888efaeb1cb97402c485fca2d1360aaa936b291237cab7d43af870d9653b833a9a0e57c57b23918b4128186b476 SHA512 abc90d374a24507998041fd8dcd5f9c2d91bf94046e3da8d324546471f482b5929d863bd2bc846581da32f6c980ef5c2e5d6780655c757316ef0b67e37c72a19
DIST s6-networking-2.6.0.0.tar.gz 112145 BLAKE2B 1e111614da26283c0a9ee46b0d09d554c4efaf6866b322d5850512058d3237cc060b2ca6d5d1bd0e60791598e034c5fe222a2b6cf5bf271af8ee9e4403f61ea3 SHA512 dcd9a9c8e2d17fcfca96d44b1b86760a0f0e303a638f566ba064b4eb071e18736baa188cfcdb2ae27c0b00a2ed7876a9da6361a8e3a4719b70f462925df913e7
DIST s6-networking-2.7.0.0.tar.gz 114592 BLAKE2B ce4eab80788bd4c7406e4b5732cb035e483ef1d788ea24a61886fa23402af5df23380d17464020ea562810563162e18fbd49644e9ac3d4827802e2caf294bab7 SHA512 b0dd1b0007704ca087bf49ae93cc09b7cbaa59f6ab99a0281f6bb9de38b25da18be925bc27f1bb74f984f60579f4ebdba41f276ea529b77344d9f3155bad314c
+DIST s6-networking-2.7.0.1.tar.gz 115939 BLAKE2B da3edb3401a64ab343a40f584c9ccf183268a0ac3ab5e642734fb7a7ce4eba42a08b8642188ce2cee0b561363feb1b61f3ee21c66d3639ffc735af0677b8837d SHA512 3074c24e833f6f19bfc016c264963457f8a9df6b07bab1c0a58dc4cd0b464371051d1d5af0d5ac5544751ffa18514e2f078f329249fe97955657a3aab9ebaa99
diff --git a/net-misc/s6-networking/s6-networking-2.7.0.1.ebuild b/net-misc/s6-networking/s6-networking-2.7.0.1.ebuild
new file mode 100644
index 000000000000..681fbb7f92eb
--- /dev/null
+++ b/net-misc/s6-networking/s6-networking-2.7.0.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature toolchain-funcs
+
+DESCRIPTION="Suite of small networking utilities for Unix systems"
+HOMEPAGE="https://www.skarnet.org/software/s6-networking/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+RDEPEND="
+ dev-lang/execline:=
+ >=dev-libs/skalibs-2.14.1.0:=
+ >=net-dns/s6-dns-2.3.7.0:=
+ sys-apps/s6:=[execline]
+ ssl? ( dev-libs/libretls:= )
+"
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+
+ # Avoid QA warning for LDFLAGS addition
+ sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+
+ local myconf=(
+ --bindir=/bin
+ --dynlibdir="/$(get_libdir)"
+ --libdir="/usr/$(get_libdir)/${PN}"
+ --with-dynlib="/$(get_libdir)"
+ --with-lib="/usr/$(get_libdir)/s6"
+ --with-lib="/usr/$(get_libdir)/s6-dns"
+ --with-lib="/usr/$(get_libdir)/skalibs"
+ --with-sysdeps="/usr/$(get_libdir)/skalibs"
+ --enable-shared
+ --disable-allstatic
+ --disable-static
+ --disable-static-libc
+ $(use_enable ssl ssl libtls)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ optfeature "man pages" app-doc/s6-networking-man-pages
+}