summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2018-02-07 09:17:01 +0000
committerTony Vroon <chainsaw@gentoo.org>2018-02-07 09:17:01 +0000
commitc1a2081df6f82c07aa8c90391bee03a234327d18 (patch)
tree20b41eb9f7e1f649d134fd730388a68824210c17
parentx11-misc/evolvotron: remove 0.6.3-r1 (diff)
downloadgentoo-c1a2081df6f82c07aa8c90391bee03a234327d18.tar.gz
gentoo-c1a2081df6f82c07aa8c90391bee03a234327d18.tar.bz2
gentoo-c1a2081df6f82c07aa8c90391bee03a234327d18.zip
net-libs/pjproject: Deal with Speex moving goalposts
Apparently we now want speexdsp instead, but this is a recent development. Also remove older releases which do not have the SSL configure logic override, as they will break with Asterisk. Closes: https://bugs.gentoo.org/641810 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--net-libs/pjproject/Manifest2
-rw-r--r--net-libs/pjproject/pjproject-2.5.1.ebuild101
-rw-r--r--net-libs/pjproject/pjproject-2.6.ebuild101
-rw-r--r--net-libs/pjproject/pjproject-2.7.1.ebuild2
4 files changed, 1 insertions, 205 deletions
diff --git a/net-libs/pjproject/Manifest b/net-libs/pjproject/Manifest
index ee5cb59e30fa..f4403851ca63 100644
--- a/net-libs/pjproject/Manifest
+++ b/net-libs/pjproject/Manifest
@@ -1,3 +1 @@
-DIST pjproject-2.5.1.tar.bz2 4180967 BLAKE2B 1c7d00ad1eddd0b2b53591927a2cdd9dedfdf61b6e9ab88dba41d3916a3adc5e889ebc2e3e2518368378990929ced580917d990b4b8649e137e03953a7d77ee9 SHA512 7722980e5afa4b541614c4117462b0df3fff2bfec45ca5da18a7c3fce2a5dd6c628ed0bb2412da6086abd59c5ba2844bea9466f49737dbc9ca85d32ef67a2628
-DIST pjproject-2.6.tar.bz2 4933273 BLAKE2B cb41f00b81da5069a85a8facde14e77a3cf13b50d9f5131fe04e15a4538cbc2bac026429d386938501b4715c584cd497d31a9ba4f3579f96b7b1b8cf363c99e1 SHA512 48be9a80f90b1cb292c6eb0d071d889f6027f56bdd75095c510d9be2d6b5f1df5a6371617009371525ac5797dc61f5814dcc1cc11d14105e5a2576539f89293f
DIST pjproject-2.7.1.tar.bz2 4880007 BLAKE2B 33fca89f07abc0b9662b1070c96b903c236a60149734755286dad3111411dbeef5779077a77d21112be6db2957cb7e18c5c833b3c5fd32c26be44d4550fb215e SHA512 cd15afee2a02659668ff228b2652d2bd179393e3b5031afae1c326354fb9676babc08eb689e466165536abc360684299b4fdb41dbb1148aed89afe1ce7e5d979
diff --git a/net-libs/pjproject/pjproject-2.5.1.ebuild b/net-libs/pjproject/pjproject-2.5.1.ebuild
deleted file mode 100644
index d47ae1c5b9b5..000000000000
--- a/net-libs/pjproject/pjproject-2.5.1.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic
-
-DESCRIPTION="Open source SIP, Media, and NAT Traversal Library"
-HOMEPAGE="http://www.pjsip.org/"
-SRC_URI="http://www.pjsip.org/release/${PV}/${P}.tar.bz2"
-KEYWORDS="~amd64 ~x86"
-
-LICENSE="GPL-2"
-SLOT="0"
-CODEC_FLAGS="g711 g722 g7221 gsm ilbc speex l16"
-VIDEO_FLAGS="sdl ffmpeg v4l2 openh264 libyuv"
-SOUND_FLAGS="alsa oss portaudio"
-IUSE="amr debug doc epoll examples ipv6 opus resample silk ssl static-libs webrtc ${CODEC_FLAGS} ${VIDEO_FLAGS} ${SOUND_FLAGS}"
-
-RDEPEND="alsa? ( media-libs/alsa-lib )
- oss? ( media-libs/portaudio[oss] )
- portaudio? ( media-libs/portaudio )
-
- amr? ( media-libs/opencore-amr )
- gsm? ( media-sound/gsm )
- ilbc? ( dev-libs/ilbc-rfc3951 )
- opus? ( media-libs/opus )
- speex? ( media-libs/speex )
-
- ffmpeg? ( virtual/ffmpeg:= )
- sdl? ( media-libs/libsdl )
- openh264? ( media-libs/openh264 )
- resample? ( media-libs/libsamplerate )
-
- ssl? ( dev-libs/openssl:= )
-
- net-libs/libsrtp:0"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-REQUIRED_USE="?? ( ${SOUND_FLAGS} )"
-
-src_configure() {
- local myconf=()
- local videnable="--disable-video"
- local t
-
- use ipv6 && append-flags -DPJ_HAS_IPV6=1
- use debug || append-flags -DNDEBUG=1
-
- for t in ${CODEC_FLAGS}; do
- myconf+=( $(use_enable ${t} ${t}-codec) )
- done
-
- for t in ${VIDEO_FLAGS}; do
- myconf+=( $(use_enable ${t}) )
- use "${t}" && videnable="--enable-video"
- done
-
- econf \
- --enable-shared \
- --with-external-srtp \
- ${videnable} \
- $(use_enable epoll) \
- $(use_with gsm external-gsm) \
- $(use_with speex external-speex) \
- $(use_enable speex speex-aec) \
- $(use_enable resample) \
- $(use_enable resample libsamplerate) \
- $(use_enable resample resample-dll) \
- $(use_enable alsa sound) \
- $(use_enable oss) \
- $(use_with portaudio external-pa) \
- $(use_enable portaudio ext-sound) \
- $(use_enable amr opencore-amr) \
- $(use_enable silk) \
- $(use_enable opus) \
- $(use_enable ssl) \
- $(use_enable webrtc) \
- "${myconf[@]}"
-}
-
-src_compile() {
- emake dep
- emake
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- if use doc; then
- dodoc README.txt README-RTEMS
- fi
-
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- doins -r pjsip-apps/src/samples
- fi
-
- use static-libs || rm "${D}/usr/$(get_libdir)/*.a"
-}
diff --git a/net-libs/pjproject/pjproject-2.6.ebuild b/net-libs/pjproject/pjproject-2.6.ebuild
deleted file mode 100644
index d47ae1c5b9b5..000000000000
--- a/net-libs/pjproject/pjproject-2.6.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic
-
-DESCRIPTION="Open source SIP, Media, and NAT Traversal Library"
-HOMEPAGE="http://www.pjsip.org/"
-SRC_URI="http://www.pjsip.org/release/${PV}/${P}.tar.bz2"
-KEYWORDS="~amd64 ~x86"
-
-LICENSE="GPL-2"
-SLOT="0"
-CODEC_FLAGS="g711 g722 g7221 gsm ilbc speex l16"
-VIDEO_FLAGS="sdl ffmpeg v4l2 openh264 libyuv"
-SOUND_FLAGS="alsa oss portaudio"
-IUSE="amr debug doc epoll examples ipv6 opus resample silk ssl static-libs webrtc ${CODEC_FLAGS} ${VIDEO_FLAGS} ${SOUND_FLAGS}"
-
-RDEPEND="alsa? ( media-libs/alsa-lib )
- oss? ( media-libs/portaudio[oss] )
- portaudio? ( media-libs/portaudio )
-
- amr? ( media-libs/opencore-amr )
- gsm? ( media-sound/gsm )
- ilbc? ( dev-libs/ilbc-rfc3951 )
- opus? ( media-libs/opus )
- speex? ( media-libs/speex )
-
- ffmpeg? ( virtual/ffmpeg:= )
- sdl? ( media-libs/libsdl )
- openh264? ( media-libs/openh264 )
- resample? ( media-libs/libsamplerate )
-
- ssl? ( dev-libs/openssl:= )
-
- net-libs/libsrtp:0"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-REQUIRED_USE="?? ( ${SOUND_FLAGS} )"
-
-src_configure() {
- local myconf=()
- local videnable="--disable-video"
- local t
-
- use ipv6 && append-flags -DPJ_HAS_IPV6=1
- use debug || append-flags -DNDEBUG=1
-
- for t in ${CODEC_FLAGS}; do
- myconf+=( $(use_enable ${t} ${t}-codec) )
- done
-
- for t in ${VIDEO_FLAGS}; do
- myconf+=( $(use_enable ${t}) )
- use "${t}" && videnable="--enable-video"
- done
-
- econf \
- --enable-shared \
- --with-external-srtp \
- ${videnable} \
- $(use_enable epoll) \
- $(use_with gsm external-gsm) \
- $(use_with speex external-speex) \
- $(use_enable speex speex-aec) \
- $(use_enable resample) \
- $(use_enable resample libsamplerate) \
- $(use_enable resample resample-dll) \
- $(use_enable alsa sound) \
- $(use_enable oss) \
- $(use_with portaudio external-pa) \
- $(use_enable portaudio ext-sound) \
- $(use_enable amr opencore-amr) \
- $(use_enable silk) \
- $(use_enable opus) \
- $(use_enable ssl) \
- $(use_enable webrtc) \
- "${myconf[@]}"
-}
-
-src_compile() {
- emake dep
- emake
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- if use doc; then
- dodoc README.txt README-RTEMS
- fi
-
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- doins -r pjsip-apps/src/samples
- fi
-
- use static-libs || rm "${D}/usr/$(get_libdir)/*.a"
-}
diff --git a/net-libs/pjproject/pjproject-2.7.1.ebuild b/net-libs/pjproject/pjproject-2.7.1.ebuild
index d2428b19f346..e4d25565824a 100644
--- a/net-libs/pjproject/pjproject-2.7.1.ebuild
+++ b/net-libs/pjproject/pjproject-2.7.1.ebuild
@@ -27,7 +27,7 @@ RDEPEND="alsa? ( media-libs/alsa-lib )
gsm? ( media-sound/gsm )
ilbc? ( dev-libs/ilbc-rfc3951 )
opus? ( media-libs/opus )
- speex? ( media-libs/speex )
+ speex? ( media-libs/speexdsp )
ffmpeg? ( virtual/ffmpeg:= )
sdl? ( media-libs/libsdl )