summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-04-09 14:19:49 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-04-11 14:06:53 -0500
commitc1b2240a8ab1a5938a3cc80495096a76a34f7485 (patch)
tree83dd56f3b876dd9af10695f8a13d3721034b555f
parentsys-cluster/cinder: 17.1.0 stable amd64/x86 with cleanup (diff)
downloadgentoo-c1b2240a8ab1a5938a3cc80495096a76a34f7485.tar.gz
gentoo-c1b2240a8ab1a5938a3cc80495096a76a34f7485.tar.bz2
gentoo-c1b2240a8ab1a5938a3cc80495096a76a34f7485.zip
app-emulation/diskimage-builder: 3.9.0 bump
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-3.9.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index a8e40903bedf..f3a79ef9388b 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1,2 +1,3 @@
DIST diskimage-builder-3.7.0.tar.gz 472703 BLAKE2B 4c3bf294f33556525f65d29e999cccaa4066d42f8e17742041666872ac01f5c6acab77d20b5d4281cc385a3f6988086e43c36f5330a656e5d2cb73c2e63e346d SHA512 c4453840f043774446e8dcb88bdc841d2fee8fb60432168fe48048171896932f2be9048fb0af9c5b777978218ec51f24bdfd6484a8e6cbe7a195b6df2508a1e1
DIST diskimage-builder-3.8.0.tar.gz 473795 BLAKE2B 86ce05ac649ff0faef90d9dd6f2677d6cc609e2fa4613ab00b88f75b861e586650f4a74ea01d1fb68745581d043b0dc7d8f3c9e8437ee16003a34ffc617ab513 SHA512 f3e553746f77545cf6cfe7fad706000bfa9761878f4481bae5fe8d06118c2e0360a7af220e89fe3d65320a6a2ae8b4f4ae69259fa9455bebe8bae8b07acff455
+DIST diskimage-builder-3.9.0.tar.gz 473797 BLAKE2B 79654b7d5673d084e81850be102174b509c43fc598b54455256309abe9e503db779be03a440cd5bc6c37fd890bba9412cd8850dfc2bf855f7d8bf69e1e26ee6e SHA512 8be45bef3680b7a5c7aeb1a301a09ace26db51b4f842a7fdb19194a82cc3436e18296e9a3b88a75cfeccbd14e9098d6ad83f50ca44f7eaeba85accf4ef54e7da
diff --git a/app-emulation/diskimage-builder/diskimage-builder-3.9.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-3.9.0.ebuild
new file mode 100644
index 000000000000..4c39e9fb0b8c
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-3.9.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"