summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-06-03 12:20:40 +0200
committerUlrich Müller <ulm@gentoo.org>2018-06-03 12:21:14 +0200
commitc1c3f63e52bd120684ef9e5c951124abd15b12a5 (patch)
treed2b25f580761b387cd8c60c7237ebbc0fcbbc52f
parentdev-python/cached-property: Remove old (diff)
downloadgentoo-c1c3f63e.tar.gz
gentoo-c1c3f63e.tar.bz2
gentoo-c1c3f63e.zip
app-emacs/websocket: Version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--app-emacs/websocket/Manifest1
-rw-r--r--app-emacs/websocket/files/50websocket-gentoo.el1
-rw-r--r--app-emacs/websocket/websocket-1.10.ebuild33
3 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/websocket/Manifest b/app-emacs/websocket/Manifest
index 1727892d8198..b70b965e03b0 100644
--- a/app-emacs/websocket/Manifest
+++ b/app-emacs/websocket/Manifest
@@ -1 +1,2 @@
+DIST websocket-1.10.tar.gz 27108 BLAKE2B b164b3ca47e0705322d9bcd0d9535c8e84777487e8783bf599f5391c88ee6193a1ef1750ec4b3cbd4fac2968c449c4f3a140255a434f3de38e66ad7364c192ba SHA512 ef1a34eccd173eb206cd9eeb4ea988a5b076f178bd4ca903e03b2f2301a34c2cbd08e43a13c8d24a64d10da28b3a77c15b2321978460db7a6b23c601abe31197
DIST websocket-1.9.tar.gz 27029 BLAKE2B 9a492beda1b7f7211d1a72b5af0cab445f0fa78439797f05b565a0421a798a4fe0c6fb0e24aac0454f5b48f8f536762d0fcc5d92c216bd6b83b6ac34a1e024a4 SHA512 bcd98e7edcbe95cae2f196cea05fd6cfa9083ed1ab2392530ca00cb05b87d6fa95b5f5319981fd94244b74989850c171e4c31c8758a8b7fe95d49299103a4410
diff --git a/app-emacs/websocket/files/50websocket-gentoo.el b/app-emacs/websocket/files/50websocket-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/websocket/files/50websocket-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/websocket/websocket-1.10.ebuild b/app-emacs/websocket/websocket-1.10.ebuild
new file mode 100644
index 000000000000..2211d645c5a3
--- /dev/null
+++ b/app-emacs/websocket/websocket-1.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="A websocket implementation in elisp"
+HOMEPAGE="https://github.com/ahyatt/emacs-websocket"
+SRC_URI="https://github.com/ahyatt/emacs-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/emacs-${P}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile websocket.el
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -l websocket-test \
+ -f ert-run-tests-batch-and-exit
+}
+
+src_install() {
+ elisp-install ${PN} websocket.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc README.org websocket-functional-test.el testserver.py
+}