summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-10-27 15:14:09 -0700
committerZac Medico <zmedico@gentoo.org>2019-10-27 16:51:03 -0700
commitc1faef3a67ae5904fcd8e95495b005e268f1bc76 (patch)
tree1d8c0750dccbda1a5835e62c26cd573308c32037
parentprofiles: UT2004 mod packages have been removed and others rescued (diff)
downloadgentoo-c1faef3a.tar.gz
gentoo-c1faef3a.tar.bz2
gentoo-c1faef3a.zip
dev-util/diffball: revbump to 1.0.1-r1 for bug 543310
Fix stack buffer overflows reported in bug 543310. Bug: https://bugs.gentoo.org/543310 See: https://github.com/zmedico/diffball/pull/1 Reported-by: Aidan Thornton <makosoft@googlemail.com> Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--dev-util/diffball/Manifest2
-rw-r--r--dev-util/diffball/diffball-1.0.1-r1.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/diffball/Manifest b/dev-util/diffball/Manifest
index 538d9e71b8f5..29623d42c415 100644
--- a/dev-util/diffball/Manifest
+++ b/dev-util/diffball/Manifest
@@ -1 +1,3 @@
+DIST bug_543310_diffball_stack_buffer_overflows.patch 2945 BLAKE2B 17aa01d64464edccc490e7714dc9db8767d19b0c8b6d14223359d266d38e47aae822454aa14446c038b2b3477a4d8a8db228be7e28666528883ebf02ac2cb65b SHA512 be9a44cd9abfb41f32683d0363375902477f739f9c0dd23b30cfcd9fc6fced61111a2b101cb46db2d6320b4d70ed04627a1c178d44f23530f248bcb87e6efd32
DIST diffball-1.0.1.tar.bz2 387787 BLAKE2B e46dbf32b2ec9bece106ca90a6ae46bdfde8b83a5fd41e67f15c4bd25d7015327b4738ce3bfba71c92fd2baa94a5d3bc507dd0fad2b3451447a39a7fe058002e SHA512 1e01fff8bf7d993c828f195d974b7df1cd4fb056e9a51f9533bc8e01666a55e0d9467c799a005f58d7b4369bbf88fc9b716d0fb68ead6171d349e3c874bddb8c
+DIST diffball-1.0.1.tar.gz 86387 BLAKE2B 1e2c6d522b00a643666e88d19d2d6986ce02c7835378dfc9799e43fa291683bf08e129546a85c332b04ab549788ae4ac3b4d57fd6140a29a9556bece4293cbf9 SHA512 3344f03a65e2b44615eaf9210d26a4438712684c438fcea9caabe89688fe3b3d5436703f0ed63412a18a63acb49ca0dacff190fa002ea76b346bbccba3388ee4
diff --git a/dev-util/diffball/diffball-1.0.1-r1.ebuild b/dev-util/diffball/diffball-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..7515e452dd66
--- /dev/null
+++ b/dev-util/diffball/diffball-1.0.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Delta compression suite for using/generating binary patches"
+HOMEPAGE="https://github.com/zmedico/diffball"
+SRC_URI="https://github.com/zmedico/diffball/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/zmedico/diffball/pull/1.patch -> bug_543310_diffball_stack_buffer_overflows.patch"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="debug"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ >=app-arch/bzip2-1.0.2
+ app-arch/xz-utils"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# Invalid RESTRICT for source package. Investigate.
+RESTRICT="strip"
+
+PATCHES=("${DISTDIR}/bug_543310_diffball_stack_buffer_overflows.patch")
+
+src_prepare() {
+ # fix bug 548316 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug asserts)
+}