summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-07-22 13:55:13 -0400
committerMatt Turner <mattst88@gentoo.org>2023-07-22 13:55:13 -0400
commitc1fb973f08517e305697514053545cf40ed6b574 (patch)
tree4007f21c0045a91180df57cf9d7c7c772852ef55
parentx11-base/xorg-server: fix xf86-video-nouveau build (diff)
downloadgentoo-c1fb973f.tar.gz
gentoo-c1fb973f.tar.bz2
gentoo-c1fb973f.zip
media-gfx/shotwell: Version bump to 0.32.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-gfx/shotwell/Manifest1
-rw-r--r--media-gfx/shotwell/shotwell-0.32.2.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/media-gfx/shotwell/Manifest b/media-gfx/shotwell/Manifest
index 56b114e1cbca..4d240c8c18f0 100644
--- a/media-gfx/shotwell/Manifest
+++ b/media-gfx/shotwell/Manifest
@@ -1 +1,2 @@
DIST shotwell-0.32.1.tar.xz 35324252 BLAKE2B a8fd4195dcf495db8413586805f0d75d37759b62847c55dc8e81ed447c7d3c75e1f0f6b95f3982ee0712403b850d735962e4cd0f48ec41426e98c62555fdeb60 SHA512 1d487a0ea7ef0fb1b26d7c53b50e64b7d899bb9082744620dd421195b3ea90765633aac940695371d82fe5054f979e43cb587e726c4fa90712403ea9f60afcfe
+DIST shotwell-0.32.2.tar.xz 35327248 BLAKE2B e64c14fa8516dede11e5793f35328993755e83b893423f413a9419fe30fc8eebc26c61b34b259dcee1353dfdecb77f582c6e1a10a62e477032ea518d0e56af12 SHA512 3f502856ed0ad6dba18d696b67c940afe04b40130ba273bef8d2324301444c1c90e2762827061383785bb20f31b62a8657e9795b405f719254cec308f9430fca
diff --git a/media-gfx/shotwell/shotwell-0.32.2.ebuild b/media-gfx/shotwell/shotwell-0.32.2.ebuild
new file mode 100644
index 000000000000..63235d2bfa5c
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.32.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson optfeature vala xdg
+
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Shotwell"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+IUSE="opencv udev"
+
+DEPEND="
+ >=x11-libs/gtk+-3.22.0:3
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/libgee-0.8.5:0.8=
+ >=net-libs/webkit-gtk-2.26:4.1
+ net-libs/libsoup:3.0
+ >=dev-libs/json-glib-0.7.6
+ >=dev-libs/libxml2-2.6.32:2
+ x11-libs/gdk-pixbuf:2
+ >=dev-db/sqlite-3.5.9:3
+ >=media-libs/gstreamer-1.20:1.0
+ >=media-libs/gst-plugins-base-1.20:1.0
+ >=media-libs/libgphoto2-2.5:=
+ udev? ( >=dev-libs/libgudev-145:= )
+ >=media-libs/gexiv2-0.12.3
+ >=media-libs/libraw-0.13.2:=
+ >=media-libs/libexif-0.6.16
+ app-crypt/libsecret
+ >=dev-libs/libportal-0.5:=[gtk]
+ media-libs/libwebp:=
+
+ >=app-crypt/gcr-3:0=[gtk]
+ x11-libs/cairo
+ opencv? ( >=media-libs/opencv-4.0.0:= )
+"
+RDEPEND="${DEPEND}
+ media-plugins/gst-plugins-gdkpixbuf:1.0
+ media-plugins/gst-plugins-meta:1.0
+"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-libs/glib
+ dev-util/gdbus-codegen
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ net-libs/libsoup:3.0[vala]
+ media-libs/gexiv2[vala]
+ app-crypt/gcr:0[vala]
+"
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dunity_support=false
+ # -Dpublishers # In 0.30.2 all get compiled in anyways, even if restricted list, affects only runtime support
+ #trace
+ #measure
+ -Ddupe_detection=true
+ $(meson_use udev)
+ -Dinstall_apport_hook=false
+ $(meson_use opencv face_detection)
+ -Dfatal_warnings=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ optfeature "Enable support for the AVIF format" media-libs/libavif[gdk-pixbuf]
+ optfeature "Enable support for the HEIF format" media-libs/libheif[gdk-pixbuf]
+ optfeature "Enable support for the JPEG format" x11-libs/gdk-pixbuf[jpeg]
+ optfeature "Enable support for the TIFF format" x11-libs/gdk-pixbuf[tiff]
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}