summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-15 22:51:45 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-15 22:53:23 -0400
commitc1fbb93535c73aa3dde578d391f9e7fce71ca81d (patch)
treeac252156e13760e3653d8cd2eb080d1b64be1dab
parentapp-portage/iwdevtools: drop 0.11.6 (diff)
downloadgentoo-c1fbb93535c73aa3dde578d391f9e7fce71ca81d.tar.gz
gentoo-c1fbb93535c73aa3dde578d391f9e7fce71ca81d.tar.bz2
gentoo-c1fbb93535c73aa3dde578d391f9e7fce71ca81d.zip
app-portage/iwdevtools: add 0.11.8
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--app-portage/iwdevtools/Manifest1
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.11.8.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index f4655ead52a9..a02f224116ad 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1 +1,2 @@
DIST iwdevtools-0.11.7.tar.gz 86578 BLAKE2B 1945f99ab5d516bdef7081e13ecb0921728497f84e5e5248b2ddea78b306f185a0952a664165b4bae6c2089ddd1a4423d26524f42631a53b75fd2749a6994721 SHA512 fe18a88d166f239581bdddb0c719bf1d7789f671df151d87844b1836d134754d731114250ae2a9ef5b1a37a403615c15bbd6174eeeec3fe275e93c32ce6fae5c
+DIST iwdevtools-0.11.8.tar.gz 86740 BLAKE2B 3c91f39c37f96d0f619f13ff632b89752cd1e1f3307597c0d103d32c4894d183ded3f301e74fbcb87bea2227ba73ca9cf9fdf87087d984c9f095e7d06f903891 SHA512 50457e81cece003d384a2418a486490c43da12f10b466688b221e9dc910b14ccf559834363d970e19e0f85273c17fef8c2b124d3adfbd3a48548192e93108cca
diff --git a/app-portage/iwdevtools/iwdevtools-0.11.8.ebuild b/app-portage/iwdevtools/iwdevtools-0.11.8.ebuild
new file mode 100644
index 000000000000..68858249d8a0
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.11.8.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools"
+SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ >=app-shells/bash-5.1
+ dev-libs/libxml2:2
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ || ( sys-apps/util-linux app-misc/getopt )"
+BDEPEND="
+ sys-apps/help2man
+ || ( sys-apps/util-linux app-misc/getopt )
+ test? ( ${RDEPEND} )"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ -Dshellcheck=false
+ $(meson_use test)
+ )
+
+ has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Optional portage integration relies on using /etc/portage/bashrc."
+ elog "The example bashrc can be used as-is if not already using one:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "Otherwise, inspect the tools' --help output and the example to integrate"
+ elog "(if not defining the same phase functions, the example can be sourced)."
+ elog
+ elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
+ elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
+ elog
+ elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
+ fi
+}