summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-07 19:01:58 +0000
committerSam James <sam@gentoo.org>2021-01-07 19:01:58 +0000
commitc202f939cfbd90e688d0bf0756d9165920c4d88e (patch)
treeba805e4edb6baffd38b06377c33e30ac238cfc3c
parentapp-misc/figlet: cleanup old (diff)
downloadgentoo-c202f939.tar.gz
gentoo-c202f939.tar.bz2
gentoo-c202f939.zip
media-libs/x264: cleanup old
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/x264/Manifest1
-rw-r--r--media-libs/x264/x264-0.0.20190214.ebuild65
-rw-r--r--media-libs/x264/x264-0.0.20190903.ebuild65
3 files changed, 0 insertions, 131 deletions
diff --git a/media-libs/x264/Manifest b/media-libs/x264/Manifest
index fd3a99264506..c1e5f3cbddf9 100644
--- a/media-libs/x264/Manifest
+++ b/media-libs/x264/Manifest
@@ -1,2 +1 @@
-DIST x264-snapshot-20190214-2245.tar.bz2 770462 BLAKE2B d90a3bafb88febe12526b225617616a62c32fa3d3eacf410267e1fbd7e0fafaadca7c146172c08fc525bce8791d81c7d87dc27b06d61a6a44bf2ad92f6c1def6 SHA512 c8b1b46d4e6c0ef653dab35083a454c635ebf72c6a5255ce30bbb5d9d6bb8e23fca0e6cc197ea99f3c702fbfec096587df6fa82dec338d8bd45e35fa89c43039
DIST x264-snapshot-20190903-2245.tar.bz2 774515 BLAKE2B 0b19fc1d3cedea32bfac9c5247bce7b3c04dead35458d61f3b5c0694040dc852b0110b620faf4118ed265a5605aafce3c49d468d38fb91e4c515b2860c486920 SHA512 c357c9025ffdf653c974eb7ccc2e9a4de86c02881372a6a8270ae59ce948c284da48a2aba37763bd29359d2a6dfc76ea56a52fed6082f8483912c8f948488a2d
diff --git a/media-libs/x264/x264-0.0.20190214.ebuild b/media-libs/x264/x264-0.0.20190214.ebuild
deleted file mode 100644
index afad6f3e086f..000000000000
--- a/media-libs/x264/x264-0.0.20190214.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic multilib-minimal toolchain-funcs
-
-DESCRIPTION="A free library for encoding X264/AVC streams"
-HOMEPAGE="https://www.videolan.org/developers/x264.html"
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://code.videolan.org/videolan/x264.git"
-else
- MY_P="x264-snapshot-$(ver_cut 3)-2245"
- SRC_URI="https://download.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
- S="${WORKDIR}/${MY_P}"
-fi
-
-SLOT="0/157" # SONAME
-
-LICENSE="GPL-2"
-IUSE="altivec +interlaced opencl pic static-libs cpu_flags_x86_sse +threads"
-
-ASM_DEP=">=dev-lang/nasm-2.13"
-DEPEND="abi_x86_32? ( ${ASM_DEP} )
- abi_x86_64? ( ${ASM_DEP} )
- opencl? ( dev-lang/perl )"
-RDEPEND="opencl? ( >=virtual/opencl-0-r3[${MULTILIB_USEDEP}] )"
-
-DOCS=( AUTHORS doc/{ratecontrol,regression_test,standards,threads,vui}.txt )
-
-multilib_src_configure() {
- tc-export CC
-
- if [[ ${ABI} == x86 || ${ABI} == amd64 ]]; then
- export AS="nasm"
- else
- export AS="${CC}"
- fi
-
- local asm_conf=""
-
- if [[ ${ABI} == x86* ]] && { use pic || use !cpu_flags_x86_sse ; } || [[ ${ABI} == "x32" ]] || [[ ${CHOST} == armv5* ]] || [[ ${ABI} == ppc* ]] && { use !altivec ; }; then
- asm_conf=" --disable-asm"
- fi
-
- "${S}/configure" \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --disable-cli \
- --disable-avs \
- --disable-lavf \
- --disable-swscale \
- --disable-ffms \
- --disable-gpac \
- --enable-pic \
- --enable-shared \
- --host="${CHOST}" \
- $(usex interlaced "" "--disable-interlaced") \
- $(usex opencl "" "--disable-opencl") \
- $(usex static-libs "--enable-static" "") \
- $(usex threads "" "--disable-thread") \
- ${asm_conf} || die
-}
diff --git a/media-libs/x264/x264-0.0.20190903.ebuild b/media-libs/x264/x264-0.0.20190903.ebuild
deleted file mode 100644
index 51c45d66d468..000000000000
--- a/media-libs/x264/x264-0.0.20190903.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic multilib-minimal toolchain-funcs
-
-DESCRIPTION="A free library for encoding X264/AVC streams"
-HOMEPAGE="https://www.videolan.org/developers/x264.html"
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://code.videolan.org/videolan/x264.git"
-else
- MY_P="x264-snapshot-$(ver_cut 3)-2245"
- SRC_URI="https://download.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
- S="${WORKDIR}/${MY_P}"
-fi
-
-SLOT="0/157" # SONAME
-
-LICENSE="GPL-2"
-IUSE="cpu_flags_ppc_altivec +interlaced opencl pic static-libs cpu_flags_x86_sse +threads"
-
-ASM_DEP=">=dev-lang/nasm-2.13"
-DEPEND="abi_x86_32? ( ${ASM_DEP} )
- abi_x86_64? ( ${ASM_DEP} )
- opencl? ( dev-lang/perl )"
-RDEPEND="opencl? ( >=virtual/opencl-0-r3[${MULTILIB_USEDEP}] )"
-
-DOCS=( AUTHORS doc/{ratecontrol,regression_test,standards,threads,vui}.txt )
-
-multilib_src_configure() {
- tc-export CC
-
- if [[ ${ABI} == x86 || ${ABI} == amd64 ]]; then
- export AS="nasm"
- else
- export AS="${CC}"
- fi
-
- local asm_conf=""
-
- if [[ ${ABI} == x86* ]] && { use pic || use !cpu_flags_x86_sse ; } || [[ ${ABI} == "x32" ]] || [[ ${CHOST} == armv5* ]] || [[ ${ABI} == ppc* ]] && { use !cpu_flags_ppc_altivec ; }; then
- asm_conf=" --disable-asm"
- fi
-
- "${S}/configure" \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --disable-cli \
- --disable-avs \
- --disable-lavf \
- --disable-swscale \
- --disable-ffms \
- --disable-gpac \
- --enable-pic \
- --enable-shared \
- --host="${CHOST}" \
- $(usex interlaced "" "--disable-interlaced") \
- $(usex opencl "" "--disable-opencl") \
- $(usex static-libs "--enable-static" "") \
- $(usex threads "" "--disable-thread") \
- ${asm_conf} || die
-}