summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-03-31 12:53:49 +0200
committerJeroen Roovers <jer@gentoo.org>2018-03-31 12:53:49 +0200
commitc2127970eb736221fcf799fe8b2f3cf2dfcd6df3 (patch)
tree5f9259e709704b5b21b134835031b1efeacc1bdd
parentapp-arch/dpkg: Old. (diff)
downloadgentoo-c2127970.tar.gz
gentoo-c2127970.tar.bz2
gentoo-c2127970.zip
dev-util/debootstrap: Version 1.0.95.
Package-Manager: Portage-2.3.27, Repoman-2.3.9
-rw-r--r--dev-util/debootstrap/Manifest1
-rw-r--r--dev-util/debootstrap/debootstrap-1.0.95.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/debootstrap/Manifest b/dev-util/debootstrap/Manifest
index d06615ab92e4..9202bf4f4451 100644
--- a/dev-util/debootstrap/Manifest
+++ b/dev-util/debootstrap/Manifest
@@ -1,4 +1,5 @@
DIST debootstrap_1.0.89.tar.gz 69020 BLAKE2B 9175d0936b6c9a28a29ee1b24bd835c41aaf807bc24a029201aaa45d07789206ee06e38b0a70c1e507ab448a3ec9c0fded2838bfb868334270b5159b34cbe9eb SHA512 3f230ce3eff6359353d106c806ce395861fb47fc1416eb0b498af7ce12a45ce7572b18284633d6d4d07b73a4a203e03bc205df3eae0db6f637237d25d0a69b1a
DIST debootstrap_1.0.92.tar.gz 70042 BLAKE2B d2e42f876c1bcc03d6159f1bbedaa26fece48d11cc847315711c2e89b4d313d98e7394515a319cda0f1fd857965878227862fd5255b50d6e0ccd433c7002f6eb SHA512 42d6cdeb1efbe95d9215522648d87165326ae1b5a024608abd476a6b3889c8c04420a0f29f5eb9cfd2e57adb4aa57a606519b09e356d0442cd4a4a0f6f45f656
DIST debootstrap_1.0.93.tar.gz 70695 BLAKE2B e0d5747dce7e2c45f5aec271b3a6f1e004ae19e58747abaa10d258f4e16383d305da28aad3a72c51e8ea513ffc15f61980ff27e141de69af5e259572b1afd089 SHA512 c5947a0aafd8f526236d98fe3da3374ef02a69b089844c89a3f5bb5f991fa29d8c2a4ecdbbc84a69a85eca242c628cd592c22e59f444b65c581b8a70d60a3f01
+DIST debootstrap_1.0.95.tar.gz 68631 BLAKE2B e102be7f263426506c5896b50f34c918d76d265e31eaac3f85b0471e6bfede598ef7ffbaaae726d03017b4bd94d482d4267ce02a67226e310687e8c70f88fe6c SHA512 cf2c32430325b19c61de6ef782d7df68a740812faf5f464d837b5b612b9ba0539f8c12876ce23ba20cc1aa23908eb4f45ca602798ee0a6eacf7489c45c5dc7cc
DIST devices.tar.gz 47835 BLAKE2B 03bfe097fda12a7a0aa19d3308c0d44382ad945defea05a63b17a72e4051ef94f0e60e75bde35baeace81da59d9f04126f6e463163609475b9c0fdf518f533ef SHA512 994ec8d72e3d52d2d872f7ff0da2336e4cbd3a5fa73bb6cdb9e06f5e7f5b8c69cea639c738fdba1186f382d6dcf62e7746fface664bfbd744aac24b16f034432
diff --git a/dev-util/debootstrap/debootstrap-1.0.95.ebuild b/dev-util/debootstrap/debootstrap-1.0.95.ebuild
new file mode 100644
index 000000000000..93ffd5d2d1aa
--- /dev/null
+++ b/dev-util/debootstrap/debootstrap-1.0.95.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Debian/Ubuntu bootstrap scripts"
+HOMEPAGE="https://packages.qa.debian.org/d/debootstrap.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz
+ mirror://gentoo/devices.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-arch/dpkg
+ net-misc/wget
+ sys-devel/binutils
+"
+DOCS=( TODO debian/changelog )
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+ cp "${DISTDIR}"/devices.tar.gz "${S}"
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ default
+ doman debootstrap.8
+}
+
+pkg_postinst() {
+ if ! has_version ${CATEGORY}/${PN} && ! has_version app-crypt/gnupg; then
+ elog "To check Release files against a keyring (--keyring=K), please"
+ elog "install app-crypt/gnupg"
+ fi
+
+ if ! has_version app-crypt/debian-archive-keyring || ! has_version app-crypt/ubuntu-keyring; then
+ elog "To check Release files from Debian or Ubuntu, please install"
+ elog " app-crypt/debian-archive-keyring or"
+ elog " app-crypt/ubuntu-keyring as required"
+ fi
+}