summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-07-30 18:39:16 -0400
committerMike Gilbert <floppym@gentoo.org>2022-07-31 12:55:01 -0400
commitc2204cc82792abe8ba280740fb441d440ceb5055 (patch)
tree8da360c32827a7577d5eb111384a1f2506ebf4cd
parentapp-portage/metagen: keyword 0.7.3-r1 for ~riscv (diff)
downloadgentoo-c2204cc8.tar.gz
gentoo-c2204cc8.tar.bz2
gentoo-c2204cc8.zip
app-shells/bash: rename builtins.1 to bash_builtins.1
This seems to be the intended name based on doc/Makefile.in. This also fixes a rendering issue when the man pages are viewed with mandoc. Closes: https://github.com/gentoo/gentoo/pull/26669 Closes: https://github.com/gentoo/gentoo/pull/26673 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--app-shells/bash/bash-5.1_p16-r1.ebuild (renamed from app-shells/bash/bash-5.1_p16.ebuild)6
-rw-r--r--app-shells/bash/bash-5.2_rc2-r1.ebuild (renamed from app-shells/bash/bash-5.2_rc2.ebuild)6
-rw-r--r--app-shells/bash/bash-9999.ebuild6
3 files changed, 15 insertions, 3 deletions
diff --git a/app-shells/bash/bash-5.1_p16.ebuild b/app-shells/bash/bash-5.1_p16-r1.ebuild
index 43292ec1f762..e7efd65fd661 100644
--- a/app-shells/bash/bash-5.1_p16.ebuild
+++ b/app-shells/bash/bash-5.1_p16-r1.ebuild
@@ -270,7 +270,11 @@ src_install() {
done
fi
- doman doc/*.1
+ # Install bash_builtins.1 and rbash.1
+ emake -C doc DESTDIR="${D}" install_builtins
+ sed 's:bash\.1:man1/&:' doc/rbash.1 > "${T}"/rbash.1 || die
+ doman "${T}"/rbash.1
+
newdoc CWRU/changelog ChangeLog
dosym bash.info /usr/share/info/bashref.info
}
diff --git a/app-shells/bash/bash-5.2_rc2.ebuild b/app-shells/bash/bash-5.2_rc2-r1.ebuild
index 4effa61a8843..3fa9e5592430 100644
--- a/app-shells/bash/bash-5.2_rc2.ebuild
+++ b/app-shells/bash/bash-5.2_rc2-r1.ebuild
@@ -294,7 +294,11 @@ src_install() {
done
fi
- doman doc/*.1
+ # Install bash_builtins.1 and rbash.1
+ emake -C doc DESTDIR="${D}" install_builtins
+ sed 's:bash\.1:man1/&:' doc/rbash.1 > "${T}"/rbash.1 || die
+ doman "${T}"/rbash.1
+
newdoc CWRU/changelog ChangeLog
dosym bash.info /usr/share/info/bashref.info
}
diff --git a/app-shells/bash/bash-9999.ebuild b/app-shells/bash/bash-9999.ebuild
index 6e82b8f94a03..065cb2bc6dee 100644
--- a/app-shells/bash/bash-9999.ebuild
+++ b/app-shells/bash/bash-9999.ebuild
@@ -294,7 +294,11 @@ src_install() {
done
fi
- doman doc/*.1
+ # Install bash_builtins.1 and rbash.1
+ emake -C doc DESTDIR="${D}" install_builtins
+ sed 's:bash\.1:man1/&:' doc/rbash.1 > "${T}"/rbash.1 || die
+ doman "${T}"/rbash.1
+
newdoc CWRU/changelog ChangeLog
dosym bash.info /usr/share/info/bashref.info
}