summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-29 03:37:44 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-29 04:04:54 +0100
commitc23131c950daab17344b3a58f471b7a8fe9ca91a (patch)
treef9d723e04c40a8088307e2f4581fd3a4ba59caf8
parentdev-lang/dafny: bump to 4.6.0 (diff)
downloadgentoo-c23131c950daab17344b3a58f471b7a8fe9ca91a.tar.gz
gentoo-c23131c950daab17344b3a58f471b7a8fe9ca91a.tar.bz2
gentoo-c23131c950daab17344b3a58f471b7a8fe9ca91a.zip
app-containers/distrobox: bump to 1.7.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-containers/distrobox/Manifest1
-rw-r--r--app-containers/distrobox/distrobox-1.7.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-containers/distrobox/Manifest b/app-containers/distrobox/Manifest
index a5e9fd82f380..ef9c8201ce3a 100644
--- a/app-containers/distrobox/Manifest
+++ b/app-containers/distrobox/Manifest
@@ -1,2 +1,3 @@
DIST distrobox-1.6.0.1.tar.gz 6751373 BLAKE2B 9d82f33e15be8a2c17b7716ddbecf4fc533f971924c36ba8fa009dac7a87fbc26075ca98d6c58c5974fa1a02657419f26b415925d71f6577a8897a9e199950fc SHA512 cc7bd42b1c7e198eb255b6bdd90a76fa25700edc274b14379ffe3199c8a8cadc9ab27c94f43ee4a92d270b65df7b04e6c11441eb68456fe7ec3d56b2879534f2
DIST distrobox-1.7.0.1.tar.gz 6756031 BLAKE2B 320dde2bdf005c5bd66954f212547adb6bbd6d06611272c6a1b1859eef7ad47dbbbf300baaef555e2bf9a750def117ec69418affb75514652aa0e366314fbaf2 SHA512 971a3f15216d2dfa2829a1ea085c7579c4f0bf0e57678474f83df05ae8c897db8a8cd477a429d0126cad11ac0379029b9c759944cea8649971e67f20a3e18328
+DIST distrobox-1.7.1.tar.gz 6885484 BLAKE2B c4b2710d7f1cff7baee2e340a79345359e9906e508e8b1bc351a7b8ee2d8d2e1cb13c381e40231f8c962542e37e32988d04a687810bdfd7ec917868944c51cf3 SHA512 a86a49b9f6158af3172369a201ce3852a349258c46ebb8dfb269f7b96dfbe2bf2fe9f80a5cf9b9236432d99f4f67fb3d95ab4663964fcdb0f888d48cbdd82c39
diff --git a/app-containers/distrobox/distrobox-1.7.1.ebuild b/app-containers/distrobox/distrobox-1.7.1.ebuild
new file mode 100644
index 000000000000..ddd8a782dfb3
--- /dev/null
+++ b/app-containers/distrobox/distrobox-1.7.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Use any Linux distribution inside your terminal (powered by docker/podman)"
+HOMEPAGE="https://distrobox.privatedns.org/
+ https://github.com/89luca89/distrobox/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/89luca89/${PN}.git"
+else
+ SRC_URI="https://github.com/89luca89/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3" # GPL-3.0-only !
+SLOT="0"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+src_install() {
+ sh ./install --prefix "${ED}/usr" || die "${PN} install script failed"
+
+ dodoc *.md
+}