summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2022-03-29 10:13:26 +0200
committerDirkjan Ochtman <djc@gentoo.org>2022-03-29 10:13:26 +0200
commitc233a7e833165d0cf86479d51c894ce8c58a32dd (patch)
treef9a074acfebd9b326d9116b7a6c6392eba695ca5
parentapp-editors/zile: amd64 stable wrt bug #835557 (diff)
downloadgentoo-c233a7e833165d0cf86479d51c894ce8c58a32dd.tar.gz
gentoo-c233a7e833165d0cf86479d51c894ce8c58a32dd.tar.bz2
gentoo-c233a7e833165d0cf86479d51c894ce8c58a32dd.zip
app-text/pelican: version bump to 4.7.2
Closes: https://bugs.gentoo.org/show_bug.cgi?id=836337 Closes: https://bugs.gentoo.org/show_bug.cgi?id=836336 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Dirkjan Ochtman <djc@gentoo.org>
-rw-r--r--app-text/pelican/Manifest1
-rw-r--r--app-text/pelican/pelican-4.7.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-text/pelican/Manifest b/app-text/pelican/Manifest
index b883eb6230cb..a900cf6df054 100644
--- a/app-text/pelican/Manifest
+++ b/app-text/pelican/Manifest
@@ -1 +1,2 @@
DIST pelican-4.5.3.tar.gz 1397896 BLAKE2B 86651f627af67c571ea65a7ddfe7b62747fd2798575d6c4f29455da9b2371ce22ff42d715f148925724764e0a9fbb8aeba1dea401226856d3681b520dbb0a7af SHA512 b1ef5f145b448f6af2e25a1adb399521d4c5f7eef3ee2aa5ab9e50c223623b5c9961622e5cd835a3cb72dbbe905da6ac9217128f2459a35892bbac9b9cb6d26a
+DIST pelican-4.7.2.tar.gz 1401737 BLAKE2B c277844c0c153f71aae051dd8897e9abf8fd1ddc7c49251aaa7b85b7324a85da0ded74e8328a4b64ec79b8e6b4e143d5496b8535900c8a88bfa6198489c0a80c SHA512 9fbf2ecb3c193e976e01a4d095095ac55d56fe45aa24467d91635bbecb9df933ccabd6a456e14c6ee14ce0a845820be8d887917af314e13c7a3eb830cb0ce7e6
diff --git a/app-text/pelican/pelican-4.7.2.ebuild b/app-text/pelican/pelican-4.7.2.ebuild
new file mode 100644
index 000000000000..bc44f2e4f3c2
--- /dev/null
+++ b/app-text/pelican/pelican-4.7.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to generate a static blog, with restructured text or markdown input files"
+HOMEPAGE="https://blog.getpelican.com/ https://pypi.org/project/pelican/"
+SRC_URI="https://github.com/getpelican/pelican/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples markdown"
+
+RESTRICT="test"
+RDEPEND=">=dev-python/feedgenerator-1.9[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ markdown? ( dev-python/markdown[${PYTHON_USEDEP}] )"
+DEPEND="test? ( dev-python/markdown[${PYTHON_USEDEP}] )"
+
+DOCS=( README.rst )
+
+distutils_enable_tests nose
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ if use examples; then
+ insinto "/usr/share/doc/${PF}"
+ docompress -x "/usr/share/doc/${PF}/samples"
+ doins -r samples
+ fi
+ distutils-r1_python_install_all
+}