summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-06-06 10:17:20 +0200
committerMichał Górny <mgorny@gentoo.org>2018-06-06 10:23:08 +0200
commitc23c7b1745c7e21db7f021f7f7faaf51a2575c97 (patch)
tree19730a3b871927424b5f3dc5b240bec5a770b4b8
parentnet-wireless/gr-osmosdr: Drop old (diff)
downloadgentoo-c23c7b1745c7e21db7f021f7f7faaf51a2575c97.tar.gz
gentoo-c23c7b1745c7e21db7f021f7f7faaf51a2575c97.tar.bz2
gentoo-c23c7b1745c7e21db7f021f7f7faaf51a2575c97.zip
dev-python/clang-python: Fix handling test failures
Fix handling test failurse to die on any implementation failing, rather than only on the last one tested.
-rw-r--r--dev-python/clang-python/clang-python-5.0.2.ebuild8
-rw-r--r--dev-python/clang-python/clang-python-6.0.0.ebuild6
-rw-r--r--dev-python/clang-python/clang-python-6.0.9999.ebuild6
-rw-r--r--dev-python/clang-python/clang-python-9999.ebuild8
4 files changed, 22 insertions, 6 deletions
diff --git a/dev-python/clang-python/clang-python-5.0.2.ebuild b/dev-python/clang-python/clang-python-5.0.2.ebuild
index f60acf5217fa..4331a4a3bf5f 100644
--- a/dev-python/clang-python/clang-python-5.0.2.ebuild
+++ b/dev-python/clang-python/clang-python-5.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -34,8 +34,12 @@ src_unpack() {
tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/bindings/python" || die
}
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}
+
src_test() {
- python_foreach_impl nosetests -v || die
+ python_foreach_impl python_test
}
src_install() {
diff --git a/dev-python/clang-python/clang-python-6.0.0.ebuild b/dev-python/clang-python/clang-python-6.0.0.ebuild
index 6abf574e9b93..5d6eaf45c6cd 100644
--- a/dev-python/clang-python/clang-python-6.0.0.ebuild
+++ b/dev-python/clang-python/clang-python-6.0.0.ebuild
@@ -34,8 +34,12 @@ src_unpack() {
tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/bindings/python" || die
}
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
src_test() {
- python_foreach_impl python -m unittest discover -v || die
+ python_foreach_impl python_test
}
src_install() {
diff --git a/dev-python/clang-python/clang-python-6.0.9999.ebuild b/dev-python/clang-python/clang-python-6.0.9999.ebuild
index e0aa3318ebd9..89b1f72d475d 100644
--- a/dev-python/clang-python/clang-python-6.0.9999.ebuild
+++ b/dev-python/clang-python/clang-python-6.0.9999.ebuild
@@ -36,8 +36,12 @@ src_unpack() {
git-r3_checkout '' '' '' bindings/python
}
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
src_test() {
- python_foreach_impl python -m unittest discover -v || die
+ python_foreach_impl python_test
}
src_install() {
diff --git a/dev-python/clang-python/clang-python-9999.ebuild b/dev-python/clang-python/clang-python-9999.ebuild
index 0e636d4e4c11..cf488945799b 100644
--- a/dev-python/clang-python/clang-python-9999.ebuild
+++ b/dev-python/clang-python/clang-python-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -35,8 +35,12 @@ src_unpack() {
git-r3_checkout '' '' '' bindings/python
}
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
src_test() {
- python_foreach_impl python -m unittest discover -v || die
+ python_foreach_impl python_test
}
src_install() {