summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-30 01:52:00 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-30 02:41:49 +1300
commitc2570b706d4e7e1777ecf4680986d6719ba584f5 (patch)
tree7007faf76c27cbcf5e6c4de2e1ace919286bc90a
parentdev-util/cookiecutter: Version bumps (diff)
downloadgentoo-c2570b70.tar.gz
gentoo-c2570b70.tar.bz2
gentoo-c2570b70.zip
dev-perl/libintl-perl: Bump to version 1.280.0
- Drop hedging of de_AT ( advertised fixed upstream ) - Rework patch due to source changes Upstream: - Fixed false negatives in test suite - New class methods options, keywords, flags, for Locale::TextDomain - Don't require modules from relative paths - Don't generate files in distribution - Skip XS tests without explicit enabling - Check applicability of de_AT test - Disable translation tests on localeless systems Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--dev-perl/libintl-perl/Manifest1
-rw-r--r--dev-perl/libintl-perl/files/libintl-perl-1.280.0-sanity-2.patch65
-rw-r--r--dev-perl/libintl-perl/libintl-perl-1.280.0.ebuild23
-rw-r--r--dev-perl/libintl-perl/metadata.xml2
4 files changed, 90 insertions, 1 deletions
diff --git a/dev-perl/libintl-perl/Manifest b/dev-perl/libintl-perl/Manifest
index f75668120f4e..2f09d2b04627 100644
--- a/dev-perl/libintl-perl/Manifest
+++ b/dev-perl/libintl-perl/Manifest
@@ -1,2 +1,3 @@
DIST libintl-perl-1.20.tar.gz 499899 SHA256 3036a9d2df85f200631b55a0b01082898c20819d9aabdb9b871508054bee5c67 SHA512 7d3ff7b1b48c2e5d1bcf07ce9e4519d3146acee04314709ccbfdfc54fb6d5d2583468bb72532115c423de9853364d4912c7a2ecffdd7132e5a4af59cca509db1 WHIRLPOOL 3509d0e9b4f671dd056cc53ef715bce3ae95bd02905f7ceed1aaee66d33278aeb34aa1f2166a64cbb557d2cafe9654324abc1267f0d8ab469f6dcedf7ba77e67
DIST libintl-perl-1.24.tar.gz 605626 SHA256 d8d5e95f5553e1a624c3f8bf0cd42f4a46d67bcf83291d5bd6c81c9be2f261a2 SHA512 1c2c5d6d7ab21c45897195952a9f0f6ba26a9bbb7bfef0b5f3e9da282fcf94ab4ee80721164e5e3293d8abda0158e77ffbc331b8bed66aa56dd7fc7a6a91323d WHIRLPOOL e29989dd61c3d2305b1167b3242323e527d10095bd5a4185f7ab7aff4f6a5a9505f02cb244064eed0be2401a76ec00326e754254e854344e0af302aa8fc41aed
+DIST libintl-perl-1.28.tar.gz 470898 SHA256 7bebf2fb1b6d612dbee206693eac4707e185a3e85298683ec5944916b7cb4ebd SHA512 50f0836c1a84a22fcc8fca0fff2faeaae66774ec67b96c09a911c4969e8a610bbf20ba38167c13339b9ad9617e1fca07cb0cb1f12732f973b1cf618d502f59aa WHIRLPOOL 68319f1c34cf62f21ff398ae63a048a4f730e66a7e9a1ba936de95cdcbb8dd480681d0f5fad48cc91542bd6c83fa30a0c83255a6b8f5b5968454759686edd3d4
diff --git a/dev-perl/libintl-perl/files/libintl-perl-1.280.0-sanity-2.patch b/dev-perl/libintl-perl/files/libintl-perl-1.280.0-sanity-2.patch
new file mode 100644
index 000000000000..456ea3349a90
--- /dev/null
+++ b/dev-perl/libintl-perl/files/libintl-perl-1.280.0-sanity-2.patch
@@ -0,0 +1,65 @@
+From fbc3111eec0b71d247d6588bf1f9397bae558a29 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
+Date: Wed, 1 Jun 2016 00:06:12 +0200
+Subject: Minimal build system patching
+
+Bug: https://bugs.gentoo.org/584636
+---
+ Makefile.PL | 41 -----------------------------------------
+ 1 file changed, 41 deletions(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 97d88bf..e23dc89 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -163,47 +163,6 @@ EOC
+
+ package MY;
+
+-# FIXME: This is really a hack! Problem: Depending on the build system,
+-# we may or may not build and install the XS version. If the XS version
+-# is being built, the directory blib/arch will be populated, if it is
+-# not being built, blib/arch will be empty. Unfortunately, if blib/arch
+-# is not empty, *all* library files will be installed in the architecture
+-# dependent locations, if it is empty, they will be installed in the
+-# architecture independent tree.
+-#
+-# Unfortunately, ExtUtils::MakeMaker does not take care of uninstalling
+-# files from previous installations. Consequently, we cannot determine
+-# which version of the library will be loaded, since this depends on the
+-# current value of @INC.
+-#
+-# The solution does not really make me happy. The Makefile will be patched,
+-# so that instead of ExtUtils::Install a custom module MyInstall.pm will
+-# be used. This custom module overwrites the subroutine that detects
+-# whether a directory is empty in ExtUtils::Install, and will lie if that
+-# directory happens to be "blib/arch". This little hack effectively disables
+-# the annoying behavior of ExtUtils::Install (and I sincerely hope that
+-# this is portable).
+-sub libscan
+-{
+- my ($self, $file) = @_;
+-
+- return if 'MyInstall.pm' eq $file;
+-
+- $self->SUPER::libscan ($file);
+-}
+-
+-sub tools_other
+-{
+- my $self = shift;
+-
+- my $fragment = $self->SUPER::tools_other (@_);
+-
+- $fragment =~ s/^MOD_INSTALL\s*=\s*(.*?)-MExtUtils::Install
+- /MOD_INSTALL =$1-I. -MMyInstall/msx;
+-
+- return $fragment;
+-}
+-
+ package main;
+
+ my $name = $0;
+--
+2.14.3
+
diff --git a/dev-perl/libintl-perl/libintl-perl-1.280.0.ebuild b/dev-perl/libintl-perl/libintl-perl-1.280.0.ebuild
new file mode 100644
index 000000000000..3259b10197c4
--- /dev/null
+++ b/dev-perl/libintl-perl/libintl-perl-1.280.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=GUIDO
+DIST_VERSION=1.28
+inherit perl-module
+
+DESCRIPTION="High-Level Interface to Uniforum Message Translation"
+HOMEPAGE="http://guido-flohr.net/projects/libintl-perl ${HOMEPAGE}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+PATCHES=( "${FILESDIR}/${P}-sanity-2.patch" )
diff --git a/dev-perl/libintl-perl/metadata.xml b/dev-perl/libintl-perl/metadata.xml
index 017b791bc859..642af8f58061 100644
--- a/dev-perl/libintl-perl/metadata.xml
+++ b/dev-perl/libintl-perl/metadata.xml
@@ -152,10 +152,10 @@
<remote-id type="cpan-module">Locale::RecodeData::_Encode</remote-id>
<remote-id type="cpan-module">Locale::TextDomain</remote-id>
<remote-id type="cpan-module">Locale::Util</remote-id>
+ <remote-id type="cpan-module">Locale::gettext_dumb</remote-id>
<remote-id type="cpan-module">Locale::gettext_pp</remote-id>
<remote-id type="cpan-module">Locale::gettext_xs</remote-id>
<remote-id type="cpan-module">MyInstall</remote-id>
<remote-id type="cpan-module">SimpleCal</remote-id>
- <remote-id type="cpan-module">__TiedTextDomain</remote-id>
</upstream>
</pkgmetadata>