summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2023-01-02 10:30:06 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-01-02 12:36:50 +0100
commitc25cf605654ce46033649d0f2599218611b0a537 (patch)
tree7c41473999338ac9894f84658bb72a9d88db2b01
parentgames-emulation/pcsx2: add comment about upstream (diff)
downloadgentoo-c25cf605.tar.gz
gentoo-c25cf605.tar.bz2
gentoo-c25cf605.zip
sci-geosciences/josm-bin: version bump to 18621
Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/28935 Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--sci-geosciences/josm-bin/Manifest1
-rw-r--r--sci-geosciences/josm-bin/josm-bin-18621.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sci-geosciences/josm-bin/Manifest b/sci-geosciences/josm-bin/Manifest
index aac79c523a07..2d1ff565ff23 100644
--- a/sci-geosciences/josm-bin/Manifest
+++ b/sci-geosciences/josm-bin/Manifest
@@ -2,3 +2,4 @@ DIST josm-snapshot-18463.jar 16273803 BLAKE2B 043121ca1e7512207608dfaa549a53d705
DIST josm-snapshot-18513.jar 16216859 BLAKE2B e8b941f5e725170c03650cf8319dc92d6484c21d9138827134caeab790ba251ad5ba820398027fdf136ef7c22f4e97fd2989f49390544464e8c763fdb6fc7411 SHA512 a4772803aaa2194a0e8563c08ba81ce9cc0caf719003dcfb07d558b0036c0b59a7367f6182c111a03153e17838e8624e464897145fa6b7815620d68dfb94bd36
DIST josm-snapshot-18570.jar 16252476 BLAKE2B e69965a4075fd26921b2624668eca70b082660d376112d664eb55ee7c4cb1a9962b9a711120a24f4cabdafc7e6d4e8ab04c77d907d13a08f25156868b188ca11 SHA512 98a32266ba195b8a83701b17db900b19054fd0877d0ea1d92fccfc8f76a1c813359b2bfb7344554b2db39d56e0b700a74fd7e35e5817ea0ecacf37f472ccd3a2
DIST josm-snapshot-18583.jar 16269996 BLAKE2B 1f661090db02278a05f457093ac6ff8aff060c00ead6347e283892e114ea7bf5c0a96279dd645cf97cbb45a3bf8f8919b5523cc847f52b703b19c4bfa909f463 SHA512 04cd705e745357cc6169a2d12bf7ca9b91615201976326d52dc468921ea959f281d30ff2be8eeb2fbde9e780ca588e6240538036d2cdf66b0316def28dbbf684
+DIST josm-snapshot-18621.jar 16311452 BLAKE2B c462434be5bd664cb1799179183c4a185b1ca77fc49d773b83f8fc0ab68ccdf6d6a78c76bfd51bffdccffed86d2629b80d9a200b5929424a36c02ade53599630 SHA512 bc78931481bf011423dbef2271df16a0f286285cbdc8ef8bd9300399449b8d9837a18cf66c7cd6c238048f7ef513f24cf83d265e7e7edd0f38bd21d0d2efefaf
diff --git a/sci-geosciences/josm-bin/josm-bin-18621.ebuild b/sci-geosciences/josm-bin/josm-bin-18621.ebuild
new file mode 100644
index 000000000000..613ce5d3b132
--- /dev/null
+++ b/sci-geosciences/josm-bin/josm-bin-18621.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop java-utils-2 xdg
+
+DESCRIPTION="Java-based editor for the OpenStreetMap project"
+HOMEPAGE="https://josm.openstreetmap.de/"
+# PV should be stable here https://josm.openstreetmap.de/wiki/StartupPage
+SRC_URI="https://josm.openstreetmap.de/download/josm-snapshot-${PV}.jar"
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0 GPL-2+ GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8"
+BDEPEND="app-arch/unzip"
+
+src_install() {
+ java-pkg_newjar "${DISTDIR}/${A}" ${PN}.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+
+ local icon_size
+ for icon_size in 16 32 48; do
+ newicon -s ${icon_size} -t hicolor \
+ images/logo_${icon_size}x${icon_size}x32.png ${PN}.png
+ newicon -s ${icon_size} -t locolor \
+ images/logo_${icon_size}x${icon_size}x8.png ${PN}.png
+ done
+ make_desktop_entry ${PN} "Java OpenStreetMap Editor" ${PN} "Utility;Science;Geoscience"
+}