summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2024-03-24 08:27:44 +0000
committerPatrick Lauer <patrick@gentoo.org>2024-03-24 08:29:03 +0000
commitc26039d783061d7f8344835ec5b43c07672c6df4 (patch)
tree493a035dcd84e410860b9ed4b54028acf70b4603
parentmedia-libs/libsoundtouch: respect LDFLAGS (diff)
downloadgentoo-c26039d783061d7f8344835ec5b43c07672c6df4.tar.gz
gentoo-c26039d783061d7f8344835ec5b43c07672c6df4.tar.bz2
gentoo-c26039d783061d7f8344835ec5b43c07672c6df4.zip
net-analyzer/netdata: Fix implicit systemd dependency
Otherwise fails to build if systemd/journald not present Signed-off-by: Patrick Lauer <patrick@gentoo.org>
-rw-r--r--net-analyzer/netdata/netdata-1.45.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-analyzer/netdata/netdata-1.45.0.ebuild b/net-analyzer/netdata/netdata-1.45.0.ebuild
index 56ca10202a2c..2d2fe2aeb560 100644
--- a/net-analyzer/netdata/netdata-1.45.0.ebuild
+++ b/net-analyzer/netdata/netdata-1.45.0.ebuild
@@ -20,7 +20,7 @@ HOMEPAGE="https://github.com/netdata/netdata https://my-netdata.io/"
LICENSE="GPL-3+ MIT BSD"
SLOT="0"
-IUSE="aclk bpf cloud cups +dbengine ipmi mongodb mysql nfacct nodejs postgres prometheus +python tor xen"
+IUSE="aclk bpf cloud cups +dbengine ipmi mongodb mysql nfacct nodejs postgres prometheus +python systemd tor xen"
REQUIRED_USE="
mysql? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
@@ -78,7 +78,8 @@ RDEPEND="
xen? (
app-emulation/xen-tools
dev-libs/yajl
- )"
+ )
+ systemd? ( sys-apps/systemd )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
@@ -108,6 +109,7 @@ src_configure() {
-DENABLE_PLUGIN_XENSTAT=$(usex xen)
-DENABLE_PLUGIN_EBPF=$(usex bpf)
-DENABLE_PLUGIN_GO=FALSE
+ -DENABLE_PLUGIN_SYSTEMD_JOURNAL=$(usex systemd)
)
cmake_src_configure
}