summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-04-29 00:44:02 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2020-04-29 00:44:16 +0200
commitc2688349694c17c401694990e069ab5efeacca0a (patch)
treeb27f2bc958cfcf6daa69ed80e4196d3855e9cfae
parentgames-puzzle/world-of-goo: Drop package in favour of world-of-goo-hb (diff)
downloadgentoo-c2688349.tar.gz
gentoo-c2688349.tar.bz2
gentoo-c2688349.zip
net-misc/dibbler: move musl patch from overlay to main tree
Closes: https://bugs.gentoo.org/551818 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--net-misc/dibbler/dibbler-1.0.1-r3.ebuild63
-rw-r--r--net-misc/dibbler/files/dibbler-1.0.1-gnu-ism.patch83
2 files changed, 146 insertions, 0 deletions
diff --git a/net-misc/dibbler/dibbler-1.0.1-r3.ebuild b/net-misc/dibbler/dibbler-1.0.1-r3.ebuild
new file mode 100644
index 000000000000..8db74de7aae0
--- /dev/null
+++ b/net-misc/dibbler/dibbler-1.0.1-r3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit readme.gentoo-r1 systemd
+
+DESCRIPTION="Portable DHCPv6 implementation (server, client and relay)"
+HOMEPAGE="http://klub.com.pl/dhcpv6/"
+SRC_URI="http://klub.com.pl/dhcpv6/dibbler/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~mips ~x86"
+IUSE="doc resolvconf"
+
+RDEPEND="resolvconf? ( virtual/resolvconf )"
+DEPEND="${RDEPEND}
+ doc? (
+ || (
+ dev-texlive/texlive-latexextra
+ dev-tex/floatflt
+ )
+ )"
+
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-gnu-ism.patch
+ )
+
+DOC_CONTENTS="Make sure that you modify client.conf, server.conf and/or relay.conf
+to suit your needs. They are stored in /etc/dibbler"
+
+src_configure() {
+ econf $(use_enable resolvconf)
+}
+
+src_compile() {
+ default
+ # devel documentation is broken and users should consult the online version
+ # http://klub.com.pl/dhcpv6/doxygen/
+ use doc && emake -C doc/ user
+}
+
+src_install() {
+ default
+ readme.gentoo_create_doc
+
+ dosbin dibbler-{client,relay,server}
+ doman doc/man/*.8
+
+ insinto /etc/dibbler
+ doins doc/examples/*.conf
+ keepdir /var/lib/dibbler
+
+ dodoc AUTHORS CHANGELOG RELNOTES TODO
+ use doc && dodoc doc/dibbler-user.pdf
+
+ doinitd "${FILESDIR}"/dibbler-{client,relay,server}
+ systemd_dounit "${FILESDIR}"/dibbler-client.service
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/net-misc/dibbler/files/dibbler-1.0.1-gnu-ism.patch b/net-misc/dibbler/files/dibbler-1.0.1-gnu-ism.patch
new file mode 100644
index 000000000000..aedc3e81cbba
--- /dev/null
+++ b/net-misc/dibbler/files/dibbler-1.0.1-gnu-ism.patch
@@ -0,0 +1,83 @@
+From f8352ac6dfc61a99b1162e0fd28d30b1e9340fde Mon Sep 17 00:00:00 2001
+From: Robert Gerus <arachnist@i.am-a.cat>
+Date: Thu, 11 Jun 2015 21:34:39 +0200
+Subject: [PATCH] Compatybility patch for musl
+
+Minor header/include/typedef changes to fix compatybility with musl libc.
+Doesn't break compatybility with glibc, as far as I can tell.
+---
+ Misc/Portable.h.in | 4 ++++
+ Port-linux/ethtool-local.h | 6 +++---
+ Port-linux/lowlevel-linux-link-state.c | 4 +++-
+ Port-linux/utils.h | 5 +++++
+ 4 files changed, 15 insertions(+), 4 deletions(-)
+
+diff --git a/Misc/Portable.h.in b/Misc/Portable.h.in
+index 1a96293..2d94d0d 100644
+--- a/Misc/Portable.h.in
++++ b/Misc/Portable.h.in
+@@ -29,6 +29,10 @@
+ #include <arpa/inet.h>
+ #endif
+
++#if defined(LINUX)
++# include <sys/select.h>
++#endif
++
+ #include <stdint.h>
+ #include <unistd.h>
+
+diff --git a/Port-linux/ethtool-local.h b/Port-linux/ethtool-local.h
+index 2940090..555f06b 100644
+--- a/Port-linux/ethtool-local.h
++++ b/Port-linux/ethtool-local.h
+@@ -22,9 +22,9 @@
+ */
+
+ typedef unsigned long long u64;
+-typedef __uint32_t u32;
+-typedef __uint16_t u16;
+-typedef __uint8_t u8;
++typedef uint32_t u32;
++typedef uint16_t u16;
++typedef uint8_t u8;
+
+ #include "ethtool-kernel.h"
+
+diff --git a/Port-linux/lowlevel-linux-link-state.c b/Port-linux/lowlevel-linux-link-state.c
+index 7ca9f6b..76293ea 100644
+--- a/Port-linux/lowlevel-linux-link-state.c
++++ b/Port-linux/lowlevel-linux-link-state.c
+@@ -18,7 +18,9 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <unistd.h>
+-#include <bits/sigthread.h>
++#if defined(__GLIBC__)
++# include <bits/sigthread.h>
++#endif
+ #include "Portable.h"
+ #include "interface.h"
+
+diff --git a/Port-linux/utils.h b/Port-linux/utils.h
+index e40d95f..579dffb 100644
+--- a/Port-linux/utils.h
++++ b/Port-linux/utils.h
+@@ -1,9 +1,14 @@
+ #ifndef __UTILS_H__
+ #define __UTILS_H__ 1
+
++#ifndef _GNU_SOURCE
++# define _GNU_SOURCE 1
++#endif
++
+ #include <asm/types.h>
+ //#include <resolv.h>
+ #include <linux/types.h>
++#include <sys/types.h>
+
+ #include "libnetlink.h"
+ #include "ll_map.h"
+--
+2.4.3
+