summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2020-01-26 16:34:35 +0200
committerStefan Strogin <steils@gentoo.org>2020-02-25 07:17:13 +0200
commitc26bf678ea85fdbbbe8d3d14908cd25ca94397c4 (patch)
treee3147c2468510232699a50082cb9f55044e03e29
parentdev-ruby/tty-screen: add 0.7.1 (diff)
downloadgentoo-c26bf678.tar.gz
gentoo-c26bf678.tar.bz2
gentoo-c26bf678.zip
net-libs/nodejs: add USE=+system-ssl
For now net-libs/nodejs fails to build on LibreSSL systems. Add USE=+system-ssl which can be explicitly disabled in order to use bundled OpenSSL. Bug: https://bugs.gentoo.org/613344 Closes: https://github.com/gentoo/gentoo/pull/14460 Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Stefan Strogin <steils@gentoo.org>
-rw-r--r--net-libs/nodejs/metadata.xml1
-rw-r--r--net-libs/nodejs/nodejs-10.19.0.ebuild7
-rw-r--r--net-libs/nodejs/nodejs-12.16.1.ebuild7
-rw-r--r--net-libs/nodejs/nodejs-13.9.0.ebuild7
-rw-r--r--net-libs/nodejs/nodejs-99999999.ebuild7
5 files changed, 17 insertions, 12 deletions
diff --git a/net-libs/nodejs/metadata.xml b/net-libs/nodejs/metadata.xml
index 3f344f0d8eda..3e9bb1da9c02 100644
--- a/net-libs/nodejs/metadata.xml
+++ b/net-libs/nodejs/metadata.xml
@@ -9,6 +9,7 @@
<flag name="npm">Enable NPM package manager</flag>
<flag name="pax_kernel">Enable building under a PaX enabled kernel</flag>
<flag name="snapshot">Enable snapshot creation for faster startup</flag>
+ <flag name="system-ssl">Use system OpenSSL instead of the bundled one</flag>
<flag name="systemtap">Enable SystemTAP/DTrace tracing</flag>
</use>
</pkgmetadata>
diff --git a/net-libs/nodejs/nodejs-10.19.0.ebuild b/net-libs/nodejs/nodejs-10.19.0.ebuild
index 31d605f6adb2..db37b4f35189 100644
--- a/net-libs/nodejs/nodejs-10.19.0.ebuild
+++ b/net-libs/nodejs/nodejs-10.19.0.ebuild
@@ -13,10 +13,11 @@ SRC_URI="https://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz"
LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos"
-IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm +snapshot +ssl systemtap test"
+IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm +snapshot +ssl +system-ssl systemtap test"
REQUIRED_USE="
inspector? ( icu ssl )
npm? ( ssl )
+ system-ssl? ( ssl )
"
RDEPEND="
@@ -26,7 +27,7 @@ RDEPEND="
>=net-libs/nghttp2-1.39.2
sys-libs/zlib
icu? ( >=dev-libs/icu-64.2:= )
- ssl? ( >=dev-libs/openssl-1.1.1:0= )
+ system-ssl? ( >=dev-libs/openssl-1.1.1:0= )
"
DEPEND="
${RDEPEND}
@@ -99,7 +100,7 @@ src_configure() {
use inspector || myconf+=( --without-inspector )
use npm || myconf+=( --without-npm )
use snapshot && myconf+=( --with-snapshot )
- use ssl && myconf+=( --shared-openssl ) || myconf+=( --without-ssl )
+ use ssl && ( use system-ssl && myconf+=( --shared-openssl ) ) || myconf+=( --without-ssl )
local myarch=""
case ${ABI} in
diff --git a/net-libs/nodejs/nodejs-12.16.1.ebuild b/net-libs/nodejs/nodejs-12.16.1.ebuild
index 3850f958b73f..6c929f702786 100644
--- a/net-libs/nodejs/nodejs-12.16.1.ebuild
+++ b/net-libs/nodejs/nodejs-12.16.1.ebuild
@@ -15,10 +15,11 @@ SRC_URI="
LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos"
-IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm +snapshot +ssl systemtap test"
+IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm +snapshot +ssl +system-ssl systemtap test"
REQUIRED_USE="
inspector? ( icu ssl )
npm? ( ssl )
+ system-ssl? ( ssl )
"
RDEPEND="
@@ -28,7 +29,7 @@ RDEPEND="
>=net-libs/nghttp2-1.40.0
sys-libs/zlib
icu? ( >=dev-libs/icu-64.2:= )
- ssl? ( >=dev-libs/openssl-1.1.1:0= )
+ system-ssl? ( >=dev-libs/openssl-1.1.1:0= )
"
BDEPEND="
${PYTHON_DEPS}
@@ -106,7 +107,7 @@ src_configure() {
use inspector || myconf+=( --without-inspector )
use npm || myconf+=( --without-npm )
use snapshot || myconf+=( --without-node-snapshot )
- use ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) || myconf+=( --without-ssl )
+ use ssl && ( use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) ) || myconf+=( --without-ssl )
local myarch=""
case ${ABI} in
diff --git a/net-libs/nodejs/nodejs-13.9.0.ebuild b/net-libs/nodejs/nodejs-13.9.0.ebuild
index aefd3239857a..4d35b0880936 100644
--- a/net-libs/nodejs/nodejs-13.9.0.ebuild
+++ b/net-libs/nodejs/nodejs-13.9.0.ebuild
@@ -15,10 +15,11 @@ SRC_URI="
LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos"
-IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm pax_kernel +snapshot +ssl systemtap test"
+IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm pax_kernel +snapshot +ssl +system-ssl systemtap test"
REQUIRED_USE="
inspector? ( icu ssl )
npm? ( ssl )
+ system-ssl? ( ssl )
"
RDEPEND="
@@ -27,7 +28,7 @@ RDEPEND="
>=net-libs/nghttp2-1.40.0
sys-libs/zlib
icu? ( >=dev-libs/icu-64.2:= )
- ssl? ( >=dev-libs/openssl-1.1.1:0= )
+ system-ssl? ( >=dev-libs/openssl-1.1.1:0= )
"
BDEPEND="
${PYTHON_DEPS}
@@ -104,7 +105,7 @@ src_configure() {
use inspector || myconf+=( --without-inspector )
use npm || myconf+=( --without-npm )
use snapshot || myconf+=( --without-node-snapshot )
- use ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) || myconf+=( --without-ssl )
+ use ssl && ( use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) ) || myconf+=( --without-ssl )
local myarch=""
case ${ABI} in
diff --git a/net-libs/nodejs/nodejs-99999999.ebuild b/net-libs/nodejs/nodejs-99999999.ebuild
index 00962bc7bcbf..71618f3c5232 100644
--- a/net-libs/nodejs/nodejs-99999999.ebuild
+++ b/net-libs/nodejs/nodejs-99999999.ebuild
@@ -13,11 +13,12 @@ EGIT_REPO_URI="https://github.com/nodejs/node"
LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
SLOT="0"
KEYWORDS=""
-IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm pax_kernel +snapshot +ssl systemtap test"
+IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm pax_kernel +snapshot +ssl +system-ssl systemtap test"
RESTRICT="!test? ( test )"
REQUIRED_USE="
inspector? ( icu ssl )
npm? ( ssl )
+ system-ssl? ( ssl )
"
RDEPEND="
@@ -26,7 +27,7 @@ RDEPEND="
>=net-libs/nghttp2-1.39.2
sys-libs/zlib
icu? ( >=dev-libs/icu-64.2:= )
- ssl? ( >=dev-libs/openssl-1.1.1:0= )
+ system-ssl? ( >=dev-libs/openssl-1.1.1:0= )
"
BDEPEND="
${PYTHON_DEPS}
@@ -101,7 +102,7 @@ src_configure() {
use inspector || myconf+=( --without-inspector )
use npm || myconf+=( --without-npm )
use snapshot || myconf+=( --without-node-snapshot )
- use ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) || myconf+=( --without-ssl )
+ use ssl && ( use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store ) ) || myconf+=( --without-ssl )
local myarch=""
case ${ABI} in