summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-01-27 15:50:05 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-01-27 15:50:38 +0100
commitc271008f733b42327582844aced340354df9295e (patch)
tree1c7178cc2f2e7f58a346ac7dc47a3ba3af3a1185
parentgames-strategy/wargus-data: Remove games.eclass (diff)
downloadgentoo-c271008f733b42327582844aced340354df9295e.tar.gz
gentoo-c271008f733b42327582844aced340354df9295e.tar.bz2
gentoo-c271008f733b42327582844aced340354df9295e.zip
sys-devel/binutils: Introduce doc useflag
Package-Manager: Portage-2.3.20, Repoman-2.3.6
-rw-r--r--sys-devel/binutils/binutils-9999.ebuild17
1 files changed, 6 insertions, 11 deletions
diff --git a/sys-devel/binutils/binutils-9999.ebuild b/sys-devel/binutils/binutils-9999.ebuild
index 3e4f54cd69bb..a2db40c93a4d 100644
--- a/sys-devel/binutils/binutils-9999.ebuild
+++ b/sys-devel/binutils/binutils-9999.ebuild
@@ -8,7 +8,7 @@ inherit eutils libtool flag-o-matic gnuconfig multilib versionator
DESCRIPTION="Tools necessary to build programs"
HOMEPAGE="https://sourceware.org/binutils/"
LICENSE="GPL-3+"
-IUSE="+cxx multitarget +nls static-libs test"
+IUSE="+cxx doc multitarget +nls static-libs test"
# Variables that can be set here:
# PATCH_VER - the patchset version
@@ -62,6 +62,7 @@ RDEPEND="
sys-libs/zlib
"
DEPEND="${RDEPEND}
+ doc? ( sys-apps/texinfo )
test? ( dev-util/dejagnu )
nls? ( sys-devel/gettext )
sys-devel/flex
@@ -235,13 +236,8 @@ src_configure() {
echo ./configure "${myconf[@]}"
"${S}"/configure "${myconf[@]}" || die
- # Prevent makeinfo from running in releases. It may not always be
- # installed, and older binutils may fail with newer texinfo.
- # Besides, we never patch the doc files anyways, so regenerating
- # in the first place is useless. #193364
- # For older versions, it means we don't get any info pages at all.
- # Oh well, tough luck. #294617
- if [[ -e ${S}/gas/doc/as.info ]] || ! version_is_at_least 2.24 ; then
+ # Prevent makeinfo from running if doc is unset.
+ if ! use doc ; then
sed -i \
-e '/^MAKEINFO/s:=.*:= true:' \
Makefile || die
@@ -252,9 +248,8 @@ src_compile() {
cd "${MY_BUILDDIR}"
emake all
- # only build info pages if we user wants them, and if
- # we have makeinfo (may not exist when we bootstrap)
- if type -p makeinfo > /dev/null ; then
+ # only build info pages if the user wants them
+ if use doc ; then
emake info
fi