summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2023-01-09 17:35:09 -0600
committerViorel Munteanu <ceamac@gentoo.org>2023-01-20 10:07:49 +0200
commitc28644a296396307b1e7f2e43635bf083c7c2a3d (patch)
treed669d6c3b941a59c3bf6a424e508000ab107b0c6
parentapp-crypt/tpm2-tss-engine: add 1.2.0 (diff)
downloadgentoo-c28644a2.tar.gz
gentoo-c28644a2.tar.bz2
gentoo-c28644a2.zip
app-crypt/tpm2-tss-engine: drop 1.1.0-r1, 1.1.0-r2
Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29039 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--app-crypt/tpm2-tss-engine/Manifest1
-rw-r--r--app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.1.0-tests-Allow-compilation-under-musl.patch35
-rw-r--r--app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r1.ebuild42
-rw-r--r--app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r2.ebuild47
4 files changed, 0 insertions, 125 deletions
diff --git a/app-crypt/tpm2-tss-engine/Manifest b/app-crypt/tpm2-tss-engine/Manifest
index b853ba2d43c0..50e051b029ef 100644
--- a/app-crypt/tpm2-tss-engine/Manifest
+++ b/app-crypt/tpm2-tss-engine/Manifest
@@ -1,2 +1 @@
-DIST tpm2-tss-engine-1.1.0.tar.gz 394448 BLAKE2B 0502907dc9ce872f31be3b980f975a02af2e3e4b369d188afa5327bd4475d93dbf43769dc7ddc11e8cbda8d1fde09f28a9aef9145e859a90225cd397f62c7a2c SHA512 5d2e08178be54350e8672245023d601a0d9d520f8c49e977af49d7c59b91d033c14b4a347b71e042fe7c5ff12af9fcc43b69fd1dc83a9f0db12d47d43e1107f4
DIST tpm2-tss-engine-1.2.0.tar.gz 410605 BLAKE2B f6b88238ed780315cf23dc9caac4639220e76e8daeeb35a0e9bf2f23efb1b45497dd24f43f97d0f4018440b33e2e80de4f321254b9e58708d04a15a3bd922aae SHA512 cd0f1c3b5251ab2f21159099cdb9c0b1cc68d7ad334d4c5245bba9c07274ecea7c86a531afc9ce6250635a9d0929a5147f461cc3760b15cd6ad099342af87ad0
diff --git a/app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.1.0-tests-Allow-compilation-under-musl.patch b/app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.1.0-tests-Allow-compilation-under-musl.patch
deleted file mode 100644
index b8114b4c25c0..000000000000
--- a/app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.1.0-tests-Allow-compilation-under-musl.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-https://bugs.gentoo.org/833531
---- a/configure.ac
-+++ b/configure.ac
-@@ -174,6 +174,8 @@ AC_ARG_WITH([device],
- [with_device_set=no])
- AM_CONDITIONAL([TESTDEVICE],[test "x$with_device_set" = xyes])
-
-+AC_CHECK_FUNC([backtrace_symbols_fd],[AC_DEFINE([HAVE_EXECINFO],[1], ['Define to 1 if you have the <execinfo.h> header file.'])])
-+
- # Integration test with simulator
- AS_IF([test "x$enable_integration" = xyes && test "x$with_device_set" = xno],
- [integration_args=""
---- a/test/error_tpm2-tss-engine-common.c
-+++ b/test/error_tpm2-tss-engine-common.c
-@@ -7,7 +7,9 @@
- #include "tpm2-tss-engine.h"
- #include "tpm2-tss-engine-common.h"
-
-+#ifdef HAVE_EXECINFO
- #include <execinfo.h>
-+#endif
- #include <stdio.h>
- #include <unistd.h>
- #include <setjmp.h>
-@@ -17,8 +19,10 @@ TSS2_RC
- __wrap_Esys_Initialize()
- {
- printf("Esys_Initialize called\n");
-+#ifdef HAVE_EXECINFO
- void* b[128];
- backtrace_symbols_fd(b, backtrace(b, sizeof(b)/sizeof(b[0])), STDOUT_FILENO);
-+#endif
- return -1;
- }
-
diff --git a/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r1.ebuild b/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r1.ebuild
deleted file mode 100644
index a737e7269f55..000000000000
--- a/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools bash-completion-r1
-
-DESCRIPTION="OpenSSL Engine for TPM2 devices"
-HOMEPAGE="https://github.com/tpm2-software/tpm2-tss-engine"
-SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="app-crypt/tpm2-tss:=
- dev-libs/openssl:0="
-DEPEND="${RDEPEND}
- test? ( dev-util/cmocka )"
-BDEPEND="sys-devel/autoconf-archive
- virtual/pkgconfig"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable test unit) \
- --disable-defaultflags \
- --disable-static \
- --with-completionsdir="$(get_bashcompdir)"
-}
-
-src_install () {
- default
- find "${ED}" -name '*.la' -delete || die
- dobashcomp bash-completion/*
-}
diff --git a/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r2.ebuild b/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r2.ebuild
deleted file mode 100644
index c320b9d81d6f..000000000000
--- a/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools bash-completion-r1
-
-DESCRIPTION="OpenSSL Engine for TPM2 devices"
-HOMEPAGE="https://github.com/tpm2-software/tpm2-tss-engine"
-SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="app-crypt/tpm2-tss:=
- >=dev-libs/openssl-1.1.1:=
- <dev-libs/openssl-3.0.0:="
-DEPEND="${RDEPEND}
- test? ( dev-util/cmocka )"
-BDEPEND="sys-devel/autoconf-archive
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.1.0-tests-Allow-compilation-under-musl.patch"
- )
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable test unit) \
- --disable-defaultflags \
- --disable-static \
- --with-completionsdir="$(get_bashcompdir)"
-}
-
-src_install () {
- default
- find "${ED}" -name '*.la' -delete || die
- dobashcomp bash-completion/*
-}