summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-02-02 00:44:15 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-02-02 00:47:13 +0100
commitc2895a3c200bb691184bd1f2bb20c87afac44bfc (patch)
tree970250acae5e9513555b3b7f109b7b41cef3a046
parentnet-analyzer/wapiti: drop 3.0.5, 3.1.2 (diff)
downloadgentoo-c2895a3c.tar.gz
gentoo-c2895a3c.tar.bz2
gentoo-c2895a3c.zip
dev-python/tld: update EAPI 7 -> 8 and python versions
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--dev-python/tld/tld-0.12.6.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-python/tld/tld-0.12.6.ebuild b/dev-python/tld/tld-0.12.6.ebuild
index 1a3c41e8bfe3..c580627f61d9 100644
--- a/dev-python/tld/tld-0.12.6.ebuild
+++ b/dev-python/tld/tld-0.12.6.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
DESCRIPTION="Extract the top level domain (TLD) from the URL given"
@@ -13,13 +14,12 @@ SRC_URI="https://github.com/barseghyanartur/${PN}/archive/${PV}.tar.gz -> ${P}.t
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test !test? ( test )"
-BDEPEND="
- test? (
- dev-python/Faker[${PYTHON_USEDEP}]
- )"
+BDEPEND="test? ( dev-python/Faker[${PYTHON_USEDEP}] )"
-distutils_enable_tests --install pytest
+distutils_enable_tests pytest
src_prepare() {
distutils-r1_src_prepare