summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-16 04:38:36 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-16 04:38:36 +0100
commitc2a760b30c6a1f0c6136d0aa2f6dd2ab984c04ce (patch)
tree4f911b6ca31ba13df880227a856774bdd0c53bf2
parentdev-python/sqlglot: Remove old (diff)
downloadgentoo-c2a760b30c6a1f0c6136d0aa2f6dd2ab984c04ce.tar.gz
gentoo-c2a760b30c6a1f0c6136d0aa2f6dd2ab984c04ce.tar.bz2
gentoo-c2a760b30c6a1f0c6136d0aa2f6dd2ab984c04ce.zip
dev-python/sqlglot: Bump to 19.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sqlglot/Manifest1
-rw-r--r--dev-python/sqlglot/sqlglot-19.5.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index c3a7b1589265..fd0510ee1055 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -1 +1,2 @@
DIST sqlglot-19.4.0.tar.gz 9056050 BLAKE2B 23d5a9bdd7bfa27128e624406f52488e90ec475c355fde6e5e7ac77bee5ae84dd1abeb2c87896f3fbc418dbe0b818e66f1d76b7e24514315e194b6bd58677203 SHA512 f0f6f4d4eca3d97ac9cd200e6a5e8df5a2c2b9e6d84dd87f19ab29b1af0c6cb55c62e28c9c7faa34425a6cfb0583b02d387b7cd744fec40419927016cd05d51e
+DIST sqlglot-19.5.0.tar.gz 9060496 BLAKE2B 190c4b507e3c630a46a493f72698f48749fc4f0e6444a2ee61499d35a5f56563b402e8947531b20c100df8ffc3af86cc45b8e1e11e7b467ec3bcd6261b880619 SHA512 3e3cbf7c9bac33b9dc0ad26021a78d534cb6ac61aae6d96c5f652938fd4efb5eca52854ca7ef02fa9ec6a989a6c80eaab31b210c932cb286b2ea8e4aace7fcf9
diff --git a/dev-python/sqlglot/sqlglot-19.5.0.ebuild b/dev-python/sqlglot/sqlglot-19.5.0.ebuild
new file mode 100644
index 000000000000..368b77416b42
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-19.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}