summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-10-30 23:28:03 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-10-30 23:43:12 +0100
commitc2b3f6534686c6e2e1b51839b50ea12de6432b5c (patch)
treec564784367d42f291b071cc3efb6f40772cc7771
parentapp-benchmarks/stress-ng: drop old version (diff)
downloadgentoo-c2b3f653.tar.gz
gentoo-c2b3f653.tar.bz2
gentoo-c2b3f653.zip
app-crypt/ssss: bump to version 0.5.6
This version switches to a maintained fork, as other distributions started to use that, which also fixes some bugs and the original author doesn't have any plans to continue development. Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--app-crypt/ssss/Manifest1
-rw-r--r--app-crypt/ssss/metadata.xml3
-rw-r--r--app-crypt/ssss/ssss-0.5.6.ebuild39
3 files changed, 43 insertions, 0 deletions
diff --git a/app-crypt/ssss/Manifest b/app-crypt/ssss/Manifest
index c24684b3ff87..d4b1b0f6c918 100644
--- a/app-crypt/ssss/Manifest
+++ b/app-crypt/ssss/Manifest
@@ -1 +1,2 @@
+DIST ssss-0.5.6.tar.gz 20128 BLAKE2B d42fff5878e2ebcc62cd86b86f0f8a3e522c089cbb5e8fb2585cf375ff133da7d9ccf00e62cc6888e00abe5d64f87ac19ddbb3f6e6a0d86913e6a6aa5a8a1d4c SHA512 964af01610a7a269d19ae1fa1712ef12ca1afab02636ba83dd84ec5aeb185210a1247d932ee39d2869aa76e54ffb051d802800d295d17355d6fe2a8010edd509
DIST ssss-0.5.tar.gz 17435 BLAKE2B 76aae463ce11341f8b0336526f7d19c9921025cabc05bc9e00005b0bdeb676ed5e069226962232f277de2fecb1cd71bafbd4b2fa0c03ef4faf0f66daa24599d1 SHA512 be8df1666ac61d4097b5fd54f2cee3640db8f85ec21411f1b208a35b671c5699bc692079525d8d313d1cf2500da31bfb03771829a9fdccc0bb6d806749526ec9
diff --git a/app-crypt/ssss/metadata.xml b/app-crypt/ssss/metadata.xml
index 51c92c834b21..caba2e85d1bb 100644
--- a/app-crypt/ssss/metadata.xml
+++ b/app-crypt/ssss/metadata.xml
@@ -10,4 +10,7 @@
The program suite does both: the generation of shares for a known secret,
and the reconstruction of a secret using user-pro‐vided shares.
</longdescription>
+ <upstream>
+ <remote-id type="github">MrJoy/ssss</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-crypt/ssss/ssss-0.5.6.ebuild b/app-crypt/ssss/ssss-0.5.6.ebuild
new file mode 100644
index 000000000000..724f2c160f99
--- /dev/null
+++ b/app-crypt/ssss/ssss-0.5.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Shamir's Secret Sharing Scheme"
+HOMEPAGE="https://github.com/MrJoy/ssss"
+SRC_URI="https://github.com/MrJoy/${PN}/archive/releases/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-releases-v${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/gmp:0="
+DEPEND="${RDEPEND}"
+BDEPEND="app-doc/xmltoman"
+
+HTML_DOCS=( "doc.html" "ssss.1.html" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+
+ # Respect users [CL]FLAGS and don't strip, as portage does this part
+ sed -e 's/-O2/$(CFLAGS) -lgmp $(LDFLAGS)/g' -e '/strip/d' -i Makefile || die
+}
+
+src_install() {
+ dobin ssss-split
+ dosym ssss-split /usr/bin/ssss-combine
+
+ doman ssss.1
+
+ einstalldocs
+}