summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-10-14 14:50:43 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-10-20 08:43:12 +0300
commitc2c9de4a8654d6c86937d2b11b229a08809385c9 (patch)
tree6de3299aa70ec0935755e5de84f00dcc9e309dee
parentapp-crypt/openpgp-keys-linuxcontainers: new keys (diff)
downloadgentoo-c2c9de4a8654d6c86937d2b11b229a08809385c9.tar.gz
gentoo-c2c9de4a8654d6c86937d2b11b229a08809385c9.tar.bz2
gentoo-c2c9de4a8654d6c86937d2b11b229a08809385c9.zip
app-emulation/lxd: use verify-sig
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-emulation/lxd/Manifest1
-rw-r--r--app-emulation/lxd/lxd-4.0.3.ebuild12
2 files changed, 9 insertions, 4 deletions
diff --git a/app-emulation/lxd/Manifest b/app-emulation/lxd/Manifest
index afffed8ce51e..84866a252c02 100644
--- a/app-emulation/lxd/Manifest
+++ b/app-emulation/lxd/Manifest
@@ -1 +1,2 @@
DIST lxd-4.0.3.tar.gz 25468067 BLAKE2B 5c3d8a2841d3222d070be39fb6cb63c99450a7edea86915a808230012f1a3b7a66c2c4a3c56be378f586c8ca033c4f547ed6eeb14bb09a091b3ae28c62fda7ae SHA512 aaf7fe7473e04765263ff99f02041748f0e57abdd0311d734fbf1cbc461516bf6adad1bc42c9cfa58b4e87c28efb5186d9436fb0a1d309b23eb37fe95299ad6f
+DIST lxd-4.0.3.tar.gz.asc 833 BLAKE2B b889b7c3a85f325a4c47319b45c4828c4fc0cac2bae77341734827e737243802852c20a766ab72ce1a12e643502d108fec41b715d8eb820ec273c651b7745fb2 SHA512 993ad833832a551e0804f9e565542b5779352cad2bb32989a440a0be11b1ae6539e46fa3332d35e8be365026dacc21d847db544b62b3e11493100d3c9cb313e1
diff --git a/app-emulation/lxd/lxd-4.0.3.ebuild b/app-emulation/lxd/lxd-4.0.3.ebuild
index abda07f1be07..cecda7cf1eb8 100644
--- a/app-emulation/lxd/lxd-4.0.3.ebuild
+++ b/app-emulation/lxd/lxd-4.0.3.ebuild
@@ -3,17 +3,18 @@
EAPI=7
-inherit autotools bash-completion-r1 linux-info optfeature systemd
+inherit autotools bash-completion-r1 linux-info optfeature systemd verify-sig
DESCRIPTION="Fast, dense and secure container management"
HOMEPAGE="https://linuxcontainers.org/lxd/introduction/ https://github.com/lxc/lxd"
-SRC_URI="https://linuxcontainers.org/downloads/${PN}/${P}.tar.gz"
+SRC_URI="https://linuxcontainers.org/downloads/${PN}/${P}.tar.gz
+ verify-sig? ( https://linuxcontainers.org/downloads/lxd/${P}.tar.gz.asc )"
# Needs to include licenses for all bundled programs and libraries.
LICENSE="Apache-2.0 BSD BSD-2 LGPL-3 MIT MPL-2.0"
SLOT="0"
KEYWORDS="amd64"
-IUSE="apparmor +ipv6 nls"
+IUSE="apparmor +ipv6 nls verify-sig"
DEPEND="app-arch/xz-utils
>=app-emulation/lxc-3.0.0[apparmor?,seccomp]
@@ -31,7 +32,8 @@ RDEPEND="${DEPEND}
sys-fs/squashfs-tools
virtual/acl"
BDEPEND=">=dev-lang/go-1.13
- nls? ( sys-devel/gettext )"
+ nls? ( sys-devel/gettext )
+ verify-sig? ( app-crypt/openpgp-keys-linuxcontainers )"
CONFIG_CHECK="
~BRIDGE
@@ -67,6 +69,8 @@ QA_PREBUILT="/usr/lib/lxd/libdqlite.so.0.0.1
EGO_PN="github.com/lxc/lxd"
GOPATH="${S}/_dist" # this seems to reset every now and then, though
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/linuxcontainers.asc
+
common_op() {
local i
for i in dqlite raft; do