summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-07-30 21:31:59 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-07-30 21:32:13 +0200
commitc2d33f25daa628eccf403e8322c3eb9d7b77a0fb (patch)
tree33988cfffa463bae86009efdaae3349743b95735
parentdev-libs/kirigami: 2.2.0 amd64 stable (diff)
downloadgentoo-c2d33f25daa628eccf403e8322c3eb9d7b77a0fb.tar.gz
gentoo-c2d33f25daa628eccf403e8322c3eb9d7b77a0fb.tar.bz2
gentoo-c2d33f25daa628eccf403e8322c3eb9d7b77a0fb.zip
dev-util/global: version bump.
This commit also bumps the ebuild to EAPI version 6. Gentoo-Bug: https://bugs.gentoo.org/543908 Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--dev-util/global/Manifest1
-rw-r--r--dev-util/global/global-6.5.7.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/dev-util/global/Manifest b/dev-util/global/Manifest
index 9505a07851c9..ccc748051242 100644
--- a/dev-util/global/Manifest
+++ b/dev-util/global/Manifest
@@ -1 +1,2 @@
DIST global-6.3.1.tar.gz 1369634 SHA256 fb10668ef1a2f63d0730564a36ecae7716aed89c09cc5896cd8c579be4ebae6c SHA512 83becd6cda06f8da17ea0c701bb135523ff48cec73b233d24566387d11a35c0b42f410b62753838e2b364a5a485cac033b4aef1159cc6f4cdeca4a7b6c5bb4d6 WHIRLPOOL 1321e131b267f842b68561f04155c06dc11b0adfe177e83113b1884eb629d8e27844de6421c1613efd2ad7472d51140deb5360a6ad78fd25f50844426314de5c
+DIST global-6.5.7.tar.gz 2940567 SHA256 d9c08fa524f9499b54241cb2d72f8a7df01453b6d5e012a63784ded08e3acd32 SHA512 0d33f718839e5e00bdd6d042b415a69c5e1f232d843610870505f8f20635b445810149b1b84ea8b77881f5f64814783ebe3cdcab2f84b8a085223b64293a9045 WHIRLPOOL 0c32bc466652a87661c21bcaee2f2a1b5eee7b3bff5e8f763bd3b1c159daea10c1e3c0f092109d9b92112258f52e88a7bed7eb58923a592013d400b7d6727f4d
diff --git a/dev-util/global/global-6.5.7.ebuild b/dev-util/global/global-6.5.7.ebuild
new file mode 100644
index 000000000000..3d6e4cfa2ed2
--- /dev/null
+++ b/dev-util/global/global-6.5.7.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools ltprune elisp-common
+
+DESCRIPTION="tag system to find an object location in various sources"
+HOMEPAGE="https://www.gnu.org/software/global/global.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc emacs vim"
+
+RDEPEND="
+ sys-libs/ncurses
+ emacs? ( virtual/emacs )
+ vim? ( || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ )
+ || (
+ dev-libs/libltdl:0
+ sys-devel/libtool:2
+ )"
+
+DEPEND="${DEPEND}
+ doc? (
+ app-text/texi2html
+ sys-apps/texinfo
+ )"
+
+SITEFILE="50gtags-gentoo.el"
+
+PATCHES=( "${FILESDIR}/${PN}-6.2.9-tinfo.patch" )
+
+DOCS=( AUTHORS FAQ NEWS README THANKS )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ "$(use_with emacs lispdir "${SITELISP}/${PN}")"
+}
+
+src_compile() {
+ if use doc; then
+ texi2pdf -q -o doc/global.pdf doc/global.texi
+ texi2html -o doc/global.html doc/global.texi
+ fi
+
+ if use emacs; then
+ elisp-compile *.el
+ fi
+
+ emake
+}
+
+src_install() {
+ default
+
+ insinto /etc
+ doins gtags.conf
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins gtags.vim
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} *.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ if use doc; then
+ # doc/global.pdf is generated if tex executable (e.g. /usr/bin/tex) is available.
+ [[ -f doc/global.pdf ]] && DOCS+=( doc/global.pdf )
+ fi
+
+ einstalldocs
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}