summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-10-02 20:32:24 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-10-02 20:40:21 +0200
commitc2df0b64e28f3b64830398ce28dba9232ae69100 (patch)
treee292b2861bbdf30c324c153f6d57c289a1d16aca
parentdev-lua/lanes: amd64 stable (diff)
downloadgentoo-c2df0b64e28f3b64830398ce28dba9232ae69100.tar.gz
gentoo-c2df0b64e28f3b64830398ce28dba9232ae69100.tar.bz2
gentoo-c2df0b64e28f3b64830398ce28dba9232ae69100.zip
dev-lua/lanes: drop 3.16.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-lua/lanes/Manifest1
-rw-r--r--dev-lua/lanes/lanes-3.16.0.ebuild93
2 files changed, 0 insertions, 94 deletions
diff --git a/dev-lua/lanes/Manifest b/dev-lua/lanes/Manifest
index ada55d99e237..08f19a66092e 100644
--- a/dev-lua/lanes/Manifest
+++ b/dev-lua/lanes/Manifest
@@ -1,2 +1 @@
-DIST lanes-3.16.0.tar.gz 257945 BLAKE2B aecc0bd551f10b29791acdde8da30fb83591395eac4d152999a0e92fe9738a6171b13363edae2d94b1db47398a01e011833ccee7a7f234033d3230605423c0b6 SHA512 ffd935baae8af752591251bbb1a7f936034ad281870d453e6e1b4291c175c91537ccae23ec25a616b45e8ab601222f323e05e938d7887091ba7e132b0cd5e449
DIST lanes-3.16.2.tar.gz 446113 BLAKE2B 5343ac98f2fac3c92d8afeb6dbbd4875ce93c44715b40b030cbbb03f311b3e358358c1daa295790b0a62113bb15355fc8927a8b7896af079d8e7fe50e2e6b438 SHA512 c7e8037d6f709b31bdb981cbcf70ba51f23823bac51f7ee9ef47881603547a8e1df3c6b7fa35110528cb7547f83048cbe71868aa94c03a59165f1b9d2d5ad08a
diff --git a/dev-lua/lanes/lanes-3.16.0.ebuild b/dev-lua/lanes/lanes-3.16.0.ebuild
deleted file mode 100644
index f31509f4e45e..000000000000
--- a/dev-lua/lanes/lanes-3.16.0.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="Lightweight, native, lazy evaluating multithreading library"
-HOMEPAGE="https://github.com/LuaLanes/lanes"
-SRC_URI="https://github.com/LuaLanes/lanes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-
-# Tests are currently somehow problematic.
-# https://github.com/LuaLanes/lanes/issues/197
-# https://github.com/LuaLanes/lanes/issues/198
-RESTRICT="test"
-
-RDEPEND="${LUA_DEPS}"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- test? ( ${RDEPEND} )
-"
-
-HTML_DOCS=( "docs/." )
-
-PATCHES=( "${FILESDIR}/${PN}-3.13.0-makefile.patch" )
-
-src_prepare() {
- default
-
- lua_copy_sources
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "LUA=${ELUA}"
- "LUA_FLAGS=$(lua_get_CFLAGS)"
- "LUA_LIBS="
- "OPT_FLAGS=${CFLAGS}"
- )
-
- tc-export PKG_CONFIG
-
- emake "${myemakeargs[@]}"
-
- popd
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_test() {
- pushd "${BUILD_DIR}" || die
-
- emake LUA="${ELUA}" test
-
- popd
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "LUA_LIBDIR=${ED}/$(lua_get_cmod_dir)"
- "LUA_SHAREDIR=${ED}/$(lua_get_lmod_dir)"
- )
-
- emake "${myemakeargs[@]}" install
-
- popd
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}