summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2023-01-23 01:59:18 +0800
committerMarc Schiffbauer <mschiff@gentoo.org>2023-01-23 01:59:58 +0800
commitc2ec3031fb80299c547af6025b0993a3c1673d62 (patch)
tree66754ba2bf4d13cf1ff555232421c1bd56d3ffc6
parentmedia-plugins/libvisual-plugins: Stabilize 0.4.1 sparc, #891659 (diff)
downloadgentoo-c2ec3031.tar.gz
gentoo-c2ec3031.tar.bz2
gentoo-c2ec3031.zip
app-backup/bareos: fix install for IUSE=merged-usr
Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
-rw-r--r--app-backup/bareos/bareos-21.1.5-r2.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/app-backup/bareos/bareos-21.1.5-r2.ebuild b/app-backup/bareos/bareos-21.1.5-r2.ebuild
index a1086b270d5f..787f2a50e2f4 100644
--- a/app-backup/bareos/bareos-21.1.5-r2.ebuild
+++ b/app-backup/bareos/bareos-21.1.5-r2.ebuild
@@ -24,7 +24,7 @@ LICENSE="AGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="X acl ceph clientonly +director glusterfs ipv6 lmdb
- logwatch ndmp readline scsi-crypto
+ logwatch ndmp readline scsi-crypto split-usr
static +storage-daemon systemd tcpd test vim-syntax vmware xattr"
# get cmake variables from core/cmake/BareosSetVariableDefaults.cmake
@@ -236,10 +236,12 @@ src_install() {
# remove duplicate binaries being installed in /usr/sbin and replace
# them by symlinks to not break systems that still use split-usr
- for f in bwild bregex bsmtp bconsole; do
- rm -f "${D}/usr/sbin/$f" || die
- ln -s "../bin/$f" "${D}/usr/sbin/$f" || die
- done
+ if use split-usr; then
+ for f in bwild bregex bsmtp bconsole; do
+ rm -f "${D}/usr/sbin/$f" || die
+ ln -s "../bin/$f" "${D}/usr/sbin/$f" || die
+ done
+ fi
# get rid of py2 stuff
rm -rf "$D"/usr/lib64/python2.7 || die