summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-08-22 09:57:17 +0200
committerJakov Smolić <jsmolic@gentoo.org>2022-08-22 10:03:23 +0200
commitc2f66264053f24ad3482f17306b8a142005986e1 (patch)
tree12f6218ca69265634d5cedfc7cf4952e67d73b7c
parentdev-haskell/blaze-builder-conduit: treeclean (diff)
downloadgentoo-c2f66264.tar.gz
gentoo-c2f66264.tar.bz2
gentoo-c2f66264.zip
dev-haskell/bitwise: treeclean
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--dev-haskell/bitwise/Manifest1
-rw-r--r--dev-haskell/bitwise/bitwise-1.0.0.1.ebuild33
-rw-r--r--dev-haskell/bitwise/metadata.xml52
-rw-r--r--profiles/package.mask1
4 files changed, 0 insertions, 87 deletions
diff --git a/dev-haskell/bitwise/Manifest b/dev-haskell/bitwise/Manifest
deleted file mode 100644
index 206b04dec792..000000000000
--- a/dev-haskell/bitwise/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST bitwise-1.0.0.1.tar.gz 16473 BLAKE2B e7caa6d1ac864d6c12ff471a7080559da93f3973eeb5949e54ee2a2f205cab4a9c452578c0a22102fe613964af4f9367b037552a30dd711b08cac2dd2c3ccdca SHA512 b8653549ef0d0f4eb608802f6124cd969c16cbeb6f26dd83839bbaab7d56cf0c1b39a7ac3dba40f3fa00f3f67f38bad091ee0f01e7f6aea7f9c0bafa34efb443
diff --git a/dev-haskell/bitwise/bitwise-1.0.0.1.ebuild b/dev-haskell/bitwise/bitwise-1.0.0.1.ebuild
deleted file mode 100644
index 7c437a36a1a8..000000000000
--- a/dev-haskell/bitwise/bitwise-1.0.0.1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.5.6.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="fast multi-dimensional unboxed bit packed Bool arrays"
-HOMEPAGE="https://code.mathr.co.uk/bitwise"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-lang/ghc-7.8.2:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.18.1.3
- test? ( >=dev-haskell/quickcheck-2.4 )
-"
-
-src_prepare() {
- default
-
- cabal_chdeps \
- 'QuickCheck >= 2.4 && < 2.12' 'QuickCheck >= 2.4' \
- 'base >= 4.7 && < 4.12' 'base >= 4.7'
-}
diff --git a/dev-haskell/bitwise/metadata.xml b/dev-haskell/bitwise/metadata.xml
deleted file mode 100644
index 361f919bab11..000000000000
--- a/dev-haskell/bitwise/metadata.xml
+++ /dev/null
@@ -1,52 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- Unboxed multidimensional bit packed Bool arrays with fast aggregate
- operations based on lifting Bool operations to bitwise operations.
-
- There are many other bit packed structures out there, but none met
- all of these requirements:
-
- (1) unboxed bit packed Bool array,
-
- (2) multi-dimensional indexing,
-
- (3) fast (de)serialization, or interoperable with foreign code,
-
- (4) fast aggregate operations (fold, map, zip).
-
- Quick tour of the bitwise library:
-
- [Data.Bits.Bitwise] Lift boolean operations on 'Bool' to bitwise
- operations on 'Data.Bits.Bits'.
-
- [Data.Array.BitArray] Immutable bit arrays.
-
- [Data.Array.BitArray.ST] Mutable bit arrays in 'Control.Monad.ST.ST'.
-
- [Data.Array.BitArray.IO] Mutable bit arrays in 'IO'.
-
- [Data.Array.BitArray.ByteString] (De)serialization.
-
- [Codec.Image.PBM] Portable bitmap monochrome 2D image format.
-
- Very rough performance benchmarks:
-
- * immutable random access single bit reads:
- @BitArray ix@ is about 40% slower than @UArray ix Bool@,
-
- * 'Control.Monad.ST.ST' mutable random access single bit reads:
- @STBitArray s ix@ is about the same as @STUArray s ix Bool@,
-
- * immutable map @Bool -&gt; Bool@:
- @BitArray ix@ is about 85x faster than @UArray ix Bool@,
-
- * immutable zipWith @Bool -&gt; Bool -&gt; Bool@:
- @BitArray ix@ is about 1300x faster than @UArray ix Bool@.
- </longdescription>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index f381f7b7c235..06d0532e1c91 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -351,7 +351,6 @@ dev-haskell/biofasta
dev-haskell/biosff
dev-haskell/bitarray
dev-haskell/bits-atomic
-dev-haskell/bitwise
# Hans de Graaff <graaff@gentoo.org> (2022-07-16)
# No longer supported upstream. Use a newer ruby version instead.