summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2019-06-02 14:47:14 +0200
committerMatthias Schwarzott <zzam@gentoo.org>2019-06-02 21:06:01 +0200
commitc3005b91380d235dea6addd0e74aa4a59ba0c208 (patch)
tree701dcafb5daf6e76c97702d866759190a49389b6
parentprofiles: remove texlive scripting part (diff)
downloadgentoo-c3005b91.tar.gz
gentoo-c3005b91.tar.bz2
gentoo-c3005b91.zip
dev-util/dwarves: version bump
Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Matthias Schwarzott <zzam@gentoo.org>
-rw-r--r--dev-util/dwarves/Manifest1
-rw-r--r--dev-util/dwarves/dwarves-1.13.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/dwarves/Manifest b/dev-util/dwarves/Manifest
index 7f96b711a1cc..8f793eb87020 100644
--- a/dev-util/dwarves/Manifest
+++ b/dev-util/dwarves/Manifest
@@ -1 +1,2 @@
DIST dwarves-1.12.tar.bz2 112400 BLAKE2B e71051041dfdbefc603dc041303de82e2e44c8b0f4f888577722466aaf7958cab7b04c15154faa8cbfcaa44fe60fc549e09b2fb68747cc3cdd08b8bce487cfdf SHA512 20644344e694253b79ede65e489696a319f10eaf424af81882414ae6efeaf34a82132321430d647916b78f97ef504907b3bd32919420f2cd14384910e283ff27
+DIST dwarves-1.13.tar.xz 222008 BLAKE2B db73f5c9a319a1a57ef37127350a9da117e3f5c89e199445393e3e312139ce8f88f46e6e5bbf302d708c0b075b1c2b2cd75dc7bc213ed144d1db792c55358220 SHA512 26485b183b4c7b608dd0392f9155dd570a14c86fdeafee232e44ad30f14a1357b408b61b0e8a31ea4bf976ed7fc44e7d5a4a3ccede9713c47265ad52c13dadf0
diff --git a/dev-util/dwarves/dwarves-1.13.ebuild b/dev-util/dwarves/dwarves-1.13.ebuild
new file mode 100644
index 000000000000..5af51df1a8e6
--- /dev/null
+++ b/dev-util/dwarves/dwarves-1.13.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit multilib cmake-utils python-single-r1
+
+DESCRIPTION="pahole (Poke-a-Hole) and other DWARF2 utilities"
+HOMEPAGE="https://git.kernel.org/cgit/devel/pahole/pahole.git/"
+
+LICENSE="GPL-2" # only
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/elfutils-0.131
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+if [[ ${PV//_p} == ${PV} ]]; then
+ SRC_URI="http://fedorapeople.org/~acme/dwarves/${P}.tar.xz"
+ S=${WORKDIR}
+else
+ SRC_URI="https://dev.gentoo.org/~zzam/${PN}/${P}.tar.xz"
+fi
+
+DOCS=( README README.ctracer NEWS )
+PATCHES=( "${FILESDIR}"/${PN}-1.10-python-import.patch )
+
+src_configure() {
+ local mycmakeargs=( "-D__LIB=$(get_libdir)" )
+ cmake-utils_src_configure
+}
+
+src_test() { :; }
+
+src_install() {
+ cmake-utils_src_install
+ python_fix_shebang "${D}"/usr/bin/ostra-cg \
+ "${D}"/usr/share/dwarves/runtime/python/ostra.py
+}