summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-11-15 13:00:59 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-11-15 14:27:58 -0500
commitc3011ebaf74f0abf2fc68486728b98be37983961 (patch)
treefd1cb7ad2ecc602ba39ae2c24003c4b816bd6036
parentdev-qt/qtvirtualkeyboard: drop 6.5.2 (diff)
downloadgentoo-c3011ebaf74f0abf2fc68486728b98be37983961.tar.gz
gentoo-c3011ebaf74f0abf2fc68486728b98be37983961.tar.bz2
gentoo-c3011ebaf74f0abf2fc68486728b98be37983961.zip
dev-qt/qtwayland: drop 6.5.2-r3
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/files/qtwayland-6.5.2-drag-drop-segfault.patch38
-rw-r--r--dev-qt/qtwayland/qtwayland-6.5.2-r3.ebuild51
3 files changed, 0 insertions, 90 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index 96e9bb4adb06..8bc9c623c179 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,5 +1,4 @@
DIST qtwayland-5.15.11-gentoo-kde-2.tar.xz 48072 BLAKE2B 5587a010e168df2a3303673c4af4d62908c1847dfe563af6bbfa325c38c3de09dafddc7cf3bf55d1293f22716f146f30729eacea8f839b01e3b2b3bd0ba2dcf8 SHA512 8bd205896c4e81203aac98adbf7da209138b5b9423780506910552aa6fdb23f8c5f0b18fd94e90349f94725d13325348c010482e1afddfa0832b9d4ff3feb8bc
DIST qtwayland-everywhere-opensource-src-5.15.11.tar.xz 569072 BLAKE2B 83b96ac4eb220aa924539a67b28bb20eff97256203f0c36efb0687b9266a2d0f3c69cec6648870e27431120bc1bd0eecf14dcc4f118e3d77ed78c1eb66298329 SHA512 b47a3358bc37f52dde0839940431e8049abfaa827722e6d57362b07547c35fe9fb422d28fd28c69a13f5773c24efc3eeea1e584372737a0151ed94bf4c5b9980
-DIST qtwayland-everywhere-src-6.5.2.tar.xz 1059356 BLAKE2B 4708b78ff5c8e413edaa4d4400317f58dd068273a5eef7caf1500abf8afbe4e9ac405b6854691ef93265a7eeb0cfb7406024826a0b7c7ba3f8149218af67fd48 SHA512 520d109402f1d629481029a3b1eaab740e66135db4069c34651172bb2ad821b22de60e9956a96331d2f32a4522fc52c6a4ba99b474092d755760cad08c776477
DIST qtwayland-everywhere-src-6.5.3.tar.xz 1059396 BLAKE2B f3b495e712a3eae53b0fe9abc4430414868fe8668468cadc844672b11597c348b0daa82a602f7e5d15f1ec67f5336d0d50466a64ca0d0a571401681ae02137d6 SHA512 e516dd5158ed1aadc989b3f1bbaad87fa38b59872b44c7c92ec1c349e7e923a6b07b7fb3a3493312330eaf581b0d27aeaad2ec03629523ee28e3627b7c30ea89
DIST qtwayland-everywhere-src-6.6.0.tar.xz 1125748 BLAKE2B e1024866761b1872ed762ef565cc4805e0dcea5a3319ec6d4aaf4d9e46477a0a4f1aea7b39faeb88ab10afa6b2fb5e0dd22a7864a3d18b479c87e345b34c7153 SHA512 e9cf63ccc71d4dc61b04a0f8a1a466e9ede09aa689c53c1ccc9db5233e324894bfd198c9204d8d93509c770a7a6612c8eb9981e0b3ee7428f8bf2dcbdc255109
diff --git a/dev-qt/qtwayland/files/qtwayland-6.5.2-drag-drop-segfault.patch b/dev-qt/qtwayland/files/qtwayland-6.5.2-drag-drop-segfault.patch
deleted file mode 100644
index d19522c4b8ef..000000000000
--- a/dev-qt/qtwayland/files/qtwayland-6.5.2-drag-drop-segfault.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-Regression in 6.5.2 that is fixed >=6.5.3.
-https://bugreports.qt.io/browse/QTBUG-115757
-https://github.com/qutebrowser/qutebrowser/issues/7827
-
-https://github.com/qt/qtwayland/commit/02e9e0a2d4538eb2b3c26d3137228f8f501bcf7f
-From: David Edmundson <davidedmundson@kde.org>
-Date: Wed, 7 Jun 2023 22:12:15 +0100
-Subject: [PATCH] client: Fix crash on dnd updates after client facing drag
- ends
-
-A platform drag and a application-facing drag have two different
-lifespans.
-
-The platform drag lasts until all mimedata is transferred and the client
-receiving the drops marks it as finished.
-
-The application facing QDrag lasts until the client deletes it. We can
-get a crash if we get updates during this time.
-
-The drop event is guarded, but not the action negotiation.
-
-Fixes: QTBUG-115757
-Change-Id: Ib9c047f04d65883105d4cd3f169637d0e038a63f
-Reviewed-by: Eskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@qt.io>
-(cherry picked from commit 22daca49b807fefba58113a06b86df4274e49f62)
-Reviewed-by: David Edmundson <davidedmundson@kde.org>
---- a/src/client/qwaylanddatadevice.cpp
-+++ b/src/client/qwaylanddatadevice.cpp
-@@ -97,6 +97,9 @@ bool QWaylandDataDevice::startDrag(QMimeData *mimeData, Qt::DropActions supporte
- connect(m_dragSource.data(), &QWaylandDataSource::cancelled, this, &QWaylandDataDevice::dragSourceCancelled);
- connect(m_dragSource.data(), &QWaylandDataSource::dndResponseUpdated, this, [this](bool accepted, Qt::DropAction action) {
- auto drag = static_cast<QWaylandDrag *>(QGuiApplicationPrivate::platformIntegration()->drag());
-+ if (!drag->currentDrag()) {
-+ return;
-+ }
- // in old versions drop action is not set, so we guess
- if (m_dragSource->version() < 3) {
- drag->setResponse(accepted);
diff --git a/dev-qt/qtwayland/qtwayland-6.5.2-r3.ebuild b/dev-qt/qtwayland/qtwayland-6.5.2-r3.ebuild
deleted file mode 100644
index 52a6a35f0218..000000000000
--- a/dev-qt/qtwayland/qtwayland-6.5.2-r3.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit qt6-build
-
-DESCRIPTION="Wayland platform plugin for Qt"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 ~arm ~arm64 ~loong ~x86"
-fi
-
-IUSE="compositor qml vulkan"
-
-RDEPEND="
- dev-libs/wayland
- ~dev-qt/qtbase-${PV}:6[egl(+),gui,opengl,vulkan=]
- media-libs/libglvnd
- x11-libs/libxkbcommon
- compositor? (
- qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
- )
-"
-DEPEND="
- ${RDEPEND}
- vulkan? ( dev-util/vulkan-headers )
-"
-BDEPEND="dev-util/wayland-scanner"
-
-CMAKE_SKIP_TESTS=(
- # segfaults for not-looked-into reasons, but not considered
- # an issue given >=seatv5 exists since wayland-1.10 (2016)
- tst_seatv4
- # needs a compositor/opengl, skip the extra trouble
- tst_surface
- tst_xdgdecorationv1
-)
-
-PATCHES=(
- "${FILESDIR}"/${P}-drag-drop-segfault.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package qml Qt6Quick)
- $(qt_feature compositor wayland_server)
- )
-
- qt6-build_src_configure
-}