summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2021-09-13 09:17:51 +0200
committerSam James <sam@gentoo.org>2021-09-18 04:04:47 +0100
commitc32b8a80a2f30e79dba6d53ec4da64285139a972 (patch)
treec00192383eeb31fa9983e500fc36402d9b7c53fb
parentsys-apps/busybox: Do not overwrite existing files with make-symlinks (diff)
downloadgentoo-c32b8a80a2f30e79dba6d53ec4da64285139a972.tar.gz
gentoo-c32b8a80a2f30e79dba6d53ec4da64285139a972.tar.bz2
gentoo-c32b8a80a2f30e79dba6d53ec4da64285139a972.zip
dev-cpp/doctest: fix gcc-11 related compilation error
Apply patch in order to fix gcc-11 related compilation error. The patch follows proposed fixes to upstream [1,2]. [1] https://github.com/onqtam/doctest/pull/505 [2] https://github.com/onqtam/doctest/pull/520 Closes: https://bugs.gentoo.org/812077 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/22280 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-cpp/doctest/doctest-2.4.6.ebuild2
-rw-r--r--dev-cpp/doctest/files/doctest-2.4.6-remove-unused-bla2.patch23
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-cpp/doctest/doctest-2.4.6.ebuild b/dev-cpp/doctest/doctest-2.4.6.ebuild
index 09d25151de7d..19efed964dd5 100644
--- a/dev-cpp/doctest/doctest-2.4.6.ebuild
+++ b/dev-cpp/doctest/doctest-2.4.6.ebuild
@@ -15,6 +15,8 @@ KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
+PATCHES=( "${FILESDIR}/${P}-remove-unused-bla2.patch" )
+
src_configure() {
local mycmakeargs=(
-DDOCTEST_WITH_TESTS=$(usex test)
diff --git a/dev-cpp/doctest/files/doctest-2.4.6-remove-unused-bla2.patch b/dev-cpp/doctest/files/doctest-2.4.6-remove-unused-bla2.patch
new file mode 100644
index 000000000000..69efd40e6a42
--- /dev/null
+++ b/dev-cpp/doctest/files/doctest-2.4.6-remove-unused-bla2.patch
@@ -0,0 +1,23 @@
+This patch follows proposed fixes to upstream.
+
+PR-1: https://github.com/onqtam/doctest/pull/505
+PR-2: https://github.com/onqtam/doctest/pull/520
+
+
+diff --git a/examples/all_features/stringification.cpp b/examples/all_features/stringification.cpp
+index a8b5d5b..492e1ec 100644
+--- a/examples/all_features/stringification.cpp
++++ b/examples/all_features/stringification.cpp
+@@ -103,9 +103,6 @@ TEST_CASE("all asserts should fail and show how the objects get stringified") {
+ MyTypeInherited<int> bla1;
+ bla1.one = 5;
+ bla1.two = 4u;
+- MyTypeInherited<int> bla2;
+- bla2.one = 5;
+- bla2.two = 6u;
+
+ Bar::Foo f1;
+ Bar::Foo f2;
+--
+2.32.0
+