summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-05-20 17:31:06 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-05-20 17:31:06 +0200
commitc35c252161000ec2d126fa978de939252665af65 (patch)
tree620784355b6b5a944b061b450102851da6458a2c
parentdev-util/ninja: update live ebuild (diff)
downloadgentoo-c35c2521.tar.gz
gentoo-c35c2521.tar.bz2
gentoo-c35c2521.zip
dev-lua/luarocks: drop 3.8.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-lua/luarocks/Manifest1
-rw-r--r--dev-lua/luarocks/luarocks-3.8.0.ebuild86
2 files changed, 0 insertions, 87 deletions
diff --git a/dev-lua/luarocks/Manifest b/dev-lua/luarocks/Manifest
index c2519d211a2e..2c52ea13e7ff 100644
--- a/dev-lua/luarocks/Manifest
+++ b/dev-lua/luarocks/Manifest
@@ -1,2 +1 @@
-DIST luarocks-3.8.0.tar.gz 249787 BLAKE2B 2bfff5af400abfdf17a0eacd1f29838dd77751f2ba085d6c6fc18dfc971ea796523781ff2488566d42c01d005bd5037171bf1aabbfdd664746c55674e3ca32c7 SHA512 6c30884c60da57706228a9870f510a1bce435b2d5d67c63c5f2958b152c7a2b334bd74a016995871e3b05b98374f4c4e008993ede81f9fc564980e183bdf06b2
DIST luarocks-3.9.0.tar.gz 252777 BLAKE2B fba01692057ea5f4a926db4b31d4a299238079af1dfd15078cbff6d3d17d1b87f9f30db8477b1b706ec4602fe9ef82533ad3cc58f8059fe84490b464da0b3c15 SHA512 ccdee2ff14f52428923d5148f3d86d2ad40f84685988a12419c191c73a4df6cfacb0defbea40556493645619fdbef807e198fbae85be69c4075b5212353c1f2d
diff --git a/dev-lua/luarocks/luarocks-3.8.0.ebuild b/dev-lua/luarocks/luarocks-3.8.0.ebuild
deleted file mode 100644
index 00f5e2767e8f..000000000000
--- a/dev-lua/luarocks/luarocks-3.8.0.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua-single
-
-DESCRIPTION="A package manager for the Lua programming language"
-HOMEPAGE="https://luarocks.org"
-SRC_URI="https://luarocks.org/releases/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-RESTRICT="test"
-
-RDEPEND="${LUA_DEPS}"
-
-DEPEND="
- net-misc/curl
- dev-libs/openssl:0
- ${RDEPEND}
-"
-
-BDEPEND="
- virtual/pkgconfig
- test? (
- $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]')
- $(lua_gen_cond_dep 'dev-lua/busted-htest[${LUA_USEDEP}]')
- ${RDEPEND}
- )
-"
-
-src_prepare() {
- default
-
- # If 'dev-lang/lua' is a new, fresh installation, no 'LUA_LIBDIR' exists,
- # as no compiled modules are installed on a new, fresh installation,
- # so this check must be disabled, otherwise 'configure' will fail.
- sed -e '/LUA_LIBDIR is not a valid directory/d' -i configure || die
-}
-
-src_configure() {
- local myeconfargs=(
- "--prefix=${EPREFIX}/usr"
- "--rocks-tree=$(lua_get_lmod_dir)"
- "--with-lua-include=$(lua_get_include_dir)"
- "--with-lua-interpreter=${ELUA}"
- "--with-lua-lib=$(lua_get_cmod_dir)"
- )
-
- # Since the configure script is handcrafted,
- # and yells at unknown options, do not use 'econf'.
- ./configure "${myeconfargs[@]}" || die
-}
-
-src_test() {
- busted --lua=${ELUA} || die
-}
-
-src_install() {
- default
-
- { find "${D}" -type f -exec sed -i -e "s:${D}::g" {} \;; } || die
-}
-
-pkg_postinst() {
- local lua_abi_ver
- if use lua_single_target_luajit; then
- lua_abi_ver="5.1"
- else
- lua_abi_ver=${ELUA#lua}
- fi
- elog
- elog "To manage rocks for a Lua version other than the current ${CATEGORY}/${PN} default (${lua_abi_ver})"
- elog "you can use the command-line option --lua-version, e.g."
- elog
- elog " luarocks --lua-version 5.3 install luasocket"
- elog
- elog "(use 5.1 for luajit). Note that the relevant Lua version must already be present in the system."
- elog
-}