summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2020-06-01 14:18:24 +0800
committerYixun Lan <dlan@gentoo.org>2020-06-01 14:53:00 +0800
commitc35ea4afaa0d50c5adb1e66c2501c83d629c0a21 (patch)
treee1ed80af2b85f8cf638f5f893d90bd27a65c7751
parentsys-cluster/ceph: re-add ~ppc64 keyword to ceph-15, bug #715962 (diff)
downloadgentoo-c35ea4af.tar.gz
gentoo-c35ea4af.tar.bz2
gentoo-c35ea4af.zip
app-backup/snapper: version bump, 0.8.9
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--app-backup/snapper/Manifest1
-rw-r--r--app-backup/snapper/snapper-0.8.9.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-backup/snapper/Manifest b/app-backup/snapper/Manifest
index 6758ce8752e1..3162b303dc6b 100644
--- a/app-backup/snapper/Manifest
+++ b/app-backup/snapper/Manifest
@@ -1,3 +1,4 @@
DIST snapper-0.5.6.tar.bz2 580047 BLAKE2B 3b945acbf734db1925dad5515323a64a2c08ee8226a593025f9160e0d1b1140734b2b498d036256946159900b50fec8567147dc0a974c281be747e977bcbd05b SHA512 392427d097cbe221bf7ca0ae20bc065dffaa4d0017ed750c41748d71128fc7ce054bb4425d6dbed7308a530df71815f80f56e60d72aab17ef3e0a16f3b3ba47e
DIST snapper-0.8.6.tar.bz2 607016 BLAKE2B 3e496fa22b1ecce2079d79caeb530ca1538febcc6bdf04aa0256e5b43bb546ea66436e60eeaae6722bc869c60579bc47c556671c5878dd671c266102516f04bb SHA512 f01a309a8dcfff455bf480ff297108e8ec3603d469d50f08740176e22bc2b8dd211de678fa8ce12c1ccd828348a35c6d347ca51b829d7b8c30b3fbaba4e9e2d9
DIST snapper-0.8.7.tar.bz2 622381 BLAKE2B 82d1a9c91beb309e87acfa914b55b2ff5900edc023a5ecd6f2bee6b1a15adb1336656f3f1fffea4a9971aa449b7825750e6c680806d4574faada5bba0a6d14f1 SHA512 6fa63c2453f93a724f0ac23d84ff2c5aafc654463e84a4f767bb8a75a0d4fb7ca7314811179d5fefddddce0df4441298c67b473596aa720d86eeefa43011b727
+DIST snapper-0.8.9.tar.gz 373192 BLAKE2B 55c927136518e91b45631f3087fce13e8e08228274ef7c54164a7024e382a45bfa5b40687fd5e3d770fc87019d8e93af5c681013a023cd89dcb1f16863a77421 SHA512 5a3e45839cd4b5e621425df2e1214ca5014a391d17b489fdf7d315e8ac9959741c1f6fcf7adf644276ed11488bc0f88fcfa563198bd78824867d267df204659d
diff --git a/app-backup/snapper/snapper-0.8.9.ebuild b/app-backup/snapper/snapper-0.8.9.ebuild
new file mode 100644
index 000000000000..9b77e973fc03
--- /dev/null
+++ b/app-backup/snapper/snapper-0.8.9.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd bash-completion-r1
+
+DESCRIPTION="Command-line program for btrfs and lvm snapshot management"
+HOMEPAGE="http://snapper.io/"
+SRC_URI="https://github.com/openSUSE/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lvm pam xattr"
+
+RDEPEND="dev-libs/boost:=[threads]
+ dev-libs/libxml2
+ dev-libs/icu:=
+ sys-apps/acl
+ sys-apps/dbus
+ sys-apps/util-linux
+ >=sys-fs/btrfs-progs-3.17.1
+ sys-libs/zlib
+ virtual/libintl
+ lvm? ( sys-fs/lvm2 )
+ pam? ( sys-libs/pam )
+ xattr? ( sys-apps/attr )"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/cron-confd.patch
+)
+
+src_prepare() {
+ default
+
+ sed -e "s,/usr/lib/systemd/system,$(systemd_get_systemunitdir),g" \
+ -i data/Makefile.* \
+ || die "Failed to fix systemd services and timers installation path"
+ eautoreconf
+}
+
+src_configure() {
+ # ext4 code does not work anymore
+ # snapper does not build without btrfs
+ local myeconfargs=(
+ --with-conf="/etc/conf.d"
+ --disable-zypp
+ --enable-rollback
+ --disable-ext4
+ --enable-btrfs
+ $(use_enable lvm)
+ $(use_enable pam)
+ $(use_enable xattr xattrs)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ # Existing configuration file required to function
+ keepdir /etc/snapper/configs
+ newconfd data/sysconfig.snapper snapper
+ find "${D}" -name '*.la' -delete || die
+ newbashcomp "${FILESDIR}"/${PN}.bash ${PN}
+}
+
+pkg_postinst() {
+ elog "In order to use Snapper, you need to set up"
+ elog "at least one config first. To do this, run:"
+ elog "snapper create-config <subvolume>"
+ elog "For more information, see man (8) snapper or"
+ elog "http://snapper.io/documentation.html"
+}