summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-17 14:24:05 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-17 15:39:31 +0200
commitc3649af65035e57b9fc5c31ab88a1e51b7ebc5ff (patch)
tree78c4a4d314857d429107861767acbc19d0c2b244
parentapp-emacs/cider: drop old 1.8.0 (diff)
downloadgentoo-c3649af65035e57b9fc5c31ab88a1e51b7ebc5ff.tar.gz
gentoo-c3649af65035e57b9fc5c31ab88a1e51b7ebc5ff.tar.bz2
gentoo-c3649af65035e57b9fc5c31ab88a1e51b7ebc5ff.zip
dev-lang/algol68g: bump to 3.4.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-lang/algol68g/Manifest1
-rw-r--r--dev-lang/algol68g/algol68g-3.4.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-lang/algol68g/Manifest b/dev-lang/algol68g/Manifest
index c47176a7dc76..d5f54cd6f27d 100644
--- a/dev-lang/algol68g/Manifest
+++ b/dev-lang/algol68g/Manifest
@@ -1,2 +1,3 @@
DIST algol68g-3.3.24.tar.gz 660171 BLAKE2B b70e568c48d4a4f1b142de97c7eaf4a52237e4bd74469318dbfa5bfdd3510f1770aaf4def2a95fe984dfa183206b70646ea0f3cd41486b64ab435ebaa4f70693 SHA512 e6d4baec87bdfc853ee6c17c80b121ce90d90409344bf55243a339e68b4bc79bcaf8cad56ca6e5eedc7742e445550c4eb6673e74352bf446a39b3ce1712de857
DIST algol68g-3.4.1.tar.gz 661315 BLAKE2B ef0230e8223123b7599278ef759cc814f9dda16c9655a4bde88797ea8847a81b36cf44f1db2c5be04c465ae82dacd6cadf5c715eaeb7d13500ece16ace569734 SHA512 3de8e5745923af6375ec15e87d8189394f1fbeeabdef4768bd968aa40aa07e91fa49eb358c280d2114f0a5ee3e756749bab9304165f70d702da1c75338343bc6
+DIST algol68g-3.4.2.tar.gz 661224 BLAKE2B 1f07ff0aa1734755886d03ea4c0e6116303db72d27956a6d2d816e146b84db26b406b684c2166d6ebfc48f08399c7f54399b6f139f73fb2f3177780dc322d711 SHA512 1c3924ea9bd752cf754dfe188dc57c8ef4433180d88543dd5559203fdcda8dd4aec3528fe952ce64d2c0665065ff44dc7fa205a1a74d0269cfa9176efd8f6f8e
diff --git a/dev-lang/algol68g/algol68g-3.4.2.ebuild b/dev-lang/algol68g/algol68g-3.4.2.ebuild
new file mode 100644
index 000000000000..f1c0cc53d018
--- /dev/null
+++ b/dev-lang/algol68g/algol68g-3.4.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Algol 68 Genie compiler-interpreter"
+HOMEPAGE="https://jmvdveer.home.xs4all.nl/en.algol-68-genie.html"
+SRC_URI="https://jmvdveer.home.xs4all.nl/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+curl +gsl +mpfr +ncurses plotutils postgres +readline"
+
+RDEPEND="
+ curl? ( net-misc/curl )
+ gsl? ( sci-libs/gsl:= )
+ mpfr? ( dev-libs/mpfr:= )
+ plotutils? ( media-libs/plotutils )
+ postgres? ( dev-db/postgresql:* )
+ readline? ( sys-libs/readline:= )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-3.3.21-configure-implicit.patch" )
+
+src_configure() {
+ local -a myconf=(
+ $(use_enable curl)
+ $(use_enable gsl)
+ $(use_enable mpfr)
+ $(use_enable ncurses curses)
+ $(use_enable plotutils)
+ $(use_enable postgres postgresql)
+ $(use_enable readline)
+ $(use_with ncurses)
+ )
+ econf "${myconf[@]}"
+}